diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-08-02 11:01:05 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 59d36c9832702989bfcca8a5af29fb2dff01efcc (patch) | |
tree | b2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-graphics/wayland | |
parent | 72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff) | |
download | meta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz |
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/wayland')
-rw-r--r-- | recipes-graphics/wayland/wayland-protocols_1.20.imx.bb | 2 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston-init.bbappend | 26 | ||||
-rw-r--r-- | recipes-graphics/wayland/weston_9.0.0.imx.bb | 48 |
3 files changed, 38 insertions, 38 deletions
diff --git a/recipes-graphics/wayland/wayland-protocols_1.20.imx.bb b/recipes-graphics/wayland/wayland-protocols_1.20.imx.bb index 852b3160..0d1f4726 100644 --- a/recipes-graphics/wayland/wayland-protocols_1.20.imx.bb +++ b/recipes-graphics/wayland/wayland-protocols_1.20.imx.bb | |||
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git" | |||
16 | inherit autotools pkgconfig | 16 | inherit autotools pkgconfig |
17 | 17 | ||
18 | PACKAGES = "${PN}" | 18 | PACKAGES = "${PN}" |
19 | FILES_${PN} += "${datadir}/pkgconfig/wayland-protocols.pc" | 19 | FILES:${PN} += "${datadir}/pkgconfig/wayland-protocols.pc" |
20 | 20 | ||
21 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 21 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
22 | COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)" | 22 | COMPATIBLE_MACHINE = "(imxfbdev|imxgpu)" |
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend index ebd98268..e6baac0b 100644 --- a/recipes-graphics/wayland/weston-init.bbappend +++ b/recipes-graphics/wayland/weston-init.bbappend | |||
@@ -1,24 +1,24 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | # OpenGL is not required for parts with GPU support for 2D but not 3D | 3 | # OpenGL is not required for parts with GPU support for 2D but not 3D |
4 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE = "" | 4 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE = "" |
5 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu2d = "opengl" | 5 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu2d = "opengl" |
6 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = "" | 6 | IMX_REQUIRED_DISTRO_FEATURES_REMOVE:imxgpu3d = "" |
7 | REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}" | 7 | REQUIRED_DISTRO_FEATURES:remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}" |
8 | 8 | ||
9 | SRC_URI_append_mx6sl = " file://weston.config" | 9 | SRC_URI:append:mx6sl = " file://weston.config" |
10 | 10 | ||
11 | # To customize weston.ini, start by setting the desired assignment in weston.ini, | 11 | # To customize weston.ini, start by setting the desired assignment in weston.ini, |
12 | # commented out. For example: | 12 | # commented out. For example: |
13 | # #xwayland=true | 13 | # #xwayland=true |
14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. | 14 | # Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. |
15 | INI_UNCOMMENT_ASSIGNMENTS_append_imx = " \ | 15 | INI_UNCOMMENT_ASSIGNMENTS:append_imx = " \ |
16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ | 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \ |
17 | " | 17 | " |
18 | INI_UNCOMMENT_ASSIGNMENTS_append_mx8 = " \ | 18 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8 = " \ |
19 | repaint-window=16 \ | 19 | repaint-window=16 \ |
20 | " | 20 | " |
21 | INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \ | 21 | INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq = " \ |
22 | gbm-format=argb8888 \ | 22 | gbm-format=argb8888 \ |
23 | \\[shell\\] \ | 23 | \\[shell\\] \ |
24 | size=1920x1080 \ | 24 | size=1920x1080 \ |
@@ -27,10 +27,10 @@ INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \ | |||
27 | # FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it | 27 | # FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it |
28 | # Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest | 28 | # Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest |
29 | # rendering code. | 29 | # rendering code. |
30 | INI_UNCOMMENT_USE_G2D_imxgpu2d ?= "use-g2d=1" | 30 | INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1" |
31 | INI_UNCOMMENT_USE_G2D_mx8qm = "" | 31 | INI_UNCOMMENT_USE_G2D:mx8qm = "" |
32 | INI_UNCOMMENT_USE_G2D_mx8qxp = "" | 32 | INI_UNCOMMENT_USE_G2D:mx8qxp = "" |
33 | INI_UNCOMMENT_ASSIGNMENTS_append_imxgpu2d = " \ | 33 | INI_UNCOMMENT_ASSIGNMENTS:append:imxgpu2d = " \ |
34 | ${INI_UNCOMMENT_USE_G2D} \ | 34 | ${INI_UNCOMMENT_USE_G2D} \ |
35 | " | 35 | " |
36 | 36 | ||
@@ -41,7 +41,7 @@ uncomment() { | |||
41 | sed -i -e 's,^#'"$1"','"$1"',g' $2 | 41 | sed -i -e 's,^#'"$1"','"$1"',g' $2 |
42 | } | 42 | } |
43 | 43 | ||
44 | do_install_append() { | 44 | do_install:append() { |
45 | if [ -f "${WORKDIR}/weston.config" ]; then | 45 | if [ -f "${WORKDIR}/weston.config" ]; then |
46 | install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston | 46 | install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston |
47 | fi | 47 | fi |
diff --git a/recipes-graphics/wayland/weston_9.0.0.imx.bb b/recipes-graphics/wayland/weston_9.0.0.imx.bb index 026f27ce..76296c8e 100644 --- a/recipes-graphics/wayland/weston_9.0.0.imx.bb +++ b/recipes-graphics/wayland/weston_9.0.0.imx.bb | |||
@@ -20,7 +20,7 @@ SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | |||
20 | file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ | 20 | file://0001-tests-include-fcntl.h-for-open-O_RDWR-O_CLOEXEC-and-.patch \ |
21 | " | 21 | " |
22 | 22 | ||
23 | SRC_URI_append_libc-musl = " file://dont-use-plane-add-prop.patch " | 23 | SRC_URI:append:libc-musl = " file://dont-use-plane-add-prop.patch " |
24 | 24 | ||
25 | SRC_URI[sha256sum] = "5cf5d6ce192e0eb15c1fc861a436bf21b5bb3b91dbdabbdebe83e1f83aa098fe" | 25 | SRC_URI[sha256sum] = "5cf5d6ce192e0eb15c1fc861a436bf21b5bb3b91dbdabbdebe83e1f83aa098fe" |
26 | 26 | ||
@@ -97,7 +97,7 @@ PACKAGECONFIG[shell-ivi] = "-Dshell-ivi=true,-Dshell-ivi=false" | |||
97 | # JPEG image loading support | 97 | # JPEG image loading support |
98 | PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg" | 98 | PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg" |
99 | 99 | ||
100 | do_install_append() { | 100 | do_install:append() { |
101 | # Weston doesn't need the .la files to load modules, so wipe them | 101 | # Weston doesn't need the .la files to load modules, so wipe them |
102 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la | 102 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la |
103 | 103 | ||
@@ -122,23 +122,23 @@ do_install_append() { | |||
122 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ | 122 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ |
123 | libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" | 123 | libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" |
124 | 124 | ||
125 | FILES_${PN}-dev += "${libdir}/${BPN}/libexec_weston.so" | 125 | FILES:${PN}-dev += "${libdir}/${BPN}/libexec_weston.so" |
126 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}" | 126 | FILES:${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}" |
127 | 127 | ||
128 | FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" | 128 | FILES:libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" |
129 | SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." | 129 | SUMMARY:libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." |
130 | 130 | ||
131 | FILES_${PN}-examples = "${bindir}/*" | 131 | FILES:${PN}-examples = "${bindir}/*" |
132 | 132 | ||
133 | FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" | 133 | FILES:${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" |
134 | RDEPENDS_${PN}-xwayland += "xwayland" | 134 | RDEPENDS:${PN}-xwayland += "xwayland" |
135 | 135 | ||
136 | RDEPENDS_${PN} += "xkeyboard-config" | 136 | RDEPENDS:${PN} += "xkeyboard-config" |
137 | RRECOMMENDS_${PN} = "weston-init liberation-fonts" | 137 | RRECOMMENDS:${PN} = "weston-init liberation-fonts" |
138 | RRECOMMENDS_${PN}-dev += "wayland-protocols" | 138 | RRECOMMENDS:${PN}-dev += "wayland-protocols" |
139 | 139 | ||
140 | USERADD_PACKAGES = "${PN}" | 140 | USERADD_PACKAGES = "${PN}" |
141 | GROUPADD_PARAM_${PN} = "--system weston-launch" | 141 | GROUPADD_PARAM:${PN} = "--system weston-launch" |
142 | 142 | ||
143 | ########### End of OE-core copy ########### | 143 | ########### End of OE-core copy ########### |
144 | 144 | ||
@@ -160,23 +160,23 @@ S = "${WORKDIR}/git" | |||
160 | 160 | ||
161 | # Disable OpenGL for parts with GPU support for 2D but not 3D | 161 | # Disable OpenGL for parts with GPU support for 2D but not 3D |
162 | REQUIRED_DISTRO_FEATURES = "opengl" | 162 | REQUIRED_DISTRO_FEATURES = "opengl" |
163 | REQUIRED_DISTRO_FEATURES_imxgpu2d = "" | 163 | REQUIRED_DISTRO_FEATURES:imxgpu2d = "" |
164 | REQUIRED_DISTRO_FEATURES_imxgpu3d = "opengl" | 164 | REQUIRED_DISTRO_FEATURES:imxgpu3d = "opengl" |
165 | PACKAGECONFIG_OPENGL = "opengl" | 165 | PACKAGECONFIG_OPENGL = "opengl" |
166 | PACKAGECONFIG_OPENGL_imxgpu2d = "" | 166 | PACKAGECONFIG_OPENGL:imxgpu2d = "" |
167 | PACKAGECONFIG_OPENGL_imxgpu3d = "opengl" | 167 | PACKAGECONFIG_OPENGL:imxgpu3d = "opengl" |
168 | 168 | ||
169 | PACKAGECONFIG_remove = "wayland x11" | 169 | PACKAGECONFIG:remove = "wayland x11" |
170 | PACKAGECONFIG_append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" | 170 | PACKAGECONFIG:append = " ${@bb.utils.filter('DISTRO_FEATURES', '${PACKAGECONFIG_OPENGL}', d)}" |
171 | 171 | ||
172 | PACKAGECONFIG_remove_imxfbdev = "kms" | 172 | PACKAGECONFIG:remove:imxfbdev = "kms" |
173 | PACKAGECONFIG_append_imxfbdev = " fbdev clients" | 173 | PACKAGECONFIG:append:imxfbdev = " fbdev clients" |
174 | PACKAGECONFIG_append_imxgpu = " imxgpu" | 174 | PACKAGECONFIG:append:imxgpu = " imxgpu" |
175 | PACKAGECONFIG_append_imxgpu2d = " imxg2d" | 175 | PACKAGECONFIG:append:imxgpu2d = " imxg2d" |
176 | 176 | ||
177 | # Clients support | 177 | # Clients support |
178 | SIMPLE_CLIENTS = "all" | 178 | SIMPLE_CLIENTS = "all" |
179 | SIMPLE_CLIENTS_imxfbdev = "damage,im,egl,shm,touch,dmabuf-v4l" | 179 | SIMPLE_CLIENTS:imxfbdev = "damage,im,egl,shm,touch,dmabuf-v4l" |
180 | PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcursor" | 180 | PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcursor" |
181 | PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLE_CLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false" | 181 | PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLE_CLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false" |
182 | # Weston with i.MX GPU support | 182 | # Weston with i.MX GPU support |