diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-24 10:45:10 -0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-27 13:31:28 -0200 |
commit | 97c8bce5c32ad5b62376c40b1227839771171a53 (patch) | |
tree | 99cdedfbef328270320322773d751efb31e6264a /recipes-graphics/mesa | |
parent | 6080fc1100fedf12aa61a3d0740e0a93cb817fcc (diff) | |
download | meta-freescale-97c8bce5c32ad5b62376c40b1227839771171a53.tar.gz |
mesa: Rework recipe to use the feature overrides
The recipe was still using the mx6 specific overrides, which is
wrong. We should use the feature overrides so more SoCs can be dealt
in the generic way.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 19 |
1 files changed, 7 insertions, 12 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 8f5aa751..3005fd73 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -1,15 +1,12 @@ | |||
1 | PACKAGECONFIG_remove_mx6 = "egl gles" | 1 | PACKAGECONFIG_remove_imxgpu2d = "egl gles" |
2 | 2 | ||
3 | PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" | 3 | PROVIDES_remove_imxgpu2d = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" |
4 | PROVIDES_remove_imxgpu3d = "virtual/libgl" | 4 | PROVIDES_remove_imxgpu3d = "virtual/libgl" |
5 | 5 | ||
6 | USE_VIV_LIBGL = "yes" | ||
7 | USE_VIV_LIBGL_mx6sl = "no" | ||
8 | |||
9 | # FIXME: mesa should support 'x11-no-tls' option | 6 | # FIXME: mesa should support 'x11-no-tls' option |
10 | python () { | 7 | python () { |
11 | overrides = d.getVar("OVERRIDES", True).split(":") | 8 | overrides = d.getVar("OVERRIDES", True).split(":") |
12 | if "mx6" not in overrides: | 9 | if "imxgpu2d" not in overrides: |
13 | return | 10 | return |
14 | 11 | ||
15 | extra_oeconf = d.getVar("EXTRA_OECONF", True) | 12 | extra_oeconf = d.getVar("EXTRA_OECONF", True) |
@@ -18,10 +15,8 @@ python () { | |||
18 | } | 15 | } |
19 | 16 | ||
20 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 17 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
21 | do_install_append_mx6 () { | 18 | do_install_append_imxgpu3d () { |
22 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then | 19 | rm -f ${D}${libdir}/libGL.* \ |
23 | rm -f ${D}${libdir}/libGL.* \ | 20 | ${D}${includedir}/GL/gl.h \ |
24 | ${D}${includedir}/GL/gl.h \ | 21 | ${D}${includedir}/GL/glext.h |
25 | ${D}${includedir}/GL/glext.h | ||
26 | fi | ||
27 | } | 22 | } |