diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-09-02 16:49:45 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:19 -0300 |
commit | 0151cf31a1778667503b8d727a9313ed4bf0bee4 (patch) | |
tree | 572036222332746c06c4f7d799eab9687c22b8e4 /recipes-graphics/mesa | |
parent | 574898eb75e55aaaf87157e4ca12e81cbc85cd81 (diff) | |
download | meta-freescale-0151cf31a1778667503b8d727a9313ed4bf0bee4.tar.gz |
Rework i.MX6 UltraLite support to not use other i.MX6 code
The i.MX6 UltraLite is very different from the other i.MX6 SoCs and
the current BSP infrastructure needs to be reworked to allow for more
granullar control of the features each SoC provide to control the
changes to be applied for the SoC peripherals support.
For now, it is not possible to express this clearly in the BSP so the
current change is to revert some of the changes done for the i.MX6
UltraLite to be enabled and make sure that the boards using the SoC
does not inherit the 'mx6' override.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r-- | recipes-graphics/mesa/mesa-demos_%.bbappend | 20 | ||||
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 21 |
2 files changed, 12 insertions, 29 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend index cc245b22..1f070a44 100644 --- a/recipes-graphics/mesa/mesa-demos_%.bbappend +++ b/recipes-graphics/mesa/mesa-demos_%.bbappend | |||
@@ -1,24 +1,14 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | MESA-DEMO-PATCH = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ | 3 | SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \ |
4 | file://fix-clear-build-break.patch \ | 4 | file://fix-clear-build-break.patch \ |
5 | file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ | 5 | file://Additional-eglSwapBuffer-calling-makes-wrong-throttl.patch \ |
6 | file://Add-OpenVG-demos-to-support-wayland.patch" | 6 | file://Add-OpenVG-demos-to-support-wayland.patch" |
7 | 7 | ||
8 | # only apply patches on mx6 that have a GPU | 8 | PACKAGECONFIG_remove_mx6 = " \ |
9 | SRC_URI_append_mx6q = " ${MESA-DEMO-PATCH}" | 9 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
10 | SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}" | 10 | bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}" |
11 | SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" | 11 | PACKAGECONFIG_remove_mx6sl = "gles1 gles2" |
12 | SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}" | ||
13 | |||
14 | REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | ||
15 | bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}" | ||
16 | |||
17 | # only remove GLU on mx6 thave have a GPU | ||
18 | PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}" | ||
19 | PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}" | ||
20 | PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}" | ||
21 | PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}" | ||
22 | 12 | ||
23 | PACKAGECONFIG_append = "\ | 13 | PACKAGECONFIG_append = "\ |
24 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ | 14 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 66913e17..2536afd6 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -1,19 +1,12 @@ | |||
1 | PACKAGECONFIG_remove_mx6q = "egl gles" | 1 | PACKAGECONFIG_remove_mx6 = "egl gles" |
2 | PACKAGECONFIG_remove_mx6dl = "egl gles" | ||
3 | PACKAGECONFIG_remove_mx6sx = "egl gles" | ||
4 | PACKAGECONFIG_remove_mx6sl = "egl gles" | ||
5 | 2 | ||
6 | # i.MX6SL uses mesa software rendering | 3 | PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" |
4 | PROVIDES_remove_mx6q = "virtual/libgl" | ||
5 | PROVIDES_remove_mx6dl = "virtual/libgl" | ||
6 | PROVIDES_remove_mx6sx = "virtual/libgl" | ||
7 | 7 | ||
8 | PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | 8 | USE_VIV_LIBGL = "yes" |
9 | PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | 9 | USE_VIV_LIBGL_mx6sl = "no" |
10 | PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl virtual/libgl" | ||
11 | PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/libopenvg virtual/egl" | ||
12 | |||
13 | USE_VIV_LIBGL = "no" | ||
14 | USE_VIV_LIBGL_mx6q = "yes" | ||
15 | USE_VIV_LIBGL_mx6dl = "yes" | ||
16 | USE_VIV_LIBGL_mx6sx = "yes" | ||
17 | 10 | ||
18 | # FIXME: mesa should support 'x11-no-tls' option | 11 | # FIXME: mesa should support 'x11-no-tls' option |
19 | python () { | 12 | python () { |