diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-20 19:30:38 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:13 -0300 |
commit | 614ee7f1c907aeabe37f500431a3491f7132a1bc (patch) | |
tree | 7ef0a3222327c5e69307a2cc1ae42f79b1f5b61a /recipes-graphics/mesa | |
parent | f54d95fb9b2e539447240a047f5839561202caa2 (diff) | |
download | meta-freescale-614ee7f1c907aeabe37f500431a3491f7132a1bc.tar.gz |
mesa: Avoid Vivante GPU headers conflict for gl.h and glext.h
The new GPU release include new GL headers which conflict with the
ones provided by mesa. The build fails with:
,----
| ERROR: The recipe imx-gpu-viv is trying to install files into a shared
| area when those files already exist. Those files and their manifest
| location are:
|
| .../build-framebuffer/tmp/sysroots/imx6qsabresd/usr/include/GL/gl.h
| Matched in manifest-imx6qsabresd-mesa.populate_sysroot
|
| .../build-framebuffer/tmp/sysroots/imx6qsabresd/usr/include/GL/glext.h
| Matched in manifest-imx6qsabresd-mesa.populate_sysroot
`----
This removes of the mesa's headers so the ones provided by Vivante are
used instead.
Fixes [Yocto: #5098].
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/mesa')
-rw-r--r-- | recipes-graphics/mesa/mesa_%.bbappend | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend index 6cc7de70..5030e7a3 100644 --- a/recipes-graphics/mesa/mesa_%.bbappend +++ b/recipes-graphics/mesa/mesa_%.bbappend | |||
@@ -21,7 +21,9 @@ USE_VIV_LIBGL_mx6sx = "yes" | |||
21 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary | 21 | # FIXME: Dirty hack to allow use of Vivante GPU libGL binary |
22 | do_install_append_mx6 () { | 22 | do_install_append_mx6 () { |
23 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then | 23 | if [ "${USE_VIV_LIBGL}" = "yes" ]; then |
24 | rm -f ${D}${libdir}/libGL.* | 24 | rm -f ${D}${libdir}/libGL.* \ |
25 | ${D}${includedir}/GL/gl.h \ | ||
26 | ${D}${includedir}/GL/glext.h | ||
25 | fi | 27 | fi |
26 | } | 28 | } |
27 | EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}" | 29 | EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}" |