summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-31 21:56:42 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:42:37 -0300
commitaf181163fec5ca859c6a3989c9ea8cd1ceb27449 (patch)
tree8521059aa06509f27d125c678b0037bbfd25e596 /recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch
parent0661394cdfef69afd454ea515eb9a395afda44fb (diff)
downloadmeta-freescale-af181163fec5ca859c6a3989c9ea8cd1ceb27449.tar.gz
imx-gpu-apitrace: fix the upgrade after rebase to 9.0.0
Bump the repository version as it was updated upstream in NXP repository and drop unused patches from the layer, they should be present now in the updated version from upstream. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch')
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch169
1 files changed, 0 insertions, 169 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch
deleted file mode 100644
index 25141602..00000000
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace/0002-specs-Tie-Python-2-3-conversion-loose-ends.patch
+++ /dev/null
@@ -1,169 +0,0 @@
1From a8791e3dca61500a382be84dc96973639b8bd182 Mon Sep 17 00:00:00 2001
2From: Jose Fonseca <jfonseca@vmware.com>
3Date: Sun, 28 Apr 2019 14:13:01 +0100
4Subject: [PATCH 2/4] specs: Tie Python 2 ->3 conversion loose ends.
5
6Upstream-Status: Backport [https://github.com/apitrace/apitrace/commit/5b3c68cafaddc82c0f34bea8127582eee07ac3be]
7
8(cherry picked from commit 5b3c68cafaddc82c0f34bea8127582eee07ac3be)
9Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
10---
11 specs/scripts/Makefile | 16 ++++++++--------
12 specs/scripts/c2api.py | 6 +++---
13 specs/scripts/cxx2api.py | 2 +-
14 specs/scripts/spec2api.py | 2 +-
15 specs/scripts/txt2api.py | 8 +++++---
16 specs/scripts/xml2api.py | 2 +-
17 specs/scripts/xml2enum.py | 2 +-
18 specs/scripts/xml2glparams.py | 2 +-
19 8 files changed, 21 insertions(+), 19 deletions(-)
20
21diff --git a/specs/scripts/Makefile b/specs/scripts/Makefile
22index 714a3deb..f03f36eb 100644
23--- a/specs/scripts/Makefile
24+++ b/specs/scripts/Makefile
25@@ -37,28 +37,28 @@ download: \
26 wget -N https://www.opengl.org/registry/oldspecs/$@
27
28 glapi.py: xml2api.py gl.xml
29- python $^ > $@
30+ python3 $^ > $@
31
32 glxapi.py: xml2api.py glx.xml
33- python $^ > $@
34+ python3 $^ > $@
35
36 wglapi.py: xml2api.py wgl.xml
37- python $^ > $@
38+ python3 $^ > $@
39
40 eglapi.py: xml2api.py egl.xml
41- python $^ > $@
42+ python3 $^ > $@
43
44 glparams.py: xml2glparams.py gl.xml
45- python $^ > $@
46+ python3 $^ > $@
47
48 glxenum.py: xml2enum.py glx.xml
49- python $^ > $@
50+ python3 $^ > $@
51
52 wglenum.py: xml2enum.py wgl.xml
53- python $^ > $@
54+ python3 $^ > $@
55
56 eglenum.py: xml2enum.py egl.xml
57- python $^ > $@
58+ python3 $^ > $@
59
60 clean:
61 rm -f \
62diff --git a/specs/scripts/c2api.py b/specs/scripts/c2api.py
63index b8aaa81d..208169d2 100755
64--- a/specs/scripts/c2api.py
65+++ b/specs/scripts/c2api.py
66@@ -1,4 +1,4 @@
67-#!/usr/bin/env python
68+#!/usr/bin/env python3
69 ##########################################################################
70 #
71 # Copyright 2011 Jose Fonseca
72@@ -404,8 +404,8 @@ class DeclParser:
73 type = 'S' + type
74 elif short:
75 type = 'Short'
76- elif int:
77- type = 'Long' * int
78+ elif long:
79+ type = 'Long' * long
80 else:
81 type = 'Int'
82 if unsigned:
83diff --git a/specs/scripts/cxx2api.py b/specs/scripts/cxx2api.py
84index 9720615d..8056de47 100755
85--- a/specs/scripts/cxx2api.py
86+++ b/specs/scripts/cxx2api.py
87@@ -1,4 +1,4 @@
88-#!/usr/bin/env python
89+#!/usr/bin/env python3
90
91
92
93diff --git a/specs/scripts/spec2api.py b/specs/scripts/spec2api.py
94index 7fb395a4..33a8d058 100755
95--- a/specs/scripts/spec2api.py
96+++ b/specs/scripts/spec2api.py
97@@ -1,4 +1,4 @@
98-#!/usr/bin/env python
99+#!/usr/bin/env python3
100 ##########################################################################
101 #
102 # Copyright 2010 VMware, Inc.
103diff --git a/specs/scripts/txt2api.py b/specs/scripts/txt2api.py
104index e9469d3c..a32ca658 100755
105--- a/specs/scripts/txt2api.py
106+++ b/specs/scripts/txt2api.py
107@@ -1,4 +1,4 @@
108-#!/usr/bin/env python
109+#!/usr/bin/env python3
110 ##########################################################################
111 #
112 # Copyright 2010 VMware, Inc.
113@@ -28,6 +28,7 @@
114 """Parser for OpenGL .txt extensions specification."""
115
116
117+import io
118 import sys
119 import re
120 import optparse
121@@ -233,12 +234,13 @@ def main():
122
123 for arg in args:
124 if arg.startswith('http://') or arg.startswith('https://'):
125- stream = urlopen(arg, 'rt')
126+ stream = urlopen(arg)
127+ stream = io.TextIOWrapper(stream, encoding='ascii')
128 else:
129 stream = open(arg, 'rt')
130 parser = TxtParser(stream, prefix = options.prefix)
131 parser.parse()
132-
133+
134
135 if __name__ == '__main__':
136 main()
137diff --git a/specs/scripts/xml2api.py b/specs/scripts/xml2api.py
138index f09fe0bf..6b4ec3b7 100755
139--- a/specs/scripts/xml2api.py
140+++ b/specs/scripts/xml2api.py
141@@ -1,4 +1,4 @@
142-#!/usr/bin/env python
143+#!/usr/bin/env python3
144 ##########################################################################
145 #
146 # Copyright 2014 VMware, Inc
147diff --git a/specs/scripts/xml2enum.py b/specs/scripts/xml2enum.py
148index cb2c4ae9..f799b7b5 100755
149--- a/specs/scripts/xml2enum.py
150+++ b/specs/scripts/xml2enum.py
151@@ -1,4 +1,4 @@
152-#!/usr/bin/env python
153+#!/usr/bin/env python3
154 ##########################################################################
155 #
156 # Copyright 2014 VMware, Inc
157diff --git a/specs/scripts/xml2glparams.py b/specs/scripts/xml2glparams.py
158index 805aac86..a651d896 100755
159--- a/specs/scripts/xml2glparams.py
160+++ b/specs/scripts/xml2glparams.py
161@@ -1,4 +1,4 @@
162-#!/usr/bin/env python
163+#!/usr/bin/env python3
164 ##########################################################################
165 #
166 # Copyright 2014 VMware, Inc
167--
1682.17.1
169