summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-10 11:10:34 -0300
committerGitHub <noreply@github.com>2022-02-10 11:10:34 -0300
commit217e58294152c828e4d084eef7daa37a2ed223c3 (patch)
tree0bc6912052392938e1faa95d1651fedf6458e09b /recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
parent682f1826e53632fbdc12edc9f1cb47762987e382 (diff)
parent679337c55cdf061099fefde9842815a8e9c407a0 (diff)
downloadmeta-freescale-217e58294152c828e4d084eef7daa37a2ed223c3.tar.gz
Merge pull request #965 from thochstein/master
Update graphics for L5.10.72-2.2.0
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
new file mode 100644
index 00000000..b3f1051a
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6# This package is currently only for GPU-based G2D. Support for DPU-based G2d is coming.
7DEPENDS = "imx-gpu-g2d"
8
9GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
10SRCBRANCH ?= "imx_1.0"
11SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
12SRCREV = "daf64d010666ef2458566573c074e238993f228c"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
20}
21
22FILES:${PN} += "/opt"