summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2023-01-05 11:20:37 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-01-08 18:12:47 +0000
commita49d6a713f1f090d0142ba0cbee5f3aa5a5f0900 (patch)
tree9a58a0cf0823af62041fde39689b77807a1e16ba /recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb
parent557de20696443efe397e7d46a2ba26667edf50e8 (diff)
downloadmeta-freescale-a49d6a713f1f090d0142ba0cbee5f3aa5a5f0900.tar.gz
imx-dpu-g2d: update from 2.1.2 to 2.1.4
- Update to the version used in NXP Yocto branch kirkstone-5.15.71-2.2.0 - Also the binaries seem to be stripped now, so skip that step to avoid build errors Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com> (cherry picked from commit 95c89b6f281d67ef1f1da0c7e1d92b77aed51e86)
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb
new file mode 100644
index 00000000..667bc26b
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.4.bb
@@ -0,0 +1,36 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
8
9DEPENDS = "libgal-imx libdrm"
10PROVIDES += "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
13SRC_URI[md5sum] = "488d9f63b2d02c687a0bc8c3debfb51c"
14SRC_URI[sha256sum] = "62050bc5dd35e942c97e7a8ab22b0b98d02e27a38935b585e622cdc5221ef2a3"
15
16inherit fsl-eula-unpack
17
18do_install () {
19 install -d ${D}${libdir}
20 install -d ${D}${includedir}
21 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
22 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
23}
24
25INSANE_SKIP:${PN} += "ldflags"
26INSANE_SKIP:append:libc-musl = " file-rdeps"
27
28# The packaged binaries have been stripped of debug info, so disable
29# operations accordingly.
30INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
31INHIBIT_PACKAGE_STRIP = "1"
32INHIBIT_SYSROOT_STRIP = "1"
33
34COMPATIBLE_MACHINE = "(imxdpu)"
35
36RDEPENDS:${PN}:append:libc-musl = " gcompat"