summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-dpu-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-06-22 15:17:08 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-26 14:19:09 -0300
commit2bbdc1c9681a84493c77c8ba056d6e66642767a9 (patch)
tree6db206fb7aa54b2c3c8d180af0692e3acb81ed59 /recipes-graphics/imx-dpu-g2d
parent435ff26ea4f44ccfa109e6796cbc86038fbbe107 (diff)
downloadmeta-freescale-2bbdc1c9681a84493c77c8ba056d6e66642767a9.tar.gz
imx-dpu-g2d: Add new G2D implementation based on DPU
Change-Id: Ib3114b9962a2bb89e95da8757870050c1d816abd Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/imx-dpu-g2d')
-rw-r--r--recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb
new file mode 100644
index 00000000..35cdbd5f
--- /dev/null
+++ b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.4.2.bb
@@ -0,0 +1,37 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2018 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D graphics library and apps for i.MX with DRM"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
8
9RDEPENDS_${PN} = "virtual/libgal-x11 libdrm"
10
11PROVIDES += "virtual/libg2d"
12
13SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
14
15S="${WORKDIR}/${PN}-${PV}"
16
17inherit fsl-eula-unpack
18
19SRC_URI[md5sum] = "9beeb2c66f1bad4e82a77487486a31c8"
20SRC_URI[sha256sum] = "905e797d7fb573b5fea616940b07dc15d817fe2f5e94668f883e9faaa516989a"
21
22do_install () {
23
24 install -d ${D}${libdir}
25 install -d ${D}${includedir}
26
27 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
28 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
29 cp -r ${S}/gpu-demos/opt ${D}
30}
31
32INSANE_SKIP_${PN} += "ldflags"
33
34FILES_${PN} = "${libdir}/libg2d* /opt"
35FILES_${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
36
37COMPATIBLE_MACHINE = "(mx8mm)"