summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-08-18 12:05:04 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-08-18 15:13:36 -0500
commit25c0d3f4ff050cad566b14f4484575b5e05a9bb6 (patch)
tree32b1273a6ab2d5daf36e5f86b4458f1c6611f8f8 /recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
parentbcc9e436bd3b705701268512fb152ed3c2fc1abe (diff)
downloadmeta-freescale-25c0d3f4ff050cad566b14f4484575b5e05a9bb6.tar.gz
imx-dpu-g2d: Upgrade to 1.9.2
2043f5e MA-18905 Fix NV12 tiled+interlaced to NV12 Linar output not correct issue. dec91a5 MGS-6047-4 [#ccc] G2d - add support for multiplane destination formats 530834d MGS-6068 [#ccc] [i.MX8QXPC0-MEK@Linux_IMX_5.4.70-2.3.0 Q4 RC1]imxvideoconvert_g2d 6f000cd MA-12001-2 Fix dpu_test build fail on android 3a7b8d4 MA-18242 configure vscale setup factor2 for bob deinterlace e59edc7 MGS-6114 [#ccc] [QNX] - add support for dpu register locking c4784ec MA-12001 Fix Android emulator build error 9fe13fb MGS-6047-3 [#ccc] G2d - add support for multiplane destination formats 43b1eb4 MGS-6047-2 [#ccc] G2d - add support for multiplane destination formats 30f3ece MGS-6047-1 [#ccc] G2d - add support for multiplane destination formats 0dfcf62 MGS-5942 [#ccc] G2D - add support of caching allocated buffers db7e627 MGS-6062 [#ccc] [G2D] YUV rotation is slow Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb')
-rw-r--r--recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
new file mode 100644
index 00000000..e4baefb5
--- /dev/null
+++ b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
8PROVIDES += "virtual/libg2d"
9
10SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "a267c87677d600ecf07d4c8f42941532"
12SRC_URI[sha256sum] = "02e4e649f2af6c867cb666df10f032af48b0907e1529fa6c5958dad7e38aebbe"
13
14inherit fsl-eula-unpack
15
16do_install () {
17 install -d ${D}${libdir}
18 install -d ${D}${includedir}
19 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
20 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
21 cp -r ${S}/gpu-demos/opt ${D}
22}
23
24FILES:${PN} = "${libdir}/libg2d* /opt"
25FILES:${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
26INSANE_SKIP:${PN} += "ldflags"
27
28RDEPENDS:${PN} = "libgal-imx libdrm"
29
30# This is required to provide support for VPU Amphion HEVC tile format
31# From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99):
32# VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx.
33RDEPENDS:${PN} += "libopencl-imx"
34
35COMPATIBLE_MACHINE = "(imxdpu)"