summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-09-11 15:54:34 -0300
committerGitHub <noreply@github.com>2021-09-11 15:54:34 -0300
commit16e0d07d36787d14e9d00ff8123419863d1f19d2 (patch)
tree36a413f5702cd2d29b5023ec0762b71c27e4fac3 /recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
parent25e9cbddbd32802634bafef62ba08da9821c604d (diff)
parentb821d72e7b7fc250eb80fa43a79ce31b88863239 (diff)
downloadmeta-freescale-16e0d07d36787d14e9d00ff8123419863d1f19d2.tar.gz
Merge pull request #859 from angolini/hardknott+bsp
Backport NXP BSP 5.10.35_2.0.0 to Hardknott
Diffstat (limited to 'recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb')
-rw-r--r--recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
new file mode 100644
index 00000000..af96367b
--- /dev/null
+++ b/recipes-graphics/imx-dpu-g2d/imx-dpu-g2d_1.9.2.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=417b82f17fc02b88125331ed312f6f1b"
8PROVIDES += "virtual/libg2d"
9
10SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "a267c87677d600ecf07d4c8f42941532"
12SRC_URI[sha256sum] = "02e4e649f2af6c867cb666df10f032af48b0907e1529fa6c5958dad7e38aebbe"
13
14inherit fsl-eula-unpack
15
16do_install () {
17 install -d ${D}${libdir}
18 install -d ${D}${includedir}
19 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
20 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
21 cp -r ${S}/gpu-demos/opt ${D}
22}
23
24FILES_${PN} = "${libdir}/libg2d* /opt"
25FILES_${PN}-dev = "${libdir}/libg2d${SOLIBSDEV} ${includedir}"
26INSANE_SKIP_${PN} += "ldflags"
27
28RDEPENDS_${PN} = "libgal-imx libdrm"
29
30# This is required to provide support for VPU Amphion HEVC tile format
31# From NXP [MGS-5547] (commit e175d6b4f78deab24d319b852998bef55cdecc99):
32# VPU Amphion HEVC tile support was added using OpenCL, so add a dependency on libopencl-imx.
33RDEPENDS_${PN} += "libopencl-imx"
34
35COMPATIBLE_MACHINE = "(imxdpu)"