diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2017-11-15 15:02:11 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-11-16 11:09:27 -0200 |
commit | 9bb1ce6c4766d501e6770589e6cc20335d311866 (patch) | |
tree | 1491d226fafc3bd0506c9898f72108c50aab47e5 /recipes-graphics/eglinfo | |
parent | 80af5dbe0775cd9540328c8aa1630aa4f4499c29 (diff) | |
download | meta-freescale-9bb1ce6c4766d501e6770589e6cc20335d311866.tar.gz |
eglinfo-fb: Use generic header
Use eglplatform.h rather than vendor-specific eglvivante.h.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/eglinfo')
-rw-r--r-- | recipes-graphics/eglinfo/eglinfo-fb/0001-Replace-vendor-specific-header-with-generic.patch | 28 | ||||
-rw-r--r-- | recipes-graphics/eglinfo/eglinfo-fb_%.bbappend | 6 |
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-graphics/eglinfo/eglinfo-fb/0001-Replace-vendor-specific-header-with-generic.patch b/recipes-graphics/eglinfo/eglinfo-fb/0001-Replace-vendor-specific-header-with-generic.patch new file mode 100644 index 00000000..7c315c83 --- /dev/null +++ b/recipes-graphics/eglinfo/eglinfo-fb/0001-Replace-vendor-specific-header-with-generic.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From fdb3add3dfd53c539c3c79e4fbf9eedb1dc1e440 Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com> | ||
3 | Date: Fri, 26 Feb 2016 11:29:54 -0600 | ||
4 | Subject: [PATCH] Use generic eglplatform.h rather than vendor specifc | ||
5 | (eglvivante.h) EGL headers. | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | --- | ||
10 | wscript | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/wscript b/wscript | ||
14 | index 195e247..d08bc29 100644 | ||
15 | --- a/wscript | ||
16 | +++ b/wscript | ||
17 | @@ -219,7 +219,7 @@ def check_vivante_egl(conf, egl_extra_defines): | ||
18 | extra_defines += egl_extra_defines | ||
19 | extra_cxxflags = map(lambda x: conf.env['DEFINES_ST'] % x, extra_defines) | ||
20 | conf.env['CXXFLAGS'] += extra_cxxflags | ||
21 | - conf.check_cxx(mandatory = 1, header_name = 'EGL/eglvivante.h', uselib_store = 'EGL') | ||
22 | + conf.check_cxx(mandatory = 1, header_name = 'EGL/eglplatform.h', uselib_store = 'EGL') | ||
23 | conf.check_cxx(mandatory = 1, header_name = 'EGL/egl.h', uselib_store = 'EGL') | ||
24 | conf.env['CXXFLAGS_EGL'] += extra_cxxflags | ||
25 | conf.env['CXXFLAGS'] = old_cxxflags | ||
26 | -- | ||
27 | 2.7.0 | ||
28 | |||
diff --git a/recipes-graphics/eglinfo/eglinfo-fb_%.bbappend b/recipes-graphics/eglinfo/eglinfo-fb_%.bbappend index 7aa0e50f..f130d23c 100644 --- a/recipes-graphics/eglinfo/eglinfo-fb_%.bbappend +++ b/recipes-graphics/eglinfo/eglinfo-fb_%.bbappend | |||
@@ -1,2 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI_append_imxgpu3d = " \ | ||
4 | file://0001-Replace-vendor-specific-header-with-generic.patch \ | ||
5 | " | ||
6 | |||
1 | # Set i.MX specific dependencies and device type | 7 | # Set i.MX specific dependencies and device type |
2 | EGLINFO_DEVICE_imxgpu3d = "imx6" | 8 | EGLINFO_DEVICE_imxgpu3d = "imx6" |