diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2021-01-28 12:33:24 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-02-01 11:24:43 -0300 |
commit | a00d108c094c993ef68601efc0bfe3454732ee31 (patch) | |
tree | dccdd4a7387e483226a0ee38ffbb94d5a0c83f3a /recipes-graphics/drm | |
parent | 364acae4d5ebdb52406d2c7a49f1a1ec64a1dea3 (diff) | |
download | meta-freescale-a00d108c094c993ef68601efc0bfe3454732ee31.tar.gz |
libdrm: update to 2.4.102.imx
NXP release imx_5.4.70_2.3.0.
Drop the explicit PACKAGE_ARCH setting. This is done by
fsl-dynamic-packagearch.bbclass.
The musl-ioctl.patch has been upstreamed.
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/drm')
-rw-r--r-- | recipes-graphics/drm/libdrm/musl-ioctl.patch | 35 | ||||
-rw-r--r-- | recipes-graphics/drm/libdrm_2.4.102.imx.bb (renamed from recipes-graphics/drm/libdrm_2.4.99.imx.bb) | 6 |
2 files changed, 3 insertions, 38 deletions
diff --git a/recipes-graphics/drm/libdrm/musl-ioctl.patch b/recipes-graphics/drm/libdrm/musl-ioctl.patch deleted file mode 100644 index e3d6c5b8..00000000 --- a/recipes-graphics/drm/libdrm/musl-ioctl.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | Upstream-Status: Submitted | ||
2 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
3 | |||
4 | From 46c0fd6c827a8cb4d04e067bf04fab579ac4712e Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@intel.com> | ||
6 | Date: Mon, 18 Jun 2018 15:07:03 +0100 | ||
7 | Subject: [PATCH] tests/nouveau/threaded: adapt ioctl signature | ||
8 | |||
9 | POSIX says ioctl() has the signature (int, int, ...) but glibc has decided to | ||
10 | use (int, unsigned long int, ...) instead. | ||
11 | |||
12 | Use a #ifdef to adapt the replacement function as appropriate. | ||
13 | --- | ||
14 | tests/nouveau/threaded.c | 4 ++++ | ||
15 | 1 file changed, 4 insertions(+) | ||
16 | |||
17 | diff --git a/tests/nouveau/threaded.c b/tests/nouveau/threaded.c | ||
18 | index 3669bcd3..e1c27c01 100644 | ||
19 | --- a/tests/nouveau/threaded.c | ||
20 | +++ b/tests/nouveau/threaded.c | ||
21 | @@ -36,7 +36,11 @@ static int failed; | ||
22 | |||
23 | static int import_fd; | ||
24 | |||
25 | +#ifdef __GLIBC__ | ||
26 | int ioctl(int fd, unsigned long request, ...) | ||
27 | +#else | ||
28 | +int ioctl(int fd, int request, ...) | ||
29 | +#endif | ||
30 | { | ||
31 | va_list va; | ||
32 | int ret; | ||
33 | -- | ||
34 | 2.11.0 | ||
35 | |||
diff --git a/recipes-graphics/drm/libdrm_2.4.99.imx.bb b/recipes-graphics/drm/libdrm_2.4.102.imx.bb index dc2aa8a9..b8c38554 100644 --- a/recipes-graphics/drm/libdrm_2.4.99.imx.bb +++ b/recipes-graphics/drm/libdrm_2.4.102.imx.bb | |||
@@ -11,14 +11,14 @@ PROVIDES = "drm" | |||
11 | DEPENDS = "libpthread-stubs" | 11 | DEPENDS = "libpthread-stubs" |
12 | 12 | ||
13 | IMX_LIBDRM_SRC ?= "git://source.codeaurora.org/external/imx/libdrm-imx.git;protocol=https;nobranch=1" | 13 | IMX_LIBDRM_SRC ?= "git://source.codeaurora.org/external/imx/libdrm-imx.git;protocol=https;nobranch=1" |
14 | IMX_LIBDRM_BRANCH ?= "libdrm-imx-2.4.99" | 14 | IMX_LIBDRM_BRANCH ?= "libdrm-imx-2.4.102" |
15 | SRC_URI = "${IMX_LIBDRM_SRC};branch=${IMX_LIBDRM_BRANCH} \ | 15 | SRC_URI = "${IMX_LIBDRM_SRC};branch=${IMX_LIBDRM_BRANCH} \ |
16 | file://musl-ioctl.patch \ | ||
17 | file://0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch " | 16 | file://0001-meson-add-libdrm-vivante-to-the-meson-meta-data.patch " |
18 | SRCREV = "f421c9c8c4b8fe48d9e6ef43910e98569c94a4b2" | 17 | SRCREV = "f525ae649cd6e81e5d4e459799b0f7a120c4e174" |
19 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
20 | 19 | ||
21 | DEFAULT_PREFERENCE = "-1" | 20 | DEFAULT_PREFERENCE = "-1" |
21 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | ||
22 | 22 | ||
23 | inherit meson pkgconfig manpages | 23 | inherit meson pkgconfig manpages |
24 | 24 | ||