summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/clutter
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-05-04 20:06:30 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-05-16 17:06:51 -0300
commit67d69d69f6e0c687175f82536f78bd0f646c2cef (patch)
tree4df056bac8dec2f4fba6780515e28b5f9d10ec0a /recipes-graphics/clutter
parentd6cdded0d8235d7eaad052a52f881d87e61d5885 (diff)
downloadmeta-freescale-67d69d69f6e0c687175f82536f78bd0f646c2cef.tar.gz
clutter-1.0: Stop using base_contains
The base_contains function is deprecated and we ought to use bb.utils.contains instead. Change-Id: I3dc34aa6a955d0bb95fb1cac0a93a41ab4a1c50f Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/clutter')
-rw-r--r--recipes-graphics/clutter/clutter-1.0_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-graphics/clutter/clutter-1.0_%.bbappend b/recipes-graphics/clutter/clutter-1.0_%.bbappend
index cdeac1f2..85cbd509 100644
--- a/recipes-graphics/clutter/clutter-1.0_%.bbappend
+++ b/recipes-graphics/clutter/clutter-1.0_%.bbappend
@@ -1,9 +1,9 @@
1# Provide the need flags and backend settings to work with Vivante GPU 1# Provide the need flags and backend settings to work with Vivante GPU
2CFLAGS_append_mx6 = " -DLINUX \ 2CFLAGS_append_mx6 = " -DLINUX \
3 ${@base_contains('DISTRO_FEATURES', 'x11', '', \ 3 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
4 base_contains('DISTRO_FEATURES', 'wayland', \ 4 bb.utils.contains('DISTRO_FEATURES', 'wayland', \
5 '-DEGL_API_WL -DEGL_API_FB', '', d), d)}" 5 '-DEGL_API_WL -DEGL_API_FB', '', d), d)}"
6 6
7PACKAGECONFIG_mx6 ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'glx x11', \ 7PACKAGECONFIG_mx6 ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11', \
8 base_contains('DISTRO_FEATURES', 'wayland', \ 8 bb.utils.contains('DISTRO_FEATURES', 'wayland', \
9 'wayland egl', '', d), d)}" 9 'wayland egl', '', d), d)}"