diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:14:27 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | f8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch) | |
tree | 79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-graphics/amd-gpu-x11-bin | |
parent | c92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff) | |
download | meta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz |
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It
contains a clean history and allowing a more granullar set of changes.
This commit is just a rename of all contents of meta-fsl-arm
subdirectory to this layer's root, subsequent changes are based on top
of that.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/amd-gpu-x11-bin')
7 files changed, 260 insertions, 0 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-bin-mx51_11.09.01.bb new file mode 100644 index 00000000..ecf38f2f --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-bin-mx51_11.09.01.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | # Copyright (C) 2011, 2012 Freescale | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "GPU driver and apps for frambuffer on mx51" | ||
5 | |||
6 | include amd-gpu-mx51.inc | ||
7 | |||
8 | SRC_URI[md5sum] = "9f9b5f67b595721a08793aae8bd8fc46" | ||
9 | SRC_URI[sha256sum] = "f0db68a764b5fb199729e7435f606b8d12b61ca97990336c647b7e81f4a584d9" | ||
10 | |||
11 | RCONFLICTS_${PN} = "amd-gpu-x11-bin-mx51" | ||
12 | |||
13 | COMPATIBLE_MACHINE = "(mx5)" | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc new file mode 100644 index 00000000..76c7bc43 --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc | |||
@@ -0,0 +1,110 @@ | |||
1 | # Copyright (C) 2011, 2012, 2013 Freescale | ||
2 | # Copyright (C) 2011-2015 O.S. Systems Software LTDA. | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | LICENSE = "Proprietary" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | # FIXME: Replace for correct AMD license | ||
9 | LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" | ||
10 | |||
11 | PROVIDES = "amd-gpu-mx51 virtual/egl virtual/libgles1 virtual/libgles2" | ||
12 | |||
13 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
14 | file://egl.pc \ | ||
15 | file://glesv2.pc \ | ||
16 | file://fix-linux-build-check.patch" | ||
17 | |||
18 | inherit fsl-eula-unpack | ||
19 | |||
20 | # For the packages that make up the OpenGL interfaces, inject variables so that | ||
21 | # they don't get Debian-renamed (which would remove the -mx51 suffix). | ||
22 | # | ||
23 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
24 | # the source we cannot fix it. Disable the insane check for now. | ||
25 | python __anonymous() { | ||
26 | for p in d.getVar('PACKAGES', True).split(): | ||
27 | d.setVar("INSANE_SKIP_%s" % p, "ldflags") | ||
28 | |||
29 | for p in (("libegl", "libegl1"), ("libgl", "libgl1"), | ||
30 | ("libgles2", "libglesv2-2")): | ||
31 | fullp = p[0] + "-mx51" | ||
32 | pkgs = " ".join(p) | ||
33 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
34 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
35 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
36 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
37 | |||
38 | # For -dev, the first element is both the Debian and original name | ||
39 | fullp += "-dev" | ||
40 | pkgs = p[0] + "-dev" | ||
41 | d.setVar("DEBIAN_NOAUTONAME_" + fullp, "1") | ||
42 | d.appendVar("RREPLACES_" + fullp, pkgs) | ||
43 | d.appendVar("RPROVIDES_" + fullp, pkgs) | ||
44 | d.appendVar("RCONFLICTS_" + fullp, pkgs) | ||
45 | } | ||
46 | |||
47 | do_install () { | ||
48 | install -d ${D}${libdir} | ||
49 | install -d ${D}${bindir} | ||
50 | install -d ${D}${includedir} | ||
51 | |||
52 | cp -Pr ${S}/usr/bin/* ${D}${bindir} | ||
53 | cp -Pr ${S}/usr/lib/* ${D}${libdir} | ||
54 | cp -Pr ${S}/usr/include/* ${D}${includedir} | ||
55 | |||
56 | find ${D}${bindir} -type f -exec chmod 755 {} \; | ||
57 | find ${D}${libdir} -type f -exec chmod 644 {} \; | ||
58 | find ${D}${includedir} -type f -exec chmod 644 {} \; | ||
59 | |||
60 | # FIXME: Fix sonames of broken libraries | ||
61 | mv ${D}${libdir}/lib2dz160.so ${D}${libdir}/lib2dz160.so.0 | ||
62 | mv ${D}${libdir}/lib2dz430.so ${D}${libdir}/lib2dz430.so.0 | ||
63 | ln -sf lib2dz160.so.0 ${D}${libdir}/lib2dz160.so | ||
64 | ln -sf lib2dz430.so.0 ${D}${libdir}/lib2dz430.so | ||
65 | |||
66 | # FIXME: Remove unknown files | ||
67 | rm -r ${D}${libdir}/libcsi.a \ | ||
68 | ${D}${libdir}/libres.a | ||
69 | |||
70 | # FIXME: Add pkgconfig files | ||
71 | install -d ${D}${libdir}/pkgconfig | ||
72 | install -m 644 ${WORKDIR}/egl.pc ${D}${libdir}/pkgconfig | ||
73 | install -m 644 ${WORKDIR}/glesv2.pc ${D}${libdir}/pkgconfig | ||
74 | } | ||
75 | |||
76 | PACKAGES =+ "libgsl-fsl-mx51 libgsl-fsl-mx51-dev libgsl-fsl-mx51-dbg \ | ||
77 | libegl-mx51 libegl-mx51-dev libegl-mx51-dbg \ | ||
78 | libgles-mx51 libgles-mx51-dev libgles-mx51-dbg \ | ||
79 | libgles2-mx51 libgles2-mx51-dev libgles2-mx51-dbg \ | ||
80 | libopenvg-mx51 libopenvg-mx51-dev libopenvg-mx51-dbg \ | ||
81 | lib2dz160-mx51 lib2dz160-mx51-dbg \ | ||
82 | lib2dz430-mx51 lib2dz430-mx51-dbg" | ||
83 | |||
84 | FILES_${PN}-dbg = "${bindir}/.debug/*" | ||
85 | |||
86 | FILES_libgsl-fsl-mx51 = "${libdir}/libgsl-fsl${SOLIBS}" | ||
87 | FILES_libgsl-fsl-mx51-dev = "${libdir}/libgsl-fsl${SOLIBSDEV}" | ||
88 | FILES_libgsl-fsl-mx51-dbg = "${libdir}/.debug/libgsl-fsl${SOLIBS}" | ||
89 | |||
90 | FILES_libegl-mx51 = "${libdir}/libEGL${SOLIBS}" | ||
91 | FILES_libegl-mx51-dev = "${includedir}/EGL ${includedir}/KHR ${libdir}/libEGL${SOLIBSDEV}" | ||
92 | FILES_libegl-mx51-dbg = "${libdir}/.debug/libEGL${SOLIBS}" | ||
93 | |||
94 | FILES_libgles-mx51 = "${libdir}/libGLESv1*${SOLIBS}" | ||
95 | FILES_libgles-mx51-dev = "${includedir}/GLES ${libdir}/libGLESv1*${SOLIBSDEV}" | ||
96 | FILES_libgles-mx51-dbg = "${libdir}/.debug/libGLESv1*${SOLIBS}" | ||
97 | |||
98 | FILES_libgles2-mx51 = "${libdir}/libGLESv2${SOLIBS}" | ||
99 | FILES_libgles2-mx51-dev = "${includedir}/GLES2 ${libdir}/libGLESv2${SOLIBSDEV}" | ||
100 | FILES_libgles2-mx51-dbg = "${libdir}/.debug/libGLESv2${SOLIBS}" | ||
101 | |||
102 | FILES_libopenvg-mx51 = "${libdir}/libOpenVG${SOLIBS}" | ||
103 | FILES_libopenvg-mx51-dev = "${includedir}/VG ${libdir}/libOpenVG${SOLIBSDEV}" | ||
104 | FILES_libopenvg-mx51-dbg = "${libdir}/.debug/libOpenVG${SOLIBS}" | ||
105 | |||
106 | FILES_lib2dz160-mx51 = "${libdir}/lib2dz160${SOLIBS}" | ||
107 | FILES_lib2dz160-mx51-dbg = "${libdir}/.debug/lib2dz160${SOLIBS}" | ||
108 | |||
109 | FILES_lib2dz430-mx51 = "${libdir}/lib2dz430${SOLIBS}" | ||
110 | FILES_lib2dz430-mx51-dbg = "${libdir}/.debug/lib2dz430${SOLIBS}" | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb new file mode 100644 index 00000000..7fc351b0 --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | # Copyright (C) 2011-2015 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2011, 2012 Freescale | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "GPU driver and apps for x11 on mx51" | ||
6 | PR = "r12" | ||
7 | |||
8 | # FIXME: Replace for correct AMD license | ||
9 | LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" | ||
10 | DEPENDS = "virtual/libx11 libxrender libxext" | ||
11 | |||
12 | include amd-gpu-mx51.inc | ||
13 | |||
14 | SRC_URI[md5sum] = "54391a4e670b597d06d01253fb217cad" | ||
15 | SRC_URI[sha256sum] = "c7a6fa03b7aa2a375556c59908876554ba720c1e744baba2debb84a408f790db" | ||
16 | |||
17 | RCONFLICTS_${PN} = "amd-gpu-bin-mx51" | ||
18 | |||
19 | COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" | ||
20 | |||
21 | do_install_append() { | ||
22 | # eglplatform_1.4.h contains X11 compatible headers | ||
23 | rm ${D}${includedir}/EGL/eglplatform.h | ||
24 | mv ${D}${includedir}/EGL/eglplatform_1.4.h ${D}${includedir}/EGL/eglplatform.h | ||
25 | } | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/files/egl.pc b/recipes-graphics/amd-gpu-x11-bin/files/egl.pc new file mode 100644 index 00000000..3d2ab5db --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/files/egl.pc | |||
@@ -0,0 +1,11 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: egl | ||
7 | Description: AMD EGL library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lEGL | ||
11 | Cflags: -I${includedir} | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch b/recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch new file mode 100644 index 00000000..946bfac7 --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h | ||
2 | --- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h 2012-08-18 12:43:19.431788396 -0300 | ||
3 | +++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h 2012-08-18 12:43:50.799909873 -0300 | ||
4 | @@ -164,11 +164,11 @@ | ||
5 | * nanoseconds (unadjusted standard time). Here, it is defined as | ||
6 | * appropriate for an ISO C compiler. | ||
7 | */ | ||
8 | -#ifndef _LINUX | ||
9 | +#ifndef __linux__ | ||
10 | typedef uint64_t EGLTimeKHR; | ||
11 | -#else // _LINUX | ||
12 | +#else // __linux__ | ||
13 | typedef unsigned long long EGLTimeKHR; | ||
14 | -#endif // _LINUX | ||
15 | +#endif // __linux__ | ||
16 | |||
17 | #define EGL_SYNC_PRIOR_COMMANDS_COMPLETE_KHR 0xFFF8 | ||
18 | #define EGL_SYNC_STATUS_KHR 0xFFF7 | ||
19 | diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h | ||
20 | --- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h 2012-08-18 12:43:19.431788396 -0300 | ||
21 | +++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h 2012-08-18 12:43:50.759785714 -0300 | ||
22 | @@ -65,7 +65,7 @@ | ||
23 | } eglYUVInfo; | ||
24 | #endif | ||
25 | |||
26 | -#ifdef _LINUX | ||
27 | +#ifdef __linux__ | ||
28 | struct EGLImageInfoFSL | ||
29 | { | ||
30 | void *mem_virt[3]; //virtual addresses for Y/U/V planes | ||
31 | diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h | ||
32 | --- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h 2012-08-18 12:43:19.431788396 -0300 | ||
33 | +++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h 2012-08-18 12:43:50.799909873 -0300 | ||
34 | @@ -15,7 +15,7 @@ | ||
35 | extern "C" { | ||
36 | #endif | ||
37 | |||
38 | -#ifndef _LINUX | ||
39 | +#ifndef __linux__ | ||
40 | #include <VG/openvg.h> | ||
41 | #else | ||
42 | #include "openvg.h" | ||
43 | diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h | ||
44 | --- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h 2012-08-18 12:43:19.431788396 -0300 | ||
45 | +++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h 2012-08-18 12:43:50.799909873 -0300 | ||
46 | @@ -449,7 +449,7 @@ | ||
47 | # endif | ||
48 | # elif defined(__APPLE__) | ||
49 | # define VG_API_CALL extern | ||
50 | -# elif defined(_LINUX) | ||
51 | +# elif defined(__linux__) | ||
52 | # if defined (OPENVG_DLL_EXPORTS) | ||
53 | # define VG_API_CALL extern | ||
54 | # else | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/files/glesv2.pc b/recipes-graphics/amd-gpu-x11-bin/files/glesv2.pc new file mode 100644 index 00000000..62e1cb65 --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/files/glesv2.pc | |||
@@ -0,0 +1,11 @@ | |||
1 | prefix=/usr | ||
2 | exec_prefix=${prefix} | ||
3 | libdir=/usr/lib | ||
4 | includedir=/usr/include | ||
5 | |||
6 | Name: glesv2 | ||
7 | Description: AMD OpenGL ES 2.0 library | ||
8 | Requires.private: | ||
9 | Version: 8.0 | ||
10 | Libs: -L${libdir} -lGLESv2 -lEGL | ||
11 | Cflags: -I${includedir} | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb new file mode 100644 index 00000000..43b9f7ff --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/libz160_11.09.01.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | # Copyright (C) 2011-2015 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2011, 2012 Freescale | ||
3 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
4 | |||
5 | DESCRIPTION = "AMD libz160 gpu driver" | ||
6 | LICENSE = "Proprietary" | ||
7 | SECTION = "libs" | ||
8 | DEPENDS = "amd-gpu-mx51" | ||
9 | |||
10 | PR = "r2" | ||
11 | |||
12 | #todo: Replace for correct AMD license | ||
13 | LIC_FILES_CHKSUM = "file://usr/include/z160.h;endline=28;md5=65dd44cd769091092f38e34cd52cc271" | ||
14 | |||
15 | SRC_URI = "${FSL_MIRROR}/libz160-bin-${PV}.bin;fsl-eula=true" | ||
16 | SRC_URI[md5sum] = "9a9c2c93f4b44e89316772d348eead7d" | ||
17 | SRC_URI[sha256sum] = "08767eb269a0a30ca0aa3d3b5aa9a53a2d17ed1c24651b7e8cefc7704b883f19" | ||
18 | |||
19 | inherit fsl-eula-unpack | ||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${libdir} | ||
23 | install -d ${D}${includedir} | ||
24 | install -m 0755 ${S}/usr/lib/* ${D}${libdir} | ||
25 | install -m 0644 ${S}/usr/include/* ${D}${includedir} | ||
26 | } | ||
27 | |||
28 | S = "${WORKDIR}/${PN}-bin-${PV}" | ||
29 | |||
30 | # Avoid QA Issue: No GNU_HASH in the elf binary | ||
31 | INSANE_SKIP_${PN} = "ldflags" | ||
32 | INSANE_SKIP_${PN}-dev = "ldflags" | ||
33 | FILES_${PN} = "${libdir}/*.so" | ||
34 | FILES_${PN}-dev = "${includedir}" | ||
35 | |||
36 | COMPATIBLE_MACHINE = "(mx5)" | ||