summaryrefslogtreecommitdiffstats
path: root/recipes-fsl
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /recipes-fsl
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/images/fsl-image-mfgtool-initramfs.bb8
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb47
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-fsl/images/fsl-image-mfgtool-initramfs.bb b/recipes-fsl/images/fsl-image-mfgtool-initramfs.bb
new file mode 100644
index 00000000..7d79d1ef
--- /dev/null
+++ b/recipes-fsl/images/fsl-image-mfgtool-initramfs.bb
@@ -0,0 +1,8 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3DESCRIPTION = "Small image to be used with Manufacturing Tool \
4(mfg-tool) in a production environment."
5
6LICENSE = "MIT"
7
8inherit mfgtool-initramfs-image
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 00000000..50885ee1
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,47 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3SUMMARY = "Freescale Manufacturing Tool requirements"
4LICENSE = "MIT"
5
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8inherit packagegroup
9
10PACKAGES = " \
11 ${PN}-base \
12 ${PN}-mtd \
13 ${PN}-extfs \
14"
15
16# The essential packages for device bootup that may be set in the
17# machine configuration file.
18MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
19
20# Distro can override the following VIRTUAL-RUNTIME providers:
21VIRTUAL-RUNTIME_keymaps ?= "keymaps"
22
23RDEPENDS_${PN}-base = " \
24 bash \
25 imx-uuc \
26 util-linux \
27 coreutils \
28 dosfstools \
29 mmc-utils \
30 base-files \
31 base-passwd \
32 busybox \
33 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
34 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
35"
36
37RDEPENDS_${PN}-mtd = " \
38 ${PN}-base \
39 imx-kobs \
40 mtd-utils \
41 mtd-utils-ubifs \
42"
43
44RDEPENDS_${PN}-extfs = " \
45 ${PN}-base \
46 e2fsprogs-mke2fs \
47"