diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-04-12 14:50:32 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-05-02 17:54:57 -0300 |
commit | 0aaeb71587fc29c9639044b401f6e8224c73031d (patch) | |
tree | d86c53547b4b68c1d3aaf90e89cb3ec51d0d8cd9 /recipes-extended | |
parent | 67d70b7cf9a2de4c88bfc66654769c0ee07cdb10 (diff) | |
download | meta-freescale-0aaeb71587fc29c9639044b401f6e8224c73031d.tar.gz |
dpdk: update to a3395d2
*include the following changes
a3395d2 - Merge pull request #310 in GITAM/dpdk from hotfix/DPDK-477-l3fwd-performance to 16.07-qoriq
cda2d04 - dpaa2: disable bug_on in qbman
cd7609b - dpaa2: enable virt addressing by default
0a17438 - dpaa2: fix legal copyright for MC files
0b5b9f9 - Merge pull request #306 in GITAM/dpdk from ~B35197/dpdk:16.07-qoriq to 16.07-qoriq
e1ab876 - dpaa_sec: allocate ctx memory from per device mempool in place of malloc
2fcbd10 - dpaa: fix incorrect header macro name
23ec077 - dpaa2:pool: removing comments and remove mbuf_size
ed6da95 - dpaa2: fix 0 buffer release call to qbman
0bbba9c - dpaa2: update ext for dpl scripts
8061b41 - dpaa: enable frame queue taildrop for rx queues
baec797 - dpaa2: compilation warning with GCC 6.1
b6d8b7c - ext: updating the ext commit
f5a43ca - dpaa - update the readme files
27c2b01 - dpaa build check script with debug
a3e73f0 - dpaa2: remove unused sw annotation and duplicate code for rx buffer layout
c00e7cb - dpaa2: Handle boundary condition and set invalid bpid properly
0c4c95f - DPAA:Adding correct flib directories path in Makefile
5f9295f - dpaa2: in sync with upstream code
b3926f9 - Merge pull request #289 in GITAM/dpdk from ~B56361/dpdk-b56361:feature/DPDK-359 to 16.07-qoriq
9c3cb3e - dpaa_sec: boundary check for session and qp logic
13262d5 - dpaa2: add support for pause frames
adc1fe1 - Merge pull request #292 in GITAM/dpdk from ~B35197/dpdk:16.07-qoriq to 16.07-qoriq
306942a - dpaa2: Improve mbuf-fd conversion routines to support fragmentation
3a363b7 - Merge pull request #294 in GITAM/dpdk from ~B27504/dpdk:16.07-qoriq to 16.07-qoriq
d85e655 - dpaa1: Add functionality to enable/disable multicast ethernet frames
690eb31 - Merge pull request #293 in GITAM/dpdk from ~B10814/dpdk:16.07-qoriq to 16.07-qoriq
585f8bc - ethdev: prevent duplicate event callback
4534008 - eal/arm: fix file descriptor leak when getting CPU features
ce66837 - app/testpmd: fix timeout in Rx queue flushing
68f549a - app/testpmd: fix RSS hash key size
3e65873 - app/testpmd: fix help of MTU set commmand
011af8b - pmdinfogen: fix clang build
1fbb214 - examples/qos_sched: fix dequeue from ring
cbe4f1e - examples/l2fwd-crypto: fix verify with decrypt in chain
c1a7e72 - examples/ipsec-secgw: check SP only when setup
c7e10ca - timer: fix lag delay
34405e3 - vhost: fix Windows VM hang
d30eb3f - tools: fix virtio interface name when binding
24d1523 - tools: fix json output of pmdinfo
f198525 - Merge pull request #291 in GITAM/dpdk from ~B46179/dpdk_rebase:16.07-qoriq to 16.07-qoriq
60e04ab - IP_FRAG: Updating correct packet type in fragmented packets
5c13b51 - DPAA:Adding refcount support in ethernet driver
9355023 - net/dpaa2: add support for free buffer count
249254f - Merge pull request #285 in GITAM/dpdk from ~B35197/dpdk:16.07-qoriq to 16.07-qoriq
69eda52 - dpaa_sec: implement attach/detach qp with session apis
0038181 - ipsec-secgw: attach session to a queue pair
5b2a271 - cryptodev: add apis to attach session with queue pair
0a9ad9f - cryptodev: add max_nb_session_per_qp parameter in rte_cryptodev_info.sym
5777555 - Merge pull request #287 in GITAM/dpdk from ~B10814/dpdk:16.07-qoriq to 16.07-qoriq
505624c - dpaa1: fix coverity reported issues
da4765d - dpaa2: fix the coverity reported issues
cb0fa4e - dpaa2: upgrade MC to 10.1.0
5e45742 - DPAA: Removing usage of shared portals in QBMAN
2e9ee37 - DPAA: Adding perf optimizations in qman
e16eac0 - DPAA: Adding performance optimizations in ethernet driver
a08afad - DPAA: Adding L3_IPV4_EXT as supported ptype
1387949 - DPAA: Correcting the Parse results masks
dd7ea75 - mk: fix build of assembly files for ARM64
5cd5587 - flib/rta: fix HMAC key size in cnstr_shdsc_hmac()
c686a81 - crypto/dpaa2_sec: add per device mempool to store frame list entries
575b661 - Merge pull request #279 in GITAM/dpdk from ~B10814/dpdk:16.07-qoriq to 16.07-qoriq
ff60419 - Merge pull request #274 in GITAM/dpdk from ~B46179/dpdk_rebase:16.07-qoriq to 16.07-qoriq
9b4d9da - IP_RSMBL: Removing compilation failure from IP_Reassembly
588049f - DPAA: Adding checksum offload support for SG use-case
774a5e7 - dpaa: removing unused dtsec registers and routines
dc00642 - dpaa: add support for unicast mac addr filters
0c047b3 - dpaa: removing warning with 32 bit compilation
4cf6c40 - mbuf: use pktmbuf helper to create the pool
ee78cc9 - fsl_qbman: ceetm: fix parsing of lni and sp id ranges
6a80c9c - fsl_qbman: fix bman debugfs endianness
bd9d970 - fsl_qbman: fix kernel doc comments
0922755 - fsl_qbman: ceetm: add missing endianness conversions
704abbb - fsl_qman: Fix endianness in ccgr query
c299629 - fsl_qman: Fix endianness class queue query
5638a2c - fsl_qbman: Fix endianness for wq query
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/dpdk/dpdk_16.07.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.07.bb b/recipes-extended/dpdk/dpdk_16.07.bb index 89c2558e..ee0fcca0 100644 --- a/recipes-extended/dpdk/dpdk_16.07.bb +++ b/recipes-extended/dpdk/dpdk_16.07.bb | |||
@@ -13,7 +13,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/dpdk.git;nobranch=1 \ | |||
13 | file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ | 13 | file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ |
14 | file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ | 14 | file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ |
15 | " | 15 | " |
16 | SRCREV = "34b69f9ab1af11db43df2d616be1c1f20feef70b" | 16 | SRCREV = "a3395d24774a8a7a2ce0d56a92a8ad2895b2ae8c" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||
@@ -40,7 +40,7 @@ do_install() { | |||
40 | oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" T="${RTE_TARGET}" DESTDIR="${D}" install | 40 | oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" T="${RTE_TARGET}" DESTDIR="${D}" install |
41 | 41 | ||
42 | # Build and install the DPDK examples | 42 | # Build and install the DPDK examples |
43 | for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni; do | 43 | for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do |
44 | oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} | 44 | oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} |
45 | 45 | ||
46 | [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example | 46 | [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example |
@@ -75,6 +75,10 @@ FILES_${PN}-dbg += "${bindir}/dpdk-example/.debug \ | |||
75 | ${datadir}/examples/l3fwd/build/app/.debug \ | 75 | ${datadir}/examples/l3fwd/build/app/.debug \ |
76 | ${datadir}/examples/ipsec-secgw/build/.debug \ | 76 | ${datadir}/examples/ipsec-secgw/build/.debug \ |
77 | ${datadir}/examples/ipsec-secgw/build/app/.debug \ | 77 | ${datadir}/examples/ipsec-secgw/build/app/.debug \ |
78 | ${datadir}/examples/ip_fragmentation/build/.debug \ | ||
79 | ${datadir}/examples/ip_fragmentation/build/app/.debug \ | ||
80 | ${datadir}/examples/ip_reassembly/build/.debug \ | ||
81 | ${datadir}/examples/ip_reassembly/build/app/.debug \ | ||
78 | " | 82 | " |
79 | FILES_${PN}-dev += "${datadir}/mk ${datadir}/scripts \ | 83 | FILES_${PN}-dev += "${datadir}/mk ${datadir}/scripts \ |
80 | ${datadir}/${RTE_TARGET} \ | 84 | ${datadir}/${RTE_TARGET} \ |