summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-04-03 11:50:21 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-11 10:26:14 -0300
commite92f5cb438291c2ee70cfdbd85cfd95f299eb7ac (patch)
tree7d209a11dd04cbb7015cc69dca89f72cbc94ef1f /recipes-extended
parent0edae65e61a4ed1d5555fe565838bf50a4485d27 (diff)
downloadmeta-freescale-e92f5cb438291c2ee70cfdbd85cfd95f299eb7ac.tar.gz
secure-obj: add recipes
*include the following changes: 74befe0 - SOBJ_TA: Fix for crash on running multiple sobj_eng_app simultaneously abfad4b - SOBJ_ENG: Adding support for parsing fake pem file 0120544 - SOBJ_APP:Adding option to save label in pem file 0f75291 - LIB: Removing compilation error 40cb954 - Updating README file 02be730 - SEC_KEY_DEV: Removing Compilation Error for Linux 4.14 1ed3e61 - SEC_KEY_DEV: Updating module information. 99253c5 - SEC_ENG_APP: Removing Compilation Error bb77eb4 - Merge pull request #14 in DNDEV/secure_obj from devel to master 7a98861 - Miscellaneous Changes 3225611 - SEC_KEY_DEV: Updating License to GPLV2.0 6d22fae - SEC_KEY_DEV: Removing FLIB dependancy for MP Key feature 436d79c - Removing issues reported by coverity 3db41f7 - LIB: Adding application for testing Secure Object Engine 1ae06b6 - SOBJ_ENGINE: Adding Secure Object based OpenSSL Engine 1e322f4 - LIB: Adding License to MP Apps file 4445c63 - LIB: Adding Manufacturing Key Feature 5b68462 - LIB: Changing library name to libsecure_obj.so f700c98 - Added Secure Object Application. d9d6a06 - APP: Coverity issue fix fe0da83 - TA: Add support for SK_GenerateKeyPair api 6589f45 - LIB: Add support for SK_Digest api 33dccce - TA: Add support for SK_Digest api 748187b - TA: Adding LICENSE to Secure Storage TA files dded4a9 - LIB: Adding LICENSE to Securekey Library files 0fbacc6 - LIB: Adding description of APIs in securekey_api.h ff95077 - LIB: Incorporate review comments on securekey_api_types.h f77a134 - TA: Incorporate review comments 2bb00f3 - LIB: Replacing printf with debug prints a88d9b8 - Coverity: Solving issues reported by coverity b0017c8 - TA: Add support for SK_Decrypt instead of SK_Encrypt 352ef6d - LIB: Make global func list static & do runtime init 2d09e72 - LIB: Add SK_Sign & SK_Encrypt APIs implementation db11a50 - LIB: Update securekey header files with sign and encrypt api's d4a29de - TA: Add support for SK_Sign and SK_Encrypt api's 09ceac4 - LIB: Adding implementation of SK_GetObjectAttribute API 877c1fb - TA: Update securekey_api_types.h with sign/encrypt types a1e709a - TA: Add support for SK_GetObjectAttribute api 5c7479c - LIB: Correcting Error mapping function a0deca2 - LIB: Adding test for enumerate object on attributes c9a2feb - LIB: Adding implementation of SK_EraseObject f63f9ce - TA: Add support for SK_EraseObject api bcb1d3d - TA: Add support for match attribute in SK_FindObject api 3ae46cd - LIB: Exposing function pointers from Securekey Library e9a2ce9 - LIB: Mapping TEE errors to SecureKey errors 912e388 - LIB: Adding implementation of SK_EnumerateObjects a14cbbb - LIB: Adding SK_CreateObject Implementation 20ce6af - TA: Add client side test framework 4fafd61 - TA: Add sub.mk for compilation 62edd11 - TA: Add implementation for SK_FindObject api 597d4e0 - TA: Add implementation for SK_CreateObject api e11ea98 - TA: Add database mgmt and hepler api's 0ba7bd3 - TA: Add framework for Secure Storage API's e113d79 - TA: Changes in Makefile to comply with OP-TEE compilation d24d3d4 - Adding file hierarchy framework 9075f15 - Initial Commit Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/secure-obj/secure-obj-module_git.bb11
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc27
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb37
3 files changed, 75 insertions, 0 deletions
diff --git a/recipes-extended/secure-obj/secure-obj-module_git.bb b/recipes-extended/secure-obj/secure-obj-module_git.bb
new file mode 100644
index 00000000..3866dde4
--- /dev/null
+++ b/recipes-extended/secure-obj/secure-obj-module_git.bb
@@ -0,0 +1,11 @@
1require secure-obj.inc
2
3LIC_FILES_CHKSUM = "file://../README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
4
5DEPENDS += "virtual/kernel"
6
7inherit module
8
9S = "${WORKDIR}/git/securekeydev"
10
11EXTRA_OEMAKE += 'KERNEL_SRC="${STAGING_KERNEL_DIR}"'
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
new file mode 100644
index 00000000..3fd70eb8
--- /dev/null
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -0,0 +1,27 @@
1DESCRIPTION = "Secure Object"
2LICENSE = "BSD"
3
4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
5RDEPENDS_${PN} = "bash libcrypto libssl python"
6
7DEPENDS += "python-pycrypto-native"
8
9inherit pythonnative
10
11LDFLAGS += "${TOOLCHAIN_OPTIONS}"
12
13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \
14"
15SRCREV = "74befe01bda41f1c27b197ef2ab66e475e9a81b3"
16
17WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
18export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
19export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
20
21EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
22
23ALLOW_EMPTY_${PN} = "1"
24INHIBIT_PACKAGE_STRIP = "1"
25PARALLEL_MAKE = ""
26INSANE_SKIP_${PN} = "ldflags"
27COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
new file mode 100644
index 00000000..103c089e
--- /dev/null
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -0,0 +1,37 @@
1require secure-obj.inc
2
3LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
4
5S = "${WORKDIR}/git"
6
7WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
8export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
9export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
10export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
11export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
12
13do_compile() {
14 unset LDFLAGS
15 export TA_DEV_KIT_DIR="${RECIPE_SYSROOT}/usr/include/optee/export-user_ta"
16 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
17 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr"
18 for APP in secure_storage_ta securekey_lib secure_obj-openssl-engine; do
19 cd ${APP}
20 oe_runmake
21 cd ..
22 done
23}
24
25do_install() {
26 install -d ${D}${bindir}/secure_obj
27 install -d ${D}${libdir}/secure_obj
28 install -d ${D}${includedir}
29 cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${bindir}/secure_obj
30 cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}/secure_obj
31 cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/secure_obj
32 cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}/secure_obj
33 cp ${S}/securekey_lib/out/export/include/* ${D}${includedir}
34 cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}/secure_obj
35}
36
37FILES_${PN} += "${libdir}/secure_obj"