summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-08-30 17:28:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-08-30 10:08:09 -0300
commite473fb01569aea5f946a47bd7ab05911be7a3640 (patch)
treebb61d098d7db773956c2c16b2a70e78194783c78 /recipes-extended
parent61ef69669be977f65d63d8c0d17ba2e3b1baa7e1 (diff)
downloadmeta-freescale-e473fb01569aea5f946a47bd7ab05911be7a3640.tar.gz
ofp: add ls1088a support
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ofp/ofp/0001-Patch-to-install-ofp-example-applications.patch166
-rw-r--r--recipes-extended/ofp/ofp/Fix-compilation-issue-with-redefinition-of-a-struct.patch19
-rw-r--r--recipes-extended/ofp/ofp_git.bb10
3 files changed, 4 insertions, 191 deletions
diff --git a/recipes-extended/ofp/ofp/0001-Patch-to-install-ofp-example-applications.patch b/recipes-extended/ofp/ofp/0001-Patch-to-install-ofp-example-applications.patch
deleted file mode 100644
index 041896a6..00000000
--- a/recipes-extended/ofp/ofp/0001-Patch-to-install-ofp-example-applications.patch
+++ /dev/null
@@ -1,166 +0,0 @@
1From 82691546d6125f1d07c4f9faa06475dff94ba567 Mon Sep 17 00:00:00 2001
2From: Nikhil Agarwal <nikhil.agarwal@linaro.org>
3Date: Wed, 11 Jan 2017 00:24:07 +0530
4Subject: [PATCH] Patch to install ofp example applications.
5
6Signed-off-by: Nikhil Agarwal <nikhil.agarwal@linaro.org>
7---
8 example/classifier/Makefile.am | 3 ++-
9 example/fpm/Makefile.am | 3 ++-
10 example/fpm_burstmode/Makefile.am | 3 ++-
11 example/ioctl_test/Makefile.am | 3 ++-
12 example/multicast/Makefile.am | 3 ++-
13 example/socket/Makefile.am | 3 ++-
14 example/sysctl/Makefile.am | 3 ++-
15 example/udp_fwd_socket/Makefile.am | 3 ++-
16 example/udpecho/Makefile.am | 3 ++-
17 example/webserver/Makefile.am | 3 ++-
18 example/webserver2/Makefile.am | 3 ++-
19 11 files changed, 22 insertions(+), 11 deletions(-)
20
21diff --git a/example/classifier/Makefile.am b/example/classifier/Makefile.am
22index c54542c..cb4eb31 100644
23--- a/example/classifier/Makefile.am
24+++ b/example/classifier/Makefile.am
25@@ -1,6 +1,7 @@
26 include $(top_srcdir)/example/Makefile.inc
27
28-noinst_PROGRAMS = classifier
29+inst_PROGRAMS = classifier
30+instdir=${exec_prefix}/ofp/bin
31 classifier_LDFLAGS = $(AM_LDFLAGS) -static
32
33 dist_classifier_SOURCES = classifier_main.c
34diff --git a/example/fpm/Makefile.am b/example/fpm/Makefile.am
35index d04916c..2b459d7 100644
36--- a/example/fpm/Makefile.am
37+++ b/example/fpm/Makefile.am
38@@ -1,6 +1,7 @@
39 include $(top_srcdir)/example/Makefile.inc
40
41-noinst_PROGRAMS = fpm
42+inst_PROGRAMS = fpm
43+instdir=${exec_prefix}/ofp/bin
44 fpm_LDFLAGS = $(AM_LDFLAGS) -static
45
46 dist_fpm_SOURCES = app_main.c \
47diff --git a/example/fpm_burstmode/Makefile.am b/example/fpm_burstmode/Makefile.am
48index 6b7b024..fc8cdfe 100644
49--- a/example/fpm_burstmode/Makefile.am
50+++ b/example/fpm_burstmode/Makefile.am
51@@ -1,6 +1,7 @@
52 include $(top_srcdir)/example/Makefile.inc
53
54-noinst_PROGRAMS = fpm_burstmode
55+inst_PROGRAMS = fpm_burstmode
56+instdir=${exec_prefix}/ofp/bin
57 fpm_burstmode_LDFLAGS = $(AM_LDFLAGS) -static
58
59 dist_fpm_burstmode_SOURCES = app_main.c
60diff --git a/example/ioctl_test/Makefile.am b/example/ioctl_test/Makefile.am
61index d45c4c4..98fd573 100644
62--- a/example/ioctl_test/Makefile.am
63+++ b/example/ioctl_test/Makefile.am
64@@ -1,6 +1,7 @@
65 include $(top_srcdir)/example/Makefile.inc
66
67-noinst_PROGRAMS = ioctl_test
68+inst_PROGRAMS = ioctl_test
69+instdir=${exec_prefix}/ofp/bin
70
71 ioctl_test_LDFLAGS = $(AM_LDFLAGS) -static
72
73diff --git a/example/multicast/Makefile.am b/example/multicast/Makefile.am
74index 378aaf3..8476123 100644
75--- a/example/multicast/Makefile.am
76+++ b/example/multicast/Makefile.am
77@@ -1,6 +1,7 @@
78 include $(top_srcdir)/example/Makefile.inc
79
80-noinst_PROGRAMS = mcast
81+inst_PROGRAMS = mcast
82+instdir=${exec_prefix}/ofp/bin
83
84 mcast_LDFLAGS = $(AM_LDFLAGS) -static
85
86diff --git a/example/socket/Makefile.am b/example/socket/Makefile.am
87index 9fa2b7d..c296fc2 100644
88--- a/example/socket/Makefile.am
89+++ b/example/socket/Makefile.am
90@@ -1,6 +1,7 @@
91 include $(top_srcdir)/example/Makefile.inc
92
93-noinst_PROGRAMS = socket
94+inst_PROGRAMS = socket
95+instdir=${exec_prefix}/ofp/bin
96 socket_LDFLAGS = $(AM_LDFLAGS) -static
97
98 dist_socket_SOURCES = \
99diff --git a/example/sysctl/Makefile.am b/example/sysctl/Makefile.am
100index 42f3a27..7ef0227 100644
101--- a/example/sysctl/Makefile.am
102+++ b/example/sysctl/Makefile.am
103@@ -1,6 +1,7 @@
104 include $(top_srcdir)/example/Makefile.inc
105
106-noinst_PROGRAMS = sysctl
107+inst_PROGRAMS = sysctl
108+instdir=${exec_prefix}/ofp/bin
109
110 sysctl_LDFLAGS = $(AM_LDFLAGS) -static
111
112diff --git a/example/udp_fwd_socket/Makefile.am b/example/udp_fwd_socket/Makefile.am
113index 653fd21..c8ce9ca 100644
114--- a/example/udp_fwd_socket/Makefile.am
115+++ b/example/udp_fwd_socket/Makefile.am
116@@ -1,6 +1,7 @@
117 include $(top_srcdir)/example/Makefile.inc
118
119-noinst_PROGRAMS = udp_fwd_socket
120+inst_PROGRAMS = udp_fwd_socket
121+instdir=${exec_prefix}/ofp/bin
122
123 udp_fwd_socket_LDFLAGS = $(AM_LDFLAGS) -static
124
125diff --git a/example/udpecho/Makefile.am b/example/udpecho/Makefile.am
126index e64f2c0..a0c1085 100644
127--- a/example/udpecho/Makefile.am
128+++ b/example/udpecho/Makefile.am
129@@ -1,6 +1,7 @@
130 include $(top_srcdir)/example/Makefile.inc
131
132-noinst_PROGRAMS = udpecho
133+inst_PROGRAMS = udpecho
134+instdir=${exec_prefix}/ofp/bin
135
136 udpecho_LDFLAGS = $(AM_LDFLAGS) -static
137
138diff --git a/example/webserver/Makefile.am b/example/webserver/Makefile.am
139index 1dad1b6..230515e 100644
140--- a/example/webserver/Makefile.am
141+++ b/example/webserver/Makefile.am
142@@ -1,6 +1,7 @@
143 include $(top_srcdir)/example/Makefile.inc
144
145-noinst_PROGRAMS = webserver
146+inst_PROGRAMS = webserver
147+instdir=${exec_prefix}/ofp/bin
148
149 webserver_LDFLAGS = $(AM_LDFLAGS) -static
150
151diff --git a/example/webserver2/Makefile.am b/example/webserver2/Makefile.am
152index d9f4767..c53a9d2 100644
153--- a/example/webserver2/Makefile.am
154+++ b/example/webserver2/Makefile.am
155@@ -1,6 +1,7 @@
156 include $(top_srcdir)/example/Makefile.inc
157
158-noinst_PROGRAMS = webserver2
159+inst_PROGRAMS = webserver2
160+instdir=${exec_prefix}/ofp/bin
161
162 webserver2_LDFLAGS = $(AM_LDFLAGS) -static
163
164--
1652.9.3
166
diff --git a/recipes-extended/ofp/ofp/Fix-compilation-issue-with-redefinition-of-a-struct.patch b/recipes-extended/ofp/ofp/Fix-compilation-issue-with-redefinition-of-a-struct.patch
deleted file mode 100644
index 4163dc8e..00000000
--- a/recipes-extended/ofp/ofp/Fix-compilation-issue-with-redefinition-of-a-struct.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1ofp_netlink.c: do not include netinet/ip.h
2
3The struct iphdr is defined in netinet/ip.h and in linux/ip.h. The
4backwards compatible ofp_netlink.c is modified to include linux/ip.h.
5
6http://www.openfastpath.org/pipermail/openfastpath/2016-October/001330.html
7
8
9--- a/src/ofp_netlink.cold 2017-04-20 16:08:20.942851781 +0800
10+++ b/src/ofp_netlink.c 2017-04-20 16:08:39.222851148 +0800
11@@ -9,7 +9,7 @@
12 #include <stdio.h>
13 #include <string.h>
14 #include <netinet/in.h>
15-#include <netinet/ip.h>
16+#include <linux/ip.h>
17 #include <linux/netlink.h>
18 #include <linux/rtnetlink.h>
19 #include <linux/if_arp.h>
diff --git a/recipes-extended/ofp/ofp_git.bb b/recipes-extended/ofp/ofp_git.bb
index 1c6757ef..b8cb7eb8 100644
--- a/recipes-extended/ofp/ofp_git.bb
+++ b/recipes-extended/ofp/ofp_git.bb
@@ -6,11 +6,9 @@ SECTION = "console/network"
6LICENSE = "BSD-3-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=fbe4957c430eed6cc20521d4eb429fae" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=fbe4957c430eed6cc20521d4eb429fae"
8 8
9SRC_URI = "git://github.com/OpenFastPath/ofp.git;protocol=https \ 9SRC_URI = "git://github.com/qoriq-open-source/ofp.git;nobranch=1"
10 file://0001-Patch-to-install-ofp-example-applications.patch \ 10
11 file://Fix-compilation-issue-with-redefinition-of-a-struct.patch \ 11SRCREV = "fe66f4659f7d356f7aa73a8fb32fcf67c6cf1108"
12"
13SRCREV = "f7ea51b32450ba45d87aff79504e39fad801e7a7"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14
@@ -36,4 +34,4 @@ do_configure () {
36 34
37FILES_${PN} += "/usr/ofp/bin" 35FILES_${PN} += "/usr/ofp/bin"
38FILES_${PN}-dbg += "/usr/ofp/bin/.debug" 36FILES_${PN}-dbg += "/usr/ofp/bin/.debug"
39COMPATIBLE_MACHINE = "(ls2088a)" 37COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"