summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-07-05 17:41:52 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-05 15:08:52 -0300
commitad8c56b6823aeb91986e21f289aedf3fddfa47f6 (patch)
treef4b6ca36328262e40312e20a4165c8f42b7d3c94 /recipes-extended
parent942d9ddad881b9fb02cfb580239e2dfabc2c8a03 (diff)
downloadmeta-freescale-ad8c56b6823aeb91986e21f289aedf3fddfa47f6.tar.gz
secure-obj: update to 24d3133
*Include the following changes: 24d3133 - SOBJ_ENG_APP: Initialising uninitialised variables f979dc4 - SOBJ_APP: Adding option for creating fake pem file while importing object 2adc118 - APP: Miscellaneous changes 10f5c67 - APP: Resolving coverity issues 18d4422 - SEC_OBJ_ENG: Adding check if multiple objects are created with same index 9e21913 - Commit Update: SOBJ_APP:Adding option to save fake pem file *Update COMPATIBLE_MACHINE for ls1012a *Add ARCH for install path *Fix install path issue. *Add INSANE_SKIP for dev-elf,ldflags and dev-deps to fix QA Issue. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc4
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb21
2 files changed, 15 insertions, 10 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 3fd70eb8..3fc5b89d 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -12,7 +12,7 @@ LDFLAGS += "${TOOLCHAIN_OPTIONS}"
12 12
13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ 13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \
14" 14"
15SRCREV = "74befe01bda41f1c27b197ef2ab66e475e9a81b3" 15SRCREV = "24d31333bd50f212ac692db83a4a2d88d0dadb52"
16 16
17WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 17WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
18export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" 18export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
@@ -24,4 +24,4 @@ ALLOW_EMPTY_${PN} = "1"
24INHIBIT_PACKAGE_STRIP = "1" 24INHIBIT_PACKAGE_STRIP = "1"
25PARALLEL_MAKE = "" 25PARALLEL_MAKE = ""
26INSANE_SKIP_${PN} = "ldflags" 26INSANE_SKIP_${PN} = "ldflags"
27COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)" 27COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a|ls1012a)"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 103c089e..db881b19 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -9,6 +9,8 @@ export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
9export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" 9export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
10export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" 10export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
11export CROSS_COMPILE_TA = "${CROSS_COMPILE}" 11export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
12ARCH_qoriq-arm64 = "aarch64"
13ARCH_qoriq-arm = "arm"
12 14
13do_compile() { 15do_compile() {
14 unset LDFLAGS 16 unset LDFLAGS
@@ -23,15 +25,18 @@ do_compile() {
23} 25}
24 26
25do_install() { 27do_install() {
26 install -d ${D}${bindir}/secure_obj 28 install -d ${D}${bindir}
27 install -d ${D}${libdir}/secure_obj
28 install -d ${D}${includedir} 29 install -d ${D}${includedir}
29 cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${bindir}/secure_obj 30 install -d ${D}${base_libdir}/optee_armtz
30 cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}/secure_obj 31 install -d ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines
31 cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/secure_obj 32 cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${base_libdir}/optee_armtz
32 cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}/secure_obj 33 cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}
34 cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines
35 cp ${S}/securekey_lib/out/export/app/* ${D}${bindir}
36 cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}
33 cp ${S}/securekey_lib/out/export/include/* ${D}${includedir} 37 cp ${S}/securekey_lib/out/export/include/* ${D}${includedir}
34 cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}/secure_obj
35} 38}
36 39
37FILES_${PN} += "${libdir}/secure_obj" 40FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
41INSANE_SKIP_${PN} = "dev-deps ldflags"
42INSANE_SKIP_${PN}-dev = "ldflags dev-elf"