summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-07-05 17:41:51 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-05 15:08:37 -0300
commit942d9ddad881b9fb02cfb580239e2dfabc2c8a03 (patch)
tree336f4186346cd6a3f892491fdb8323c880acb486 /recipes-extended
parent301359c10339c9a304ed49f5a03202762f8415ef (diff)
downloadmeta-freescale-942d9ddad881b9fb02cfb580239e2dfabc2c8a03.tar.gz
dpdk: update to 9448fe7
*include the following changes: 9448fe7 - PVT:nxp: increase DPMCP counts e324b1f - crypto/armv8: fix HMAC supported digest sizes cba260d - net/ppfe: port enable/disable fix on running traffic 57a1ec9 - net/ppfe: mtu errata workaround for LS1012Rev1 72172d2 - net/ppfe: app rerun fix on running traffic 370758e - net/ppfe: jumbo setting removed during initialization faac20e - PVT:event/dpaa2: fix max port and parallel handling 8bc5683 - PVT:QDMA fix the IOVA as VA flag b97bb46 - PVT:net/dpaa: fix push mode init queue handling b2ad260 - PVT:bus/dpaa: fix LS1043 push mode disable patch 14096cb - crypto/openssl: sg support for inplace buffers f96e21c - net/ppfe: add ETH_HEADER and CRC in mtu 01bc62f - PVT:net/dpaa2: fix the prefetch rx to honor nb pkts 4420f8f - PVT: net/dpaa2: minor log fixes e52b626 - net/ppfe: fix crash on packet receive ed2048b - PVT: dpaa: change the LS1043 errata flag to compile time with id fdb1620 - nxp: make dynamic scripts executable f4c5760 - PVT: net/dpaa: check if fmc is executed 93862f8 - PVT: net/dpaa: disable default push mode for LS1043 64a9038 - PVT: bus/dpaa: pass vdqcr exact configuration from the user 04e4240 - crypto/dpaa_sec: convert phys call to iova calls 3d8f00e - doc/eventdev: fix double entry for dpaa 3156f0a - app/crypto-perf: check minimum lcore number 2d705f8 - net/liquidio: fix link state fetching during start 33ba176 - net/bnxt: fix Rx checksum flags 9073e33 - net/failsafe: fix duplicate event registration 2531da7 - net/failsafe: fix removed sub-device cleanup afdd810 - net/bonding: export mode 4 slave info routine 10180c8 - net/i40e: fix shifts of signed values d647255 - net/qede: fix unicast filter routine return code ce9aab5 - net/qede: fix missing loop index in Tx SG mode 30407bf - net/qede: fix multicast filtering 2219b5b - net/ixgbe: fix DCB configuration *fix gcc-8 build error *add l2fwd-qdma *set EXTRA_CFLAGS for oe_runmake Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch51
-rw-r--r--recipes-extended/dpdk/dpdk_17.11.bb7
2 files changed, 55 insertions, 3 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch b/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch
new file mode 100644
index 00000000..51987b53
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch
@@ -0,0 +1,51 @@
1From 7409d0b89f80a72d91e02dc9ec688a01723c3c66 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 4 Jul 2018 17:12:39 +0800
4Subject: [PATCH] fix gcc-8 build error
5
6Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
7---
8 examples/ipsec-secgw/parser.c | 6 ++----
9 mk/toolchain/gcc/rte.vars.mk | 2 +-
10 2 files changed, 3 insertions(+), 5 deletions(-)
11
12diff --git a/examples/ipsec-secgw/parser.c b/examples/ipsec-secgw/parser.c
13index 9d0ea46..b2b30e4 100644
14--- a/examples/ipsec-secgw/parser.c
15+++ b/examples/ipsec-secgw/parser.c
16@@ -544,8 +544,7 @@ parse_cfg_file(const char *cfg_filename)
17 goto error_exit;
18 }
19
20- strncpy(str + strlen(str), oneline,
21- strlen(oneline));
22+ strcpy(str + strlen(str), oneline);
23
24 continue;
25 }
26@@ -557,8 +556,7 @@ parse_cfg_file(const char *cfg_filename)
27 cfg_filename, line_num);
28 goto error_exit;
29 }
30- strncpy(str + strlen(str), oneline,
31- strlen(oneline));
32+ strcpy(str + strlen(str), oneline);
33
34 str[strlen(str)] = '\n';
35 if (cmdline_parse(cl, str) < 0) {
36diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk
37index 3b907e2..cc63da8 100644
38--- a/mk/toolchain/gcc/rte.vars.mk
39+++ b/mk/toolchain/gcc/rte.vars.mk
40@@ -75,7 +75,7 @@ WERROR_FLAGS := -W -Wall -Wstrict-prototypes -Wmissing-prototypes
41 WERROR_FLAGS += -Wmissing-declarations -Wold-style-definition -Wpointer-arith
42 WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual
43 WERROR_FLAGS += -Wformat-nonliteral -Wformat-security
44-WERROR_FLAGS += -Wundef -Wwrite-strings
45+WERROR_FLAGS += -Wundef -Wwrite-strings -Wno-cast-function-type
46
47 ifeq ($(RTE_DEVEL_BUILD),y)
48 WERROR_FLAGS += -Werror
49--
502.7.4
51
diff --git a/recipes-extended/dpdk/dpdk_17.11.bb b/recipes-extended/dpdk/dpdk_17.11.bb
index 43a18599..2010e0c2 100644
--- a/recipes-extended/dpdk/dpdk_17.11.bb
+++ b/recipes-extended/dpdk/dpdk_17.11.bb
@@ -11,8 +11,9 @@ inherit module
11 11
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \ 12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \
13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ 13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
14 file://0001-fix-gcc-8-build-error.patch \
14" 15"
15SRCREV = "11d461d88390eb77bbf695eeddaad8e6f6cc25ce" 16SRCREV = "9448fe7ff3cf1367dbc92b05a9ae386b21ff7ad2"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19
@@ -40,12 +41,12 @@ do_install() {
40 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y CONFIG_RTE_LIBRTE_PMD_OPENSSL=y 41 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
41 42
42 # Build and install the DPDK examples 43 # Build and install the DPDK examples
43 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do 44 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-qdma examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do
44 temp=`basename ${APP}` 45 temp=`basename ${APP}`
45 if [ ${temp} = "ipsec-secgw" ] || [ ${temp} = "l2fwd-crypto" ]; then 46 if [ ${temp} = "ipsec-secgw" ] || [ ${temp} = "l2fwd-crypto" ]; then
46 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} CONFIG_RTE_LIBRTE_PMD_OPENSSL=y 47 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} CONFIG_RTE_LIBRTE_PMD_OPENSSL=y
47 else 48 else
48 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP} 49 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" EXTRA_CFLAGS="--sysroot=${STAGING_DIR_HOST} -I${STAGING_INCDIR}" -C ${APP}
49 fi 50 fi
50 51
51 [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example 52 [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example