summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-30 17:10:01 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 09:58:34 -0200
commit9102e13ea658103845188fe556163932c8d16b2a (patch)
tree2e3f091defe58ab294c9cead84046ff72c85010c /recipes-extended
parent67fb6f1e85eb9602ee78b42ee1fff64512b75de9 (diff)
downloadmeta-freescale-9102e13ea658103845188fe556163932c8d16b2a.tar.gz
dpdk: update recipe
update to 076aa8e *include the following changes: 076aa8e - bus/fslmc: change the eqcr stashing threshold to 1 adc0955 - net/dpaa: Change default tail drop size to 256. a3921f8 - net/dpaa2 : Revert "enable fetching hash result from hardware" e901680 - net/dpaa2:Setting correct frame size in dev_mtu_set d61cd8f - net/dpaa:Setting correct frame size in dev_mtu_set 8bff395 - Merge branch '17.05-next-qoriq' into 17.05-qoriq 14f2b6f - Merge remote-tracking branch 'stable/17.05' into hotfix/DPDK-1036_stable_17.05-to_qoriq 5afa218 - Merge pull request #482 in GITAM/dpdk from DPDK-178-BE to 17.05-next-qoriq 0192452 - net/dpaa: add frame count based tail drop with CGR d5026f6 - net/dpaa2: removing double env variable for Tail drop setting 7468d34 - net/ixgbe: fix compilation on ARM BE c493e1f - net/i40e: fix compilation on ARM BE f502ece - bus/dpaa: fix compilation on ARM BE bfa94d6 - lpm: fix compilation on ARM BE 815ea7d - pmdinfogen: fix cross compilation for ARM BE 14c81be - Merge pull request #478 in GITAM/dpdk from DPDK-806-phyaddr to 17.05-next-qoriq b31eb4d - Merge pull request #472 in GITAM/dpdk from DPDK-1010-misc to 17.05-next-qoriq 11c1c9e - bus/dpaa: fix missing symbol for shared build 07e60bd - net/dpaa2: set queues if reconfiguration is done 1918d8c - test/test: improve dequeue logic for crypto operation b0c1ecb - net/dpaa2: support to configure taildrop size 223fe63 - net/dpaa2: support rx query count api 3333924 - net/dpaa2: enable parse error packet to driver by default 4eec0f0 - net/dpaa: optimize phy to virt for push mode queue 8b3e1c9 - net/dpaa: removing the data prefetch from driver 7505585 - net/dpaa: increase the tail drop length 23505e0 - net/dpaa: optional support for push mode queues cad1ddb - crypto/dpaa: optimizing the virt to phy conversion 4c84009 - net/dpaa: optimize the phy to virt conversion d44f70f - mempool: indicate if mempool elements are allocated from muliple memzones 77e5fd8 - errata: dpaa - change the block size flag name in alignment with upstream 305c71a - errata: mbuf - dpaa errata to use family mask cd6f661 - bus/dpaa: adding fq as a parameter for portal get 2daf985 - Merge pull request #474 in GITAM/dpdk from bugfix/DPDK-845-correction to 17.05-next-qoriq 3a2ea0d - examples/ipsec-secgw: add protocol offload cfg files for 64x64 tunne *install nxp config files Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk_16.07.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.07.bb b/recipes-extended/dpdk/dpdk_16.07.bb
index c825c3bb..9805af32 100644
--- a/recipes-extended/dpdk/dpdk_16.07.bb
+++ b/recipes-extended/dpdk/dpdk_16.07.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/qoriq-open-source/dpdk.git;nobranch=1 \
13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ 13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
14 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ 14 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \
15" 15"
16SRCREV = "3d7a6ae1745a2f60f76afd3ad3ca57329388168c" 16SRCREV = "076aa8e2f9a4ad7e0a020f5c574371d92afe4a60"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
@@ -52,7 +52,8 @@ do_install() {
52 rm -fr ${D}/lib/modules/* 52 rm -fr ${D}/lib/modules/*
53 install -d ${D}/lib/modules/${KERNEL_VERSION}/dpdk 53 install -d ${D}/lib/modules/${KERNEL_VERSION}/dpdk
54 install -m 0755 ${S}/${RTE_TARGET}/kmod/rte_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/dpdk/ 54 install -m 0755 ${S}/${RTE_TARGET}/kmod/rte_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/dpdk/
55 55 install -d ${D}/${bindir}/dpdk-example/extras
56 cp -rf ${S}/nxp/* ${D}/${bindir}/dpdk-example/extras/
56 rm ${D}/${datadir}/${RTE_TARGET}/app/dpdk-pmdinfogen 57 rm ${D}/${datadir}/${RTE_TARGET}/app/dpdk-pmdinfogen
57 58
58 chown root:root -R ${D} 59 chown root:root -R ${D}