summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-03-16 13:03:36 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-02 10:30:13 -0300
commit0dc0c701511959f1e71c97a3323ea012f3f92bb4 (patch)
treee8991e9cc0b0984828158b86268fcdc6b6a7ebda /recipes-extended
parent2939a93f87c9f5d6035af6c14c4f362fdc8feef0 (diff)
downloadmeta-freescale-0dc0c701511959f1e71c97a3323ea012f3f92bb4.tar.gz
pktgen-dpdk: add recipes
*include the following changes: ffbe7be - update merge 1b0af69 - Merge branch 'master' into dev 3bd5082 - update version 070b4e0 - fix compile erro and config support 854df24 - remove mbuf refcnt verification 5160316 - pktgen-dpdk: Add support for make O=OUTPUT option 5e28413 - Fix the protocol settings with the range command. 9e34cf6 - fix sequence command index wrong e99720d - fix cli and add more test scripts 3d15dbf - update for DPDK 17.11 changes df45b16 - merge from master tree fda09ea - add the new format for the seq command b92d6fa - update tests for new seq commandstest/set_seq.cmd 819c936 - Fix up style of code c589388 - rework seq command to add cos and tos 83646b6 - Pktgen bug fixs and new seq commands 622e6f2 - add sigpipe to signal support 19063c2 - update map file 3bfdccd - Merge branch 'master' of ssh://linksys/~rkwiles/projects/intel/pktgen b475547 - Update version and changelog 139d1d8 - fix build for standard DPDK 308d810 - Merge branch 'master' of ssh://linksys/~rkwiles/projects/intel/pktgen 3926396 - update version and changelog ee6a520 - fix up cfg files 63638ec - remove Lua for CLI builds cc604b3 - fix processing of ARP packets 06ef19d - increase the burst size b066627 - remove string functions from DPDK 4c5ede1 - remove files ac09238 - increase the memory per socket 8e770a9 - update for vscode files we need to keep 4078d68 - fix tty output on quit 319c346 - Merge branch 'master' of ssh://linksys/~rkwiles/projects/intel/pktgen 8a4d8fc - update version to 3.4.0 03c8ea7 - change MIF config Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb
new file mode 100644
index 00000000..ae62d544
--- /dev/null
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "PKTGEN DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8120b89a783571da3cb492c35ac6b1f9"
4
5DEPENDS += "libpcap dpdk"
6
7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=http;nobranch=1"
8SRCREV = "ffbe7becf8dd75fd7d46b97b10374531878cb9c5"
9
10S = "${WORKDIR}/git"
11
12DPAA_VER ?= "dpaa"
13export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
14export RTE_SDK = "${RECIPE_SYSROOT}/usr/share"
15
16EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"'
17
18do_compile() {
19 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
20 oe_runmake
21}
22
23do_install() {
24 install -d ${D}${bindir}/
25 cp -f ${S}/app/arm64-dpaa-linuxapp-gcc/pktgen ${D}${bindir}/
26 cp -f ${S}/Pktgen.lua ${D}${bindir}/
27}
28
29INSANE_SKIP_${PN} = "ldflags"
30INHIBIT_PACKAGE_STRIP = "1"
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32PARALLEL_MAKE = ""