diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-10-15 10:48:12 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-10-21 09:07:06 -0300 |
commit | 46c0867feb032d3867ae8377274323dbbf179bde (patch) | |
tree | cd554a0cca3a1ad43585844e76a51dee61e4039e /recipes-extended | |
parent | b3f08d65948e8caee957c71b3b033549f1486f43 (diff) | |
download | meta-freescale-46c0867feb032d3867ae8377274323dbbf179bde.tar.gz |
dpdkvpp: update to a36da6a
*update to lsdk 1909 tag
include the following changes:
a36da6a - Merge pull request #1050 in GITAM/dpdk from 18.11-qoriq-dev to 18.11-qoriq
eb00ab7 - PVT: examples/l3fwd: fix jumbo packet drop issue
3e8b2c4 - Merge pull request #1046 in GITAM/dpdk from 18.11-qoriq-dev to 18.11-qoriq
a1a4961 - crypto/dpaa2_sec: compile off hw debug prints
0372f8e - crypto/dpaa2_sec: remove logs from datapath
beab8d5 - crypto/dpaa2_sec: fix SG dynamic ctxt patch
4ff9915 - app/crypto-perf: fix the multi seg buffer loop
3bf73bd - app/crypto-perf: add check for out-of-place case
5bba072 - app/crypto-perf: check range of socket id
371ba75 - Merge pull request #1043 in GITAM/dpdk from bugfix/DPDK-1983 to 18.11-qoriq-dev
e9e016f - crypto/dpaa_sec: change per cryptodev pool to per qp
2ff8c21 - examples/ip_fragmentation: add Scatter support to receive jumboframes
0bfaa19 - crypto/dpaa_sec: fix pdcp check ordering
7e6f996 - Merge pull request #1039 in GITAM/dpdk from 18.11-qoriq-dev to 18.11-qoriq
e703118 - Merge pull request #1031 in GITAM/dpdk from DPDK-1951-sg7 to 18.11-qoriq-dev
7a68386 - crypto/dpaa2_sec: fix to allocate context as per num_segs
9df93ab - PVT: misc fix for 32 bit and PPC compilation
c67478c - event/dpaa2: fix selftest shared build
58b5127 - crypto/dpaa2: fix clang compilation for PDCP
d48c6cf - Merge pull request #918 in GITAM/dpdk from feature/DPDK-990 to 18.11-qoriq-dev
a598283 - Merge pull request #1037 in GITAM/dpdk from DPDK-1945 to 18.11-qoriq-dev
*update TLSDIALECT to "ftls-model=local-dynamic"
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/vpp-core/dpdkvpp.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/vpp-core/dpdkvpp.bb b/recipes-extended/vpp-core/dpdkvpp.bb index 5e355fdc..309a6101 100644 --- a/recipes-extended/vpp-core/dpdkvpp.bb +++ b/recipes-extended/vpp-core/dpdkvpp.bb | |||
@@ -9,7 +9,7 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr | |||
9 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ | 9 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ |
10 | file://0004-update-WERROR_FLAGS.patch \ | 10 | file://0004-update-WERROR_FLAGS.patch \ |
11 | " | 11 | " |
12 | SRCREV = "0123ced10233e7de8a72f743e2ae7e9791124f07" | 12 | SRCREV = "a36da6a94243015b228c15b8b9aa1e650fd4b96d" |
13 | 13 | ||
14 | RDEPENDS_${PN} += "python-subprocess" | 14 | RDEPENDS_${PN} += "python-subprocess" |
15 | DEPENDS = "virtual/kernel openssl" | 15 | DEPENDS = "virtual/kernel openssl" |
@@ -33,7 +33,7 @@ DPDK_RTE_TARGET_armv7ve = "${ARCH}-armv7a-linuxapp-gcc" | |||
33 | DPDK_RTE_TARGET ?= "${ARCH}-dpaa-linuxapp-gcc" | 33 | DPDK_RTE_TARGET ?= "${ARCH}-dpaa-linuxapp-gcc" |
34 | 34 | ||
35 | TLSDIALECT ?= "" | 35 | TLSDIALECT ?= "" |
36 | TLSDIALECT_aarch64 ?= "-mtls-dialect=trad" | 36 | TLSDIALECT_aarch64 ?= "-ftls-model=local-dynamic" |
37 | 37 | ||
38 | export RTE_TARGET = "${DPDK_RTE_TARGET}" | 38 | export RTE_TARGET = "${DPDK_RTE_TARGET}" |
39 | export RTE_OUTPUT = "${S}/${RTE_TARGET}" | 39 | export RTE_OUTPUT = "${S}/${RTE_TARGET}" |
@@ -61,7 +61,7 @@ do_compile () { | |||
61 | oe_runmake CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y \ | 61 | oe_runmake CONFIG_RTE_EAL_IGB_UIO=n CONFIG_RTE_KNI_KMOD=y \ |
62 | CONFIG_RTE_LIBRTE_PMD_OPENSSL=y \ | 62 | CONFIG_RTE_LIBRTE_PMD_OPENSSL=y \ |
63 | EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" \ | 63 | EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" \ |
64 | EXTRA_CFLAGS="${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} -I${STAGING_INCDIR} -fPIC ${TLSDIALECT}" \ | 64 | EXTRA_CFLAGS="${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} -I${STAGING_INCDIR} -Ofast -fPIC ${TLSDIALECT}" \ |
65 | CROSS="${TARGET_PREFIX}" \ | 65 | CROSS="${TARGET_PREFIX}" \ |
66 | prefix="" LDFLAGS="${TUNE_LDARGS}" WERROR_FLAGS="-w" V=1 | 66 | prefix="" LDFLAGS="${TUNE_LDARGS}" WERROR_FLAGS="-w" V=1 |
67 | 67 | ||