summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-26 15:16:39 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-04 18:33:08 -0300
commitd17f1008708987b9cc75e075241e07882ad89289 (patch)
treed1d3bd50e855438b605ee321890e8252a6606269 /recipes-extended
parent93190f273fe51716bf407a809f8d7592c72cdd81 (diff)
downloadmeta-freescale-d17f1008708987b9cc75e075241e07882ad89289.tar.gz
secure-obj: update recipes
*drop Python dependency in RDEPENDS *mp_verify and *_app will be install Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc2
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb3
2 files changed, 3 insertions, 2 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 107e46e9..166c874a 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Secure Object"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" 4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
5RDEPENDS_${PN} = "bash libcrypto libssl python" 5RDEPENDS_${PN} = "bash libcrypto libssl"
6 6
7DEPENDS += "python-pycrypto-native" 7DEPENDS += "python-pycrypto-native"
8 8
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 6af18ff9..2d723738 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -34,7 +34,8 @@ do_install() {
34 cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${base_libdir}/optee_armtz 34 cp ${S}/secure_storage_ta/ta/b05bcf48-9732-4efa-a9e0-141c7c888c34.ta ${D}${base_libdir}/optee_armtz
35 cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir} 35 cp ${S}/securekey_lib/out/export/lib/libsecure_obj.so ${D}${libdir}
36 cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines 36 cp ${S}/secure_obj-openssl-engine/libeng_secure_obj.so ${D}${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines
37 cp ${S}/securekey_lib/out/export/app/* ${D}${bindir} 37 cp ${S}/securekey_lib/out/export/app/*_app ${D}${bindir}
38 cp ${S}/securekey_lib/out/export/app/mp_verify ${D}${bindir}
38 cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir} 39 cp ${S}/secure_obj-openssl-engine/app/sobj_eng_app ${D}${bindir}
39 cp ${S}/securekey_lib/out/export/include/* ${D}${includedir} 40 cp ${S}/securekey_lib/out/export/include/* ${D}${includedir}
40 rm -rf ${D}${bindir}/test 41 rm -rf ${D}${bindir}/test