summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-22 10:51:02 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-01-23 17:51:00 -0300
commit08063be6fa9a4f8541eca8e92e5f678ed3234fdd (patch)
treea5d34984cd4cf80edde9456bd8653e87aadd2811 /recipes-extended
parentabc7fdf4cefc49257c739c46263bdf489230868a (diff)
downloadmeta-freescale-08063be6fa9a4f8541eca8e92e5f678ed3234fdd.tar.gz
recipes-extended: update recipes to use python3
Pythin2 is EOL and has been dropped on oe-core, therefore previous classes are not available anymore. Update recipes to inherit new python3 classes. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb2
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc2
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
index fd9d3a61..f87d8f78 100644
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
5DEPENDS = "dpdk python-six-native coreutils-native" 5DEPENDS = "dpdk python-six-native coreutils-native"
6RDEPENDS_${PN} = "bash libcrypto libssl python" 6RDEPENDS_${PN} = "bash libcrypto libssl python"
7 7
8inherit pythonnative 8inherit python3native
9 9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ 10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \
11" 11"
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 166c874a..f3f1d2c7 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -6,7 +6,7 @@ RDEPENDS_${PN} = "bash libcrypto libssl"
6 6
7DEPENDS += "python-pycrypto-native" 7DEPENDS += "python-pycrypto-native"
8 8
9inherit pythonnative 9inherit python3native
10 10
11LDFLAGS += "${TOOLCHAIN_OPTIONS}" 11LDFLAGS += "${TOOLCHAIN_OPTIONS}"
12 12
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
index 53437d1a..9f6d1125 100644
--- a/recipes-extended/vpp-core/vpp-core.bb
+++ b/recipes-extended/vpp-core/vpp-core.bb
@@ -22,7 +22,7 @@ DEPENDS_class-native = "openssl-native python-ply-native util-linux-native"
22 22
23inherit cmake 23inherit cmake
24inherit pkgconfig 24inherit pkgconfig
25inherit python-dir pythonnative 25inherit python3-dir python3native
26 26
27export ARCH="arm64" 27export ARCH="arm64"
28export OPENSSL_PATH = "${RECIPE_SYSROOT}" 28export OPENSSL_PATH = "${RECIPE_SYSROOT}"