diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-01-22 10:51:02 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-01-23 17:51:00 -0300 |
commit | 08063be6fa9a4f8541eca8e92e5f678ed3234fdd (patch) | |
tree | a5d34984cd4cf80edde9456bd8653e87aadd2811 /recipes-extended | |
parent | abc7fdf4cefc49257c739c46263bdf489230868a (diff) | |
download | meta-freescale-08063be6fa9a4f8541eca8e92e5f678ed3234fdd.tar.gz |
recipes-extended: update recipes to use python3
Pythin2 is EOL and has been dropped on oe-core, therefore previous
classes are not available anymore.
Update recipes to inherit new python3 classes.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb | 2 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 2 | ||||
-rw-r--r-- | recipes-extended/vpp-core/vpp-core.bb | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb index fd9d3a61..f87d8f78 100644 --- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb +++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" | |||
5 | DEPENDS = "dpdk python-six-native coreutils-native" | 5 | DEPENDS = "dpdk python-six-native coreutils-native" |
6 | RDEPENDS_${PN} = "bash libcrypto libssl python" | 6 | RDEPENDS_${PN} = "bash libcrypto libssl python" |
7 | 7 | ||
8 | inherit pythonnative | 8 | inherit python3native |
9 | 9 | ||
10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ | 10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ |
11 | " | 11 | " |
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc index 166c874a..f3f1d2c7 100644 --- a/recipes-extended/secure-obj/secure-obj.inc +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -6,7 +6,7 @@ RDEPENDS_${PN} = "bash libcrypto libssl" | |||
6 | 6 | ||
7 | DEPENDS += "python-pycrypto-native" | 7 | DEPENDS += "python-pycrypto-native" |
8 | 8 | ||
9 | inherit pythonnative | 9 | inherit python3native |
10 | 10 | ||
11 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" | 11 | LDFLAGS += "${TOOLCHAIN_OPTIONS}" |
12 | 12 | ||
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb index 53437d1a..9f6d1125 100644 --- a/recipes-extended/vpp-core/vpp-core.bb +++ b/recipes-extended/vpp-core/vpp-core.bb | |||
@@ -22,7 +22,7 @@ DEPENDS_class-native = "openssl-native python-ply-native util-linux-native" | |||
22 | 22 | ||
23 | inherit cmake | 23 | inherit cmake |
24 | inherit pkgconfig | 24 | inherit pkgconfig |
25 | inherit python-dir pythonnative | 25 | inherit python3-dir python3native |
26 | 26 | ||
27 | export ARCH="arm64" | 27 | export ARCH="arm64" |
28 | export OPENSSL_PATH = "${RECIPE_SYSROOT}" | 28 | export OPENSSL_PATH = "${RECIPE_SYSROOT}" |