diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-10-15 13:28:31 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-10-21 09:07:06 -0300 |
commit | f29ce8ff0cd3ee61ddbbc897227bed2e70933323 (patch) | |
tree | 797d44efd10f922ddaa7744185e15324de0b70e1 /recipes-extended | |
parent | 24394a3c7bf5f8c3e6e84421363f141d5eeb721f (diff) | |
download | meta-freescale-f29ce8ff0cd3ee61ddbbc897227bed2e70933323.tar.gz |
tsntool: add recipes
*update to lsdk 1909 tag
include the following changes:
30a0320 - demos:cnc: add Qci enable/disable operations provide to yang
a27ea6d - demos:cnc: fix the interfaces and bridges types xml getconfig infrormation
ccfc0ae - demos:cnc:add Qci support
50d653b - libtsn: fix compile error
a156db9 - tsntool: correct the command name in help info
6739dcb - libtsn: add optional function to monitor the operation of configuring TSN via libtsn
eadb457 - Add version v0.3 tag
42ee8f3 - libtsn: add qbu get status showing status
a22cdc8 - demos:cnc: update the get-config feedback "interfaces" to "if:interfaces"
495575c - demo:cnc: fix the get-config button out of block when brower pixel low resolution
a411c7c - demo:cnc: fix config-change place and enable for port
3d28bea - qbvset: fix overflow of qbv list
1b424e9 - Makefile : add format-security to fix gcc 9.2 build error fix the below error |main/readinput.c:267:3: error: format not a string |literal and no format arguments [-Werror=format-security]
7ec5761 - cnc: fix the qbv disable setting
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/tsntool/tsntool_git.bb | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb new file mode 100644 index 00000000..977d43ad --- /dev/null +++ b/recipes-extended/tsntool/tsntool_git.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | SUMMARY = "Configure TSN funtionalitie" | ||
2 | DESCRIPTION = "A tool to configure TSN funtionalities in user space" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ef58f855337069acd375717db0dbbb6d" | ||
5 | |||
6 | DEPENDS = "cjson libnl readline" | ||
7 | |||
8 | inherit pkgconfig | ||
9 | |||
10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1" | ||
11 | SRCREV = "30a0320eb4a1798ac3d6258a2e02d863e60a1582" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | do_compile_prepend() { | ||
16 | mkdir -p ${S}/include/linux | ||
17 | cp -r ${STAGING_KERNEL_DIR}/include/uapi/linux/tsn.h ${S}/include/linux | ||
18 | } | ||
19 | do_install() { | ||
20 | install -d ${D}${bindir} ${D}${libdir} | ||
21 | install -m 0755 ${S}/tsntool ${D}${bindir} | ||
22 | install -m 0755 ${S}/tools/event ${D}${bindir}/ | ||
23 | install -m 0755 ${S}/tools/timestamping ${D}${bindir}/ | ||
24 | install -m 0755 ${S}/libtsn.so ${D}${libdir} | ||
25 | } | ||
26 | |||
27 | PACKAGES = "${PN}-dbg ${PN}" | ||
28 | FILES_${PN} = "${libdir}/libtsn.so ${bindir}/*" | ||
29 | INSANE_SKIP_${PN} += "file-rdeps rpaths dev-so" | ||
30 | COMPATIBLE_MACHINE = "(qoriq)" | ||
31 | PARALLEL_MAKE = "" | ||