diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-04-01 13:53:24 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-04-11 09:00:13 -0300 |
commit | 9524d32736f3f627461cdad250f3e2280f78173e (patch) | |
tree | 2e712af352be42b4fdfcbe33f55bcd75a871eff1 /recipes-extended | |
parent | 83c2393eacf710f676e7c453df9200e8a06c39d7 (diff) | |
download | meta-freescale-9524d32736f3f627461cdad250f3e2280f78173e.tar.gz |
ovs-dpdk: Upgrade version to 2.10
*update to lsdk 1903 tag
include the following changes:
4d82df3 - netdev-dpdk: have env based configurable number of packet buffers
92d8a38 - travis: Remove 'sudo' configuration.
1a5ba65 - dpif-netlink: Free leaked ofpbuf by using ofpbuf_delete
d3ad005 - OVN: update RA next_announce according to {min, max}_interval
93a59ee - rconn: Avoid occasional immediate connection failures.
8896ba7 - dpdk: Fix case-sensitivity of dpdk-init knob.
a552f3a - ofp-actions: Make all actions a multiple of OFPACT_ALIGNTO bytes.
547e119 - conntrack: Fix L4 csum for V6 extension hdr pkts.
5b17e49 - packets: Change return type for 'packet_csum_upperlayer6()'.
b7478c8 - ovsdb-client: Fix typo.
5520531 - ofctl: break the loop if ovs_pcap_read returns error
8e02ed4 - Revert "ovs-tcpdump: Fix an undefined variable"
2a2ca07 - netlink: added check to prevent netlink attribute overflow
a508017 - conntrack: Keep Address Sanitizer happy.
6ecc5fc - Initialize the right database.
fc8e73f - monitor: Fix crash when monitor condition adds new columns.
bf94ce0 - conntrack: Exclude l2 padding in 'conn_key_extract()'.
057ac78 - dp-packet: Add 'dp_packet_l3_size()'.
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r-- | recipes-extended/ovs-dpdk/ovs-dpdk/0001-automake-remove-static-key-word.patch | 27 | ||||
-rw-r--r-- | recipes-extended/ovs-dpdk/ovs-dpdk_2.10.bb (renamed from recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb) | 7 |
2 files changed, 3 insertions, 31 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk/0001-automake-remove-static-key-word.patch b/recipes-extended/ovs-dpdk/ovs-dpdk/0001-automake-remove-static-key-word.patch deleted file mode 100644 index e438e476..00000000 --- a/recipes-extended/ovs-dpdk/ovs-dpdk/0001-automake-remove-static-key-word.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 9327cc35bc9e7040d9de743caebd0fee72bbd619 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Fri, 12 Oct 2018 10:53:00 +0800 | ||
4 | Subject: [PATCH] automake: remove static key word | ||
5 | |||
6 | Upstream-Status: Inappropriate [embedded specific] | ||
7 | |||
8 | Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> | ||
9 | --- | ||
10 | lib/automake.mk | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/lib/automake.mk b/lib/automake.mk | ||
14 | index 8ecad12..f9016a0 100644 | ||
15 | --- a/lib/automake.mk | ||
16 | +++ b/lib/automake.mk | ||
17 | @@ -439,6 +439,7 @@ lib/dhparams.c: lib/dh1024.pem lib/dh2048.pem lib/dh4096.pem | ||
18 | openssl dhparam -C -in $(srcdir)/lib/dh2048.pem -noout && \ | ||
19 | openssl dhparam -C -in $(srcdir)/lib/dh4096.pem -noout) \ | ||
20 | | sed 's/\(get_dh[0-9]*\)()/\1(void)/' > lib/dhparams.c.tmp && \ | ||
21 | + sed -i '/\(get_dh[0-9]*\)(void)/s/^static//' lib/dhparams.c.tmp && \ | ||
22 | mv lib/dhparams.c.tmp lib/dhparams.c | ||
23 | else | ||
24 | lib_libopenvswitch_la_SOURCES += lib/stream-nossl.c | ||
25 | -- | ||
26 | 2.7.4 | ||
27 | |||
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.10.bb index b1994c5c..3ffa9a07 100644 --- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.9.bb +++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.10.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | DESCRIPTION = "OVS DPDK" | 1 | DESCRIPTION = "OVS DPDK" |
2 | LICENSE = "BSD" | 2 | LICENSE = "BSD" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" |
4 | 4 | ||
5 | DEPENDS = "dpdk python-six-native coreutils-native" | 5 | DEPENDS = "dpdk python-six-native coreutils-native" |
6 | RDEPENDS_${PN} = "bash libcrypto libssl python" | 6 | RDEPENDS_${PN} = "bash libcrypto libssl python" |
@@ -8,9 +8,8 @@ RDEPENDS_${PN} = "bash libcrypto libssl python" | |||
8 | inherit pythonnative | 8 | inherit pythonnative |
9 | 9 | ||
10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ | 10 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \ |
11 | file://0001-automake-remove-static-key-word.patch \ | ||
12 | " | 11 | " |
13 | SRCREV = "24eec4133f03b0a5a8f903577bc87603577150c0" | 12 | SRCREV = "4d82df36993ca502d33afa305fbd2a41a950106d" |
14 | 13 | ||
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
16 | 15 | ||
@@ -47,4 +46,4 @@ do_install() { | |||
47 | ALLOW_EMPTY_${PN} = "1" | 46 | ALLOW_EMPTY_${PN} = "1" |
48 | INHIBIT_PACKAGE_STRIP = "1" | 47 | INHIBIT_PACKAGE_STRIP = "1" |
49 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 48 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
50 | COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)" | 49 | COMPATIBLE_MACHINE = "(qoriq-arm64)" |