summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vpp-core/vpp-core
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-10 16:01:09 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commitb7bf801bf6fc9c7b210602c933bbb8c42b92518d (patch)
treeb41a271be78d3bf8f7834953965c0226b67393bc /recipes-extended/vpp-core/vpp-core
parent60585d192208ca1cbebe1c7723ebb4c9d4649046 (diff)
downloadmeta-freescale-b7bf801bf6fc9c7b210602c933bbb8c42b92518d.tar.gz
vpp-core: update to ff7bf7b
*update to lsdk 1906 tag include the following changes: ff7bf7b - Merge pull request #32 in DQNS/vpp from ~NXA12342/vpp:19.01.1_devel to 19.01.1 5c2b539 - PVT: ipsec: Fixed capability matching for openssl based sha1 authentication a24588f - PVT: dpdk_plugin: introducing ipsec protocol offload 33d0d81 - Fixed Flexbuild integration issues c200b3f - dpdk-ipsec: Fixed ramdom Crash in esp traffic 2a0a031 - Enhanced the VPP startup configuration 05bce64 - Merge pull request #30 in DQNS/vpp from ~NXA19696/vpp:19.01.1 to 19.01.1 c63f8ad - Fixed RPM packaging of VPP libs w.r.t Tag format 85e9d4d - Merge pull request #29 in DQNS/vpp from ~NXA19696/vpp:19.01.1 to 19.01.1 26d2455 - Adding README for NXP platforms 9df88fa - Handled review comments d66c318 - Fixed Debian packing support for arm64 platform 513a05a - Fix for using Best mem pool ops as per platform d0f5fa4 - Updating path for cmake cross compile file fe17e96 - More Compilation Fixes e64c6ca - Cross compilation & RPM pkging known issues cbd68cb - 19.01.1 Release Notes 3262adc - cmake: fix out-of-git-tree build d302022 - Fix vpp crashing when attempting to run in kubernetes Pod 6342e48 - tcp: allow future acks if in window 46ee286 - IPSEC: crash on SA dump when SA are bound to tunnels bad0bcd - Fix crash in barrier sync when vlib_worker_threads is zero 372a33e - buffer chain linearization *update PV to "19.01" *refresh patch *update DEPENDS Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/vpp-core/vpp-core')
-rw-r--r--recipes-extended/vpp-core/vpp-core/0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch26
-rw-r--r--recipes-extended/vpp-core/vpp-core/0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch42
-rw-r--r--recipes-extended/vpp-core/vpp-core/0001-vpp-core-fix-package_qa-error.patch27
3 files changed, 95 insertions, 0 deletions
diff --git a/recipes-extended/vpp-core/vpp-core/0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch b/recipes-extended/vpp-core/vpp-core/0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch
new file mode 100644
index 00000000..7f838476
--- /dev/null
+++ b/recipes-extended/vpp-core/vpp-core/0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch
@@ -0,0 +1,26 @@
1From 6dab3ad3f91ebcdb16eb9bbb37383718793b675a Mon Sep 17 00:00:00 2001
2From: babak sarashki <babak.sarashki@windriver.com>
3Date: Sat, 29 Sep 2018 09:57:05 -0700
4Subject: [PATCH] GCC above 5.4 fails when we specify arch funattribute.
5
6Here we are as a workaround setting target.
7---
8 src/vppinfra/cpu.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/vppinfra/cpu.h b/src/vppinfra/cpu.h
12index 110815c..618276c 100644
13--- a/src/vppinfra/cpu.h
14+++ b/src/vppinfra/cpu.h
15@@ -27,7 +27,7 @@
16
17 #if __x86_64__ && CLIB_DEBUG == 0
18 #define foreach_march_variant(macro, x) \
19- macro(avx2, x, "arch=core-avx2")
20+ macro(avx2, x, "avx2")
21 #else
22 #define foreach_march_variant(macro, x)
23 #endif
24--
252.7.4
26
diff --git a/recipes-extended/vpp-core/vpp-core/0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch b/recipes-extended/vpp-core/vpp-core/0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch
new file mode 100644
index 00000000..7f80b75f
--- /dev/null
+++ b/recipes-extended/vpp-core/vpp-core/0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch
@@ -0,0 +1,42 @@
1From 205ebcd8eed1347330e7ebda616970d880bb03d7 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Tue, 9 Jul 2019 10:36:27 +0200
4Subject: [PATCH] getcpu:rename getcpu to avoid conflict with glibc >= 2.29
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
9---
10 src/vppinfra/linux/syscall.h | 2 +-
11 src/vppinfra/pmalloc.c | 2 +-
12 2 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/src/vppinfra/linux/syscall.h b/src/vppinfra/linux/syscall.h
15index 1ae029d..fa65a47 100644
16--- a/src/vppinfra/linux/syscall.h
17+++ b/src/vppinfra/linux/syscall.h
18@@ -20,7 +20,7 @@
19 #include <sys/syscall.h>
20
21 static inline int
22-getcpu (unsigned *cpu, unsigned *node, void *tcache)
23+getcpu0 (unsigned *cpu, unsigned *node, void *tcache)
24 {
25 return syscall (__NR_getcpu, cpu, node, tcache);
26 }
27diff --git a/src/vppinfra/pmalloc.c b/src/vppinfra/pmalloc.c
28index 365ee04..7dbca86 100644
29--- a/src/vppinfra/pmalloc.c
30+++ b/src/vppinfra/pmalloc.c
31@@ -53,7 +53,7 @@ pmalloc_validate_numa_node (u32 * numa_node)
32 if (*numa_node == CLIB_PMALLOC_NUMA_LOCAL)
33 {
34 u32 cpu;
35- if (getcpu (&cpu, numa_node, 0) != 0)
36+ if (getcpu0 (&cpu, numa_node, 0) != 0)
37 return 1;
38 }
39 return 0;
40--
412.7.4
42
diff --git a/recipes-extended/vpp-core/vpp-core/0001-vpp-core-fix-package_qa-error.patch b/recipes-extended/vpp-core/vpp-core/0001-vpp-core-fix-package_qa-error.patch
new file mode 100644
index 00000000..a312b49d
--- /dev/null
+++ b/recipes-extended/vpp-core/vpp-core/0001-vpp-core-fix-package_qa-error.patch
@@ -0,0 +1,27 @@
1From ba3c9e624cf7ca370d6500c04428116939076bf1 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 10 Jul 2019 09:44:34 +0200
4Subject: [PATCH] vpp-core:fix package_qa error
5
6Upstream-Status: Inappropriate[oe-specific]
7
8Signed-off-by: C.r. Guo <nxa13725@lsv07004.swis.us-cdc01.nxp.com>
9---
10 src/CMakeLists.txt | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
14index 0326dbd..116bec3 100644
15--- a/src/CMakeLists.txt
16+++ b/src/CMakeLists.txt
17@@ -51,7 +51,6 @@ endif()
18 ##############################################################################
19 # install config
20 ##############################################################################
21-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
22 set(CMAKE_INSTALL_MESSAGE NEVER)
23
24 include_directories (
25--
262.7.4
27