summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vpp-core/vpp-core.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:34 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commitb7df32af2801f4341935b7613c85325287736df8 (patch)
tree667435b89eca6e06e4e35811c6302dbec0582b74 /recipes-extended/vpp-core/vpp-core.bb
parenta7e2af210c6968914215c7cd32ccb47512408719 (diff)
downloadmeta-freescale-b7df32af2801f4341935b7613c85325287736df8.tar.gz
vpp: add recipes
*update to lsdk 1812 tag include the following changes d3111f0 - Merge pull request #28 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 3de6197 - Fixed build failure issue. 850f7b0 - Merge pull request #27 in DQNS/vpp from ~NXA12342/vpp:18.01 to 18.01 bb942a3 - dpdk/ipsec: add locks on session data hash updates 2e647f4 - Merge pull request #26 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 f242992 - PVT: ipsec: Fixed capability matching for openssl based sha1 authentication d7133de - Adding copyright for IPsec protocol offload work a0a8384 - Fixed copyright issue 8ac7782 - Fixed Debian pkg errors with Ubuntu 18.04 99f3b56 - Address compilation issues with Java > 1.8 09ba9a8 - Introducing env variables to include non-standard include in libs paths 9a24604 - glibc 2.27 fix 25c590a - Optimizing Crypto Dequeue Node to prevent buffer losses d8409f4 - Merge branch '18.01' of ssh://bitbucket.sw.nxp.com/~nxa19696/vpp into 18.01 731a2e5 - Added option for enabling RSS 3a97655 - Merge pull request #19 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 e47fe7d - Enable use of Maximum QP in Sec Device when available 723d633 - Merge pull request #18 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 a99e163 - PVT:dpdk_plugin: introducing IPSec protocol offload support 5f9b2c1 - Fixed Port detection mechanism for DPAA platforms f5724cd - Fixed debian pkg support for ARM64 platforms 29755c5 - Upstreamed: Fix to start Crypto Dev 351b6fd - Added support for Single CPU usecase with events 49ddf3b - ipsec: workaround for crypto devices having single queue d6adb7d - Tune config file for caam_jr driver b4a490c - Adjusting number of buffers for LS1012 ee5b872 - Merge pull request #13 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 b40602f - Merge branch '18.01' of ssh://bitbucket.sw.nxp.com/~nxa19696/vpp into 18.01 d8edb01 - Introduced Check for Heap allocation failure 7c551f6 - Merge pull request #12 in DQNS/vpp from ~NXA19696/vpp:18.01 to 18.01 43bef3e - Tuning Memory requirements for LS1012 ff02d6e - README_nxp updated 984ef5b - Adjusting Socket Memory requiremets Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/vpp-core/vpp-core.bb')
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
new file mode 100644
index 00000000..173d2df5
--- /dev/null
+++ b/recipes-extended/vpp-core/vpp-core.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Vector Packet Processing"
2
3S = "${WORKDIR}/git"
4PV = "18.01"
5
6LICENSE = "Apache-2.0"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
9
10AUTOTOOLS_SCRIPT_PATH = "${S}/src"
11
12SRCREV = "d3111f07682585079069b91666afffbc73c79cd8"
13
14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/vpp;nobranch=1 \
15 file://0001-Link-vpp-api-with-shared-libs-if-static-is-disabled.patch \
16 file://0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch \
17 file://config.h \
18 "
19DEPENDS = "dpdk openssl numactl bison-native vpp-core-native"
20DEPENDS_class-native = "bison-native openssl-native"
21
22inherit autotools
23inherit pkgconfig
24inherit python-dir
25
26export ARCH="arm64"
27
28EXTRA_OECONF = " \
29 --disable-dependency-tracking \
30 --with-libtool-sysroot=${SYSROOT} \
31 --srcdir=${S}/src \
32 --enable-perftool \
33 --disable-papi \
34 --disable-japi \
35 --disable-static \
36 --with-pre-data=128 \
37 --disable-flowprobe-plugin --disable-ixge-plugin \
38 --disable-memif-plugin --disable-sixrd-plugin --disable-gtpu-plugin \
39 --disable-ioam-plugin --disable-lb-plugin --disable-ila-plugin \
40 --disable-nat-plugin --disable-l2e-plugin --disable-stn-plugin \
41 --disable-pppoe-plugin --disable-kubeproxy-plugin \
42 --disable-vom --disable-dpdk-plugin \
43"
44
45EXTRA_OECONF_append_class-native = " --disable-vlib"
46
47
48include vpp-pkgs.inc
49
50
51do_configure_append () {
52 ( cd ${B} && mkdir -p vppinfra vpp/app )
53 cp ${WORKDIR}/config.h ${S}/src/vlib/config.h
54}
55
56do_install_append() {
57 mkdir -p ${D}/etc/vpp
58 cp ${S}/src/vpp/conf/startup.conf ${D}/etc/vpp/startup.conf
59}
60
61
62BBCLASSEXTEND = "native nativesdk"