summaryrefslogtreecommitdiffstats
path: root/recipes-extended/vpp-core/vpp-core.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-10 16:01:09 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commitb7bf801bf6fc9c7b210602c933bbb8c42b92518d (patch)
treeb41a271be78d3bf8f7834953965c0226b67393bc /recipes-extended/vpp-core/vpp-core.bb
parent60585d192208ca1cbebe1c7723ebb4c9d4649046 (diff)
downloadmeta-freescale-b7bf801bf6fc9c7b210602c933bbb8c42b92518d.tar.gz
vpp-core: update to ff7bf7b
*update to lsdk 1906 tag include the following changes: ff7bf7b - Merge pull request #32 in DQNS/vpp from ~NXA12342/vpp:19.01.1_devel to 19.01.1 5c2b539 - PVT: ipsec: Fixed capability matching for openssl based sha1 authentication a24588f - PVT: dpdk_plugin: introducing ipsec protocol offload 33d0d81 - Fixed Flexbuild integration issues c200b3f - dpdk-ipsec: Fixed ramdom Crash in esp traffic 2a0a031 - Enhanced the VPP startup configuration 05bce64 - Merge pull request #30 in DQNS/vpp from ~NXA19696/vpp:19.01.1 to 19.01.1 c63f8ad - Fixed RPM packaging of VPP libs w.r.t Tag format 85e9d4d - Merge pull request #29 in DQNS/vpp from ~NXA19696/vpp:19.01.1 to 19.01.1 26d2455 - Adding README for NXP platforms 9df88fa - Handled review comments d66c318 - Fixed Debian packing support for arm64 platform 513a05a - Fix for using Best mem pool ops as per platform d0f5fa4 - Updating path for cmake cross compile file fe17e96 - More Compilation Fixes e64c6ca - Cross compilation & RPM pkging known issues cbd68cb - 19.01.1 Release Notes 3262adc - cmake: fix out-of-git-tree build d302022 - Fix vpp crashing when attempting to run in kubernetes Pod 6342e48 - tcp: allow future acks if in window 46ee286 - IPSEC: crash on SA dump when SA are bound to tunnels bad0bcd - Fix crash in barrier sync when vlib_worker_threads is zero 372a33e - buffer chain linearization *update PV to "19.01" *refresh patch *update DEPENDS Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/vpp-core/vpp-core.bb')
-rw-r--r--recipes-extended/vpp-core/vpp-core.bb54
1 files changed, 17 insertions, 37 deletions
diff --git a/recipes-extended/vpp-core/vpp-core.bb b/recipes-extended/vpp-core/vpp-core.bb
index 8274534a..3155543d 100644
--- a/recipes-extended/vpp-core/vpp-core.bb
+++ b/recipes-extended/vpp-core/vpp-core.bb
@@ -1,65 +1,45 @@
1DESCRIPTION = "Vector Packet Processing" 1DESCRIPTION = "Vector Packet Processing"
2 2
3S = "${WORKDIR}/git" 3S = "${WORKDIR}/git/"
4PV = "18.01" 4PV = "19.01"
5 5
6LICENSE = "Apache-2.0" 6LICENSE = "Apache-2.0"
7 7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
9 9
10AUTOTOOLS_SCRIPT_PATH = "${S}/src" 10OECMAKE_SOURCEPATH = "${S}/src"
11 11
12SRCREV = "d3111f07682585079069b91666afffbc73c79cd8" 12SRCREV = "ff7bf7bdc0fd5a7029abdf9083178d066a42a9fb"
13 13
14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/vpp;nobranch=1 \ 14SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/vpp;nobranch=1 \
15 file://0001-Link-vpp-api-with-shared-libs-if-static-is-disabled.patch \
16 file://0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch \ 15 file://0001-GCC-above-5.4-fails-when-we-specify-arch-funattribut.patch \
17 file://config.h \ 16 file://0001-getcpu-rename-getcpu-to-avoid-conflict-with-glibc-2..patch \
18 " 17 file://0001-vpp-core-fix-package_qa-error.patch \
19DEPENDS = "dpdk openssl numactl bison-native vpp-core-native" 18"
20DEPENDS_class-native = "bison-native openssl-native" 19DEPENDS = "dpdkvpp openssl python-ply util-linux vpp-core-native"
20
21DEPENDS_class-native = "openssl-native python-ply-native util-linux-native"
21 22
22inherit autotools 23inherit cmake
23inherit pkgconfig 24inherit pkgconfig
24inherit python-dir 25inherit python-dir pythonnative
25 26
26export ARCH="arm64" 27export ARCH="arm64"
28export OPENSSL_PATH = "${RECIPE_SYSROOT}"
29export DPDK_PATH= "${RECIPE_SYSROOT}"
27 30
28EXTRA_OECONF = " \ 31EXTRA_OECONF = " \
29 --disable-dependency-tracking \
30 --with-libtool-sysroot=${SYSROOT} \ 32 --with-libtool-sysroot=${SYSROOT} \
31 --srcdir=${S}/src \ 33 --srcdir=${S}/src \
32 --enable-perftool \
33 --disable-papi \
34 --disable-japi \
35 --disable-static \
36 --with-pre-data=128 \ 34 --with-pre-data=128 \
37 --disable-flowprobe-plugin --disable-ixge-plugin \ 35 --without-libnuma \
38 --disable-memif-plugin --disable-sixrd-plugin --disable-gtpu-plugin \ 36 --without-ipv6sr \
39 --disable-ioam-plugin --disable-lb-plugin --disable-ila-plugin \
40 --disable-nat-plugin --disable-l2e-plugin --disable-stn-plugin \
41 --disable-pppoe-plugin --disable-kubeproxy-plugin \
42 --disable-vom --disable-dpdk-plugin \
43" 37"
44 38
45EXTRA_OECONF_append_class-native = " --disable-vlib" 39CFLAGS += " -mtls-dialect=trad -DCLIB_LOG2_CACHE_LINE_BYTES=6 -I${OPENSSL_PATH}/usr/include -L${OPENSSL_PATH}/lib"
46CFLAGS += "-DCLIB_LOG2_CACHE_LINE_BYTES=6"
47 40
48include vpp-pkgs.inc 41include vpp-pkgs.inc
49 42
50
51do_configure_append () {
52 ( cd ${B} && mkdir -p vppinfra vpp/app )
53 cp ${WORKDIR}/config.h ${S}/src/vlib/config.h
54}
55
56do_install_append() {
57 mkdir -p ${D}/etc/vpp
58 cp ${S}/src/vpp/conf/startup.conf ${D}/etc/vpp/startup.conf
59}
60
61
62BBCLASSEXTEND = "native nativesdk" 43BBCLASSEXTEND = "native nativesdk"
63 44
64COMPATIBLE_MACHINE_class-target = "(qoriq)" 45COMPATIBLE_MACHINE_class-target = "(qoriq)"
65