summaryrefslogtreecommitdiffstats
path: root/recipes-extended/secure-obj
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 11:01:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:24 -0700
commit59d36c9832702989bfcca8a5af29fb2dff01efcc (patch)
treeb2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-extended/secure-obj
parent72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff)
downloadmeta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-extended/secure-obj')
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc6
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb12
2 files changed, 9 insertions, 9 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 8a62d9cb..55f20ed5 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Secure Object"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" 4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
5RDEPENDS_${PN} = "bash libcrypto libssl" 5RDEPENDS:${PN} = "bash libcrypto libssl"
6 6
7DEPENDS += "python3-pycryptodomex-native" 7DEPENDS += "python3-pycryptodomex-native"
8 8
@@ -20,9 +20,9 @@ export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
20 20
21EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' 21EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
22 22
23ALLOW_EMPTY_${PN} = "1" 23ALLOW_EMPTY:${PN} = "1"
24INHIBIT_PACKAGE_STRIP = "1" 24INHIBIT_PACKAGE_STRIP = "1"
25PARALLEL_MAKE = "" 25PARALLEL_MAKE = ""
26INSANE_SKIP_${PN} = "ldflags" 26INSANE_SKIP:${PN} = "ldflags"
27COMPATIBLE_MACHINE = "(qoriq-arm64)" 27COMPATIBLE_MACHINE = "(qoriq-arm64)"
28DEBUG_BUILD = "1" 28DEBUG_BUILD = "1"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 2d723738..1fd1fea3 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -4,15 +4,15 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
4 4
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6 6
7RDEPENDS_{PN} += "secure-obj-module" 7RDEPENDS:{PN} += "secure-obj-module"
8 8
9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
10export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" 10export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
11export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" 11export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
12export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" 12export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
13export CROSS_COMPILE_TA = "${CROSS_COMPILE}" 13export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
14ARCH_qoriq-arm64 = "aarch64" 14ARCH:qoriq-arm64 = "aarch64"
15ARCH_qoriq-arm = "arm" 15ARCH:qoriq-arm = "arm"
16 16
17do_compile() { 17do_compile() {
18 unset LDFLAGS 18 unset LDFLAGS
@@ -41,6 +41,6 @@ do_install() {
41 rm -rf ${D}${bindir}/test 41 rm -rf ${D}${bindir}/test
42} 42}
43 43
44FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines" 44FILES:${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
45INSANE_SKIP_${PN} = "dev-deps ldflags" 45INSANE_SKIP:${PN} = "dev-deps ldflags"
46INSANE_SKIP_${PN}-dev = "ldflags dev-elf" 46INSANE_SKIP:${PN}-dev = "ldflags dev-elf"