diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-01-11 03:14:26 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-01-14 16:23:38 -0200 |
commit | bb4f7c6f1757297b6259db9bfc19204610921900 (patch) | |
tree | 92695c6f13d5540259e4172fe62814cabdbf7c0c /recipes-extended/secure-obj | |
parent | 3d52d176d07195042da16c3af801d06b3df49ae9 (diff) | |
download | meta-freescale-bb4f7c6f1757297b6259db9bfc19204610921900.tar.gz |
secure-obj:update to bc0553a
*update to lsdk 1812 tag
include the following changes
bc0553a - removed dead code under compile time flag SK_INVALID_HANDLE
f2fddd6 - added support for sk_digestinit sk_digestupdate sk_digestfinal.
f509695 - APP_TA_LIB: Adding SK_ATTR_PRIVATE attribute for objects
6791873 - SOBJ_LIB: Exposing SK_CreateObject for PKCS#11 Library
f3da9c0 - TA: Miscellaneous Changes
07ef069 - APP_ENG: Adding support for OAEP Encryption in engine and engine app
9fdbf7a - LIB_TA: Adding support for OAEP Encryption Scheme
1652924 - TA: Not returning TEE_ERROR_BAD_PARAMETERS for unmatched attributes
2a49505 - LIB: Exposing SK_GenerateKeyPair and SK_EraseObject Functions
*add secure-obj-module to RDEPENDS
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/secure-obj')
-rw-r--r-- | recipes-extended/secure-obj/secure-obj.inc | 2 | ||||
-rw-r--r-- | recipes-extended/secure-obj/secure-obj_git.bb | 2 |
2 files changed, 3 insertions, 1 deletions
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc index 99271d17..20341261 100644 --- a/recipes-extended/secure-obj/secure-obj.inc +++ b/recipes-extended/secure-obj/secure-obj.inc | |||
@@ -12,7 +12,7 @@ LDFLAGS += "${TOOLCHAIN_OPTIONS}" | |||
12 | 12 | ||
13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ | 13 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/secure_obj;nobranch=1 \ |
14 | " | 14 | " |
15 | SRCREV = "bbcbe6cd137440b8b23e1fa71077fd3c8973e5da" | 15 | SRCREV = "bc0553a3c7a02555eb6bf46803854f6b49227a26" |
16 | 16 | ||
17 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 17 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
18 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | 18 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" |
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb index db881b19..d85d7298 100644 --- a/recipes-extended/secure-obj/secure-obj_git.bb +++ b/recipes-extended/secure-obj/secure-obj_git.bb | |||
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2" | |||
4 | 4 | ||
5 | S = "${WORKDIR}/git" | 5 | S = "${WORKDIR}/git" |
6 | 6 | ||
7 | RDEPENDS_{PN} += "secure-obj-module" | ||
8 | |||
7 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" | 9 | WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" |
8 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" | 10 | export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" |
9 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" | 11 | export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" |