summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-05 15:16:31 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commit5a80dd02dd672c57a02622f4508be258638c1fdc (patch)
tree3c17dfbc98990f9814cae61f66ee50a791a8761a /recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
parent8324dbe927858867883a7f0cea14bc8370a9c009 (diff)
downloadmeta-freescale-5a80dd02dd672c57a02622f4508be258638c1fdc.tar.gz
ovs-dpdk: Upgrade 2.10 -> 2.11
*Update to lsdk 1906 tag include the following changes: abc80ef - netdev-dpdk: have env based configurable number of packet buffers 2410fad - rhel: Use PIDFile on forking systemd service files a631ef7 - dpif-netdev: fix meter at high packet rate. 6b14ed0 - dpif-netdev: Fix double parsing of packets when EMC disabled. 0118706 - dpif-netdev: Update comment about flow installation race. 3c54cf1 - netlink linux: fix to append the netnsid netlink attr. 9a72286 - conntrack: Fix minimum connections to clean. 9b2e4ff - datapath: Revert "datapath: Fix template leak in error cases." 62c7a9d - compiler: Fix compilation when using VStudio 2015/2017 2560908 - datapath: fix flow actions reallocation fae3311 - Docs: fix conntrack flow ct_state input daeab19 - netdev-dpdk: Fix printing masks with wrong byte order. 24909e6 - Prepare for 2.11.2. 022c173 - Set release date for 2.11.1. 044a61d - netdev-tc-offloads: Fix probe tc block support 434ffa9 - rhel: Include all header files in the Fedora's devel package 359a7d2 - reconnect.c: Don't transition back to ACTIVE when forced to RECONNECT. 2924b48 - OVN: Make periodic RAs consistent with RA responder. 54f2d11 - OVN: Always send prefix option in RAs 76f2c3b - OVN: Use offset instead of pointer into ofpbuf 6ffb917 - ofproto: fix the bug of bucket counter is not updated b1f9b4e - netdev-dpdk: Print netdev name for txq mapping. 9068a55 - dpif-netdev-perf: Fix millisecond stats precision with slower TSC. 3c440c2 - ifupdown.sh: Add missing "--may-exist" option b88dafd - dpif-netdev-perf: Fix double update of perf histograms. a55b827 - dpdk: Stop dumping memzones to stdout. 68b2304 - dpctl: Drop parser debug information. 5dea53a - netdev-tc-offloads: Properly get the block id on flow del/get 4c26dfd - netdev-tc-offloads: Improve log message for icmpv6 offload not supported d8bb89f - conntrack: Replace structure copy by memcpy(). Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb')
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
new file mode 100644
index 00000000..fd9d3a61
--- /dev/null
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.11.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python-six-native coreutils-native"
6RDEPENDS_${PN} = "bash libcrypto libssl python"
7
8inherit pythonnative
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1 \
11"
12SRCREV = "abc80ef87a8786050f27afb2a797cadd14e2a6bd"
13
14S = "${WORKDIR}/git"
15
16DPAA_VER ?= "dpaa"
17export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc"
18
19EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \
20 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \
21 OPENSSL_PATH="${STAGING_DIR_HOST}" RTE_KERNELDIR="${STAGING_KERNEL_DIR}" \
22 RTE_KERNELDIR_OUT="${STAGING_KERNEL_BUILDDIR}" \
23'
24
25do_configure() {
26 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
27 ${S}/boot.sh
28 ${S}/configure --host aarch64-fsl-linux --with-dpdk=${SYSROOT_DPDK}/usr/share/${RTE_TARGET} --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
29}
30
31do_compile() {
32 oe_runmake O="${RTE_TARGET}" T="${RTE_TARGET}"
33}
34
35do_install() {
36 install -d ${D}${bindir}/ovs-dpdk
37 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
38 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
39 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
40 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
41 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
42 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
43 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
44}
45
46ALLOW_EMPTY_${PN} = "1"
47INHIBIT_PACKAGE_STRIP = "1"
48PACKAGE_ARCH = "${MACHINE_ARCH}"
49COMPATIBLE_MACHINE = "(qoriq-arm64)"