diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2021-10-20 14:47:55 +0800 |
---|---|---|
committer | Hongxu Jia <hongxu.jia@windriver.com> | 2021-10-21 15:45:34 +0800 |
commit | 3d39d355867caaee00c42614f7eb4a9b0830b84b (patch) | |
tree | 3e05546180d63768facf0c4ef489c171f32beb74 /recipes-extended/odp | |
parent | 265c7afa5c7e1491b960e5f77132a01dd6455feb (diff) | |
download | meta-freescale-3d39d355867caaee00c42614f7eb4a9b0830b84b.tar.gz |
odp-module/odp-counters/kernel-module-ar: fix QA Issue during usermerge
While enabling usermerge, there is a QA issue:
...
ERROR: odp-counters-git-r0 do_package: QA Issue: odp-counters: Files/directories were installed but not shipped in any package:
/lib
/lib/modules
/lib/modules/5.10.70-yocto-standard
/lib/modules/5.10.70-yocto-standard/odp
/lib/modules/5.10.70-yocto-standard/odp/odpfsl_perfcounters.ko
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
odp-counters: 5 installed and not shipped files. [installed-vs-shipped]
...
Use Yocto nonarch_base_libdir to replace hardcode /lib
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'recipes-extended/odp')
-rw-r--r-- | recipes-extended/odp/odp-counters_git.bb | 4 | ||||
-rw-r--r-- | recipes-extended/odp/odp-module_git.bb | 4 |
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb index 9d88ea43..c8f13208 100644 --- a/recipes-extended/odp/odp-counters_git.bb +++ b/recipes-extended/odp/odp-counters_git.bb | |||
@@ -9,6 +9,6 @@ do_compile:prepend () { | |||
9 | } | 9 | } |
10 | 10 | ||
11 | do_install () { | 11 | do_install () { |
12 | install -d ${D}/lib/modules/${KERNEL_VERSION}/odp | 12 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
13 | install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}/lib/modules/${KERNEL_VERSION}/odp | 13 | install -m 755 ${S}/test/debug/perf_counters/odpfsl_perfcounters.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
14 | } | 14 | } |
diff --git a/recipes-extended/odp/odp-module_git.bb b/recipes-extended/odp/odp-module_git.bb index 0748e5bf..ba74a5c0 100644 --- a/recipes-extended/odp/odp-module_git.bb +++ b/recipes-extended/odp/odp-module_git.bb | |||
@@ -9,8 +9,8 @@ do_compile:prepend () { | |||
9 | } | 9 | } |
10 | 10 | ||
11 | do_install () { | 11 | do_install () { |
12 | install -d ${D}/lib/modules/${KERNEL_VERSION}/odp | 12 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
13 | install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp | 13 | install -m 755 ${S}/kern/odpfsl_kni.ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/odp |
14 | } | 14 | } |
15 | 15 | ||
16 | PKG:${PN} = "kernel-module-${PN}" | 16 | PKG:${PN} = "kernel-module-${PN}" |