diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-04-20 17:23:23 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-05-02 17:54:58 -0300 |
commit | 382b4195ce40ef4f6d406d94d7aa3a68396fc8a8 (patch) | |
tree | e0a21d5d480af714f016f80d79c7e1cc9b2c6bb9 /recipes-extended/odp/odp_git.bb | |
parent | fc4edb4833ef2c9fec4890fac129cb87ca4e0dc7 (diff) | |
download | meta-freescale-382b4195ce40ef4f6d406d94d7aa3a68396fc8a8.tar.gz |
odp: add recipes
Signed-off-by: Chunrong Guo <B40290@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/odp/odp_git.bb')
-rw-r--r-- | recipes-extended/odp/odp_git.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb new file mode 100644 index 00000000..32e31072 --- /dev/null +++ b/recipes-extended/odp/odp_git.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | require odp.inc | ||
2 | |||
3 | inherit autotools-brokensep | ||
4 | |||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
7 | DEPENDS = "openssl cunit libxml2" | ||
8 | |||
9 | RDEPENDS_${PN} = "bash libcrypto libssl odp-module odp-counters" | ||
10 | |||
11 | ODP_SOC ?= "" | ||
12 | ODP_SOC_ls1043ardb = "LS1043" | ||
13 | ODP_SOC_ls1046ardb = "LS1046" | ||
14 | ODP_PLATFORM ?= "linux-dpaa2" | ||
15 | ODP_PLATFORM_ls1043ardb = "linux-dpaa1" | ||
16 | ODP_PLATFORM_ls1046ardb = "linux-dpaa1" | ||
17 | ODP_BUILD_TYPE ?= "ls2088" | ||
18 | ODP_BUILD_TYPE_ls1043ardb = "ls1043" | ||
19 | ODP_BUILD_TYPE_ls1046ardb = "ls1046" | ||
20 | ODP_BUILD_TYPE_ls2080ardb = "ls2080" | ||
21 | |||
22 | EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \ | ||
23 | --with-sdk-install-path=${STAGING_DIR_TARGET} \ | ||
24 | --enable-build-type=${ODP_BUILD_TYPE} \ | ||
25 | --enable-test-vald \ | ||
26 | --enable-test-perf \ | ||
27 | --enable-test-cpp \ | ||
28 | " | ||
29 | |||
30 | EXTRA_OEMAKE = "CROSS_COMPILE="${TARGET_PREFIX}" \ | ||
31 | SYSROOT="${STAGING_DIR_TARGET}" \ | ||
32 | " | ||
33 | |||
34 | PACKAGECONFIG[perf] = "--enable-test-perf,,," | ||
35 | |||
36 | do_configure_prepend () { | ||
37 | export SOC=${ODP_SOC} | ||
38 | ${S}/bootstrap | ||
39 | } | ||
40 | |||
41 | do_compile_prepend () { | ||
42 | export SOC=${ODP_SOC} | ||
43 | export ARCH=${TUNE_ARCH} | ||
44 | } | ||
45 | |||
46 | do_install_append () { | ||
47 | install -d ${D}${includedir}/odp/kni | ||
48 | install -d ${D}${includedir}/odp/kern | ||
49 | install -d ${D}${includedir}/odp/flib/mc | ||
50 | install -d ${D}${includedir}/odp/flib/qbman/include/drivers | ||
51 | |||
52 | cp -rf ${S}/platform/linux-dpaa2/include/* ${D}${includedir}/odp/ | ||
53 | cp -rf ${S}/platform/linux-dpaa2/kni/*.h ${D}${includedir}/odp/kni/ | ||
54 | cp -rf ${S}/kern/*.h ${D}${includedir}/odp/kern/ | ||
55 | cp -rf ${S}/platform/linux-dpaa2/flib/mc/*.h ${D}${includedir}/odp/flib/mc/ | ||
56 | cp -rf ${S}/platform/linux-dpaa2/flib/qbman/include/drivers/*.h ${D}${includedir}/odp/flib/qbman/include/drivers | ||
57 | |||
58 | sed -i -e 's#platform/linux-dpaa2/##g' ${D}${includedir}/odp/kern/*.h | ||
59 | } | ||
60 | |||
61 | FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la" | ||
62 | FILES_${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test" | ||
63 | FILES_${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug" | ||