summaryrefslogtreecommitdiffstats
path: root/recipes-extended/odp/odp_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-10-18 13:06:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-18 11:42:30 -0200
commitd440bb6a5bffdca6ed5e11e07ce27c7b7e33a330 (patch)
tree2e7279beb7ed26512b97cb56268c95202a246726 /recipes-extended/odp/odp_git.bb
parentb43738020274b099ff492625e7ba4cb6ba3df6ff (diff)
downloadmeta-freescale-d440bb6a5bffdca6ed5e11e07ce27c7b7e33a330.tar.gz
odp:update recipes
*update to bef6398 odp include the following changes bef6398 - TM: Invalid flow crash fix 8e7a136 - Removed device based jiffies df492ef - Fixing legal issues 3e9c5da - Scripts: binaries path and odp_tm test cases updated c91dac8 - Werror flag enabled for ODP library ced3aaf - Updated MC flib to version 10.3.2 a68cd87 - odp_pktio_stats API updated 03e0e05 - LD_LIBRARY_PATH removed from loopback_script 7a64406 - CUNIT: Cunit installation enabled 048c6a6 - script: ODP library path fixed *flib include the following changes bbab28b - fix PDCP warnings for User Plane descriptor fcad69f - fix PDCP SNOW f8 + AES CMAC decapsulation *fix wrong md5sum of license file license file has changes *remove ODP_PLATFORM for ls1043ardb and ls1046ardb ODP_PLATFORM only support "linux-dpaa2" *remove "enable-build-type" and "with-sdk-install-path" config options odp configure do not support "with-sdk-install-path" and "enable-build-type" *fix building error with GCC7 set CFLAGS Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/odp/odp_git.bb')
-rw-r--r--recipes-extended/odp/odp_git.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
index b7c7deb6..b9d45581 100644
--- a/recipes-extended/odp/odp_git.bb
+++ b/recipes-extended/odp/odp_git.bb
@@ -12,8 +12,6 @@ ODP_SOC ?= ""
12ODP_SOC_ls1043ardb = "LS1043" 12ODP_SOC_ls1043ardb = "LS1043"
13ODP_SOC_ls1046ardb = "LS1046" 13ODP_SOC_ls1046ardb = "LS1046"
14ODP_PLATFORM ?= "linux-dpaa2" 14ODP_PLATFORM ?= "linux-dpaa2"
15ODP_PLATFORM_ls1043ardb = "linux-dpaa1"
16ODP_PLATFORM_ls1046ardb = "linux-dpaa1"
17ODP_BUILD_TYPE ?= "ls2088" 15ODP_BUILD_TYPE ?= "ls2088"
18ODP_BUILD_TYPE_ls1043ardb = "ls1043" 16ODP_BUILD_TYPE_ls1043ardb = "ls1043"
19ODP_BUILD_TYPE_ls1046ardb = "ls1046" 17ODP_BUILD_TYPE_ls1046ardb = "ls1046"
@@ -21,8 +19,6 @@ ODP_BUILD_TYPE_ls2080ardb = "ls2080"
21ODP_BUILD_TYPE_ls1088ardb = "ls1088" 19ODP_BUILD_TYPE_ls1088ardb = "ls1088"
22 20
23EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \ 21EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
24 --with-sdk-install-path=${STAGING_DIR_TARGET} \
25 --enable-build-type=${ODP_BUILD_TYPE} \
26 --enable-test-vald \ 22 --enable-test-vald \
27 --enable-test-perf \ 23 --enable-test-perf \
28 --enable-test-cpp \ 24 --enable-test-cpp \
@@ -32,6 +28,8 @@ EXTRA_OEMAKE = "CROSS_COMPILE="${TARGET_PREFIX}" \
32 SYSROOT="${STAGING_DIR_TARGET}" \ 28 SYSROOT="${STAGING_DIR_TARGET}" \
33" 29"
34 30
31CFLAGS += "-Wno-format-truncation -Wno-maybe-uninitialized -Wno-implicit-fallthrough"
32
35PACKAGECONFIG[perf] = "--enable-test-perf,,," 33PACKAGECONFIG[perf] = "--enable-test-perf,,,"
36 34
37do_configure_prepend () { 35do_configure_prepend () {