diff options
author | Jens Rehsack <sno@netbsd.org> | 2020-06-23 10:46:13 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-06-23 08:43:24 -0300 |
commit | cc3cc55828251301eccde0745863f75aa74b49ae (patch) | |
tree | 315f21e613b8b3c5b9ecc6c96a52556801890c5d /recipes-extended/dpdk | |
parent | 3f7c212127012a85e865abb5ed7703d38c11f3e9 (diff) | |
download | meta-freescale-cc3cc55828251301eccde0745863f75aa74b49ae.tar.gz |
dpdk: fix gcc 10 maybe-uninitialized warning
Backport upstream fix of Kevin Traynor <ktraynor@redhat.com>:
afd2924 examples/ipsec-gw: fix gcc 10 maybe-uninitialized warning
With that fix applied, dpdk builds fine with recent poky.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Diffstat (limited to 'recipes-extended/dpdk')
-rw-r--r-- | recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch | 53 | ||||
-rw-r--r-- | recipes-extended/dpdk/dpdk_19.11-20.04.bb | 1 |
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch b/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch new file mode 100644 index 00000000..3b5a2b3a --- /dev/null +++ b/recipes-extended/dpdk/dpdk/0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch | |||
@@ -0,0 +1,53 @@ | |||
1 | From 6fe3e96ab6e92f8faca9784a46bc33d92790c2b8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kevin Traynor <ktraynor@redhat.com> | ||
3 | Date: Wed, 11 Mar 2020 11:33:00 +0000 | ||
4 | Subject: [PATCH] examples/ipsec-gw: fix gcc 10 maybe-uninitialized warning | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | gcc 10.0.1 reports: | ||
10 | |||
11 | ../examples/ipsec-secgw/ipsec_process.c: In function ‘ipsec_process’: | ||
12 | ../examples/ipsec-secgw/ipsec_process.c:132:34: | ||
13 | error: ‘grp.m’ may be used uninitialized in this function | ||
14 | [-Werror=maybe-uninitialized] | ||
15 | 132 | grp[n].cnt = pkts + i - grp[n].m; | ||
16 | | ~~~~~~^~ | ||
17 | |||
18 | This is a correct warning for the initial execution of the statement. | ||
19 | However, it is the design of the loop that grp[0].cnt will later be | ||
20 | written with the correct value using an initialized grp[0].m before it | ||
21 | is used. | ||
22 | |||
23 | In order to remove the warning, initialize grp[0].m for the initial and | ||
24 | unused calculation of grp[0].cnt. | ||
25 | |||
26 | Fixes: 3e5f4625dc17 ("examples/ipsec-secgw: make data-path to use IPsec library") | ||
27 | Cc: stable@dpdk.org | ||
28 | |||
29 | Upstream-Status: Backport | ||
30 | |||
31 | Suggested-by: Konstantin Ananyev <konstantin.ananyev@intel.com> | ||
32 | Signed-off-by: Kevin Traynor <ktraynor@redhat.com> | ||
33 | Acked-by: Konstantin Ananyev <konstantin.ananyev@intel.com> | ||
34 | Signed-off-by: Jens Rehsack <jens.rehsack.ext@safrangroup.com> | ||
35 | --- | ||
36 | examples/ipsec-secgw/ipsec_process.c | 1 + | ||
37 | 1 file changed, 1 insertion(+) | ||
38 | |||
39 | diff --git a/examples/ipsec-secgw/ipsec_process.c b/examples/ipsec-secgw/ipsec_process.c | ||
40 | index 2eb5c8b34..37f406d46 100644 | ||
41 | --- a/examples/ipsec-secgw/ipsec_process.c | ||
42 | +++ b/examples/ipsec-secgw/ipsec_process.c | ||
43 | @@ -125,6 +125,7 @@ sa_group(void *sa_ptr[], struct rte_mbuf *pkts[], | ||
44 | void * const nosa = &spi; | ||
45 | |||
46 | sa = nosa; | ||
47 | + grp[0].m = pkts; | ||
48 | for (i = 0, n = 0; i != num; i++) { | ||
49 | |||
50 | if (sa != sa_ptr[i]) { | ||
51 | -- | ||
52 | 2.17.1 | ||
53 | |||
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.04.bb b/recipes-extended/dpdk/dpdk_19.11-20.04.bb index 12b6d56e..398d2ec4 100644 --- a/recipes-extended/dpdk/dpdk_19.11-20.04.bb +++ b/recipes-extended/dpdk/dpdk_19.11-20.04.bb | |||
@@ -5,6 +5,7 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr | |||
5 | file://0001-add-Wno-cast-function-type.patch \ | 5 | file://0001-add-Wno-cast-function-type.patch \ |
6 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ | 6 | file://0001-Add-RTE_KERNELDIR_OUT.patch \ |
7 | file://0004-update-WERROR_FLAGS.patch \ | 7 | file://0004-update-WERROR_FLAGS.patch \ |
8 | file://0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch \ | ||
8 | " | 9 | " |
9 | SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540" | 10 | SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540" |
10 | 11 | ||