diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-04-12 14:20:45 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-04-12 09:17:55 -0300 |
commit | c69847350e81e4fe6b1c494445c3d6c7f73abd86 (patch) | |
tree | 6772bf3041acb54b8547bf3e4c54d37242ad922e /recipes-extended/dpdk | |
parent | d055d364cb3b97c12f50e012ffa8db68c2e4dd10 (diff) | |
download | meta-freescale-c69847350e81e4fe6b1c494445c3d6c7f73abd86.tar.gz |
dpdk: Add missing patch
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/dpdk')
-rw-r--r-- | recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch | 27 | ||||
-rw-r--r-- | recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch | 51 |
2 files changed, 27 insertions, 51 deletions
diff --git a/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch b/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch new file mode 100644 index 00000000..0c846822 --- /dev/null +++ b/recipes-extended/dpdk/dpdk/0001-add-Wno-cast-function-type.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From beb13be8023beb68499c72e71a79b8f91784e484 Mon Sep 17 00:00:00 2001 | ||
2 | From: "C.r. Guo" <nxa13725@lsv07005.swis.us-cdc01.nxp.com> | ||
3 | Date: Wed, 27 Mar 2019 09:35:43 +0100 | ||
4 | Subject: [PATCH] add -Wno-cast-function-type | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | --- | ||
9 | examples/cmdif/lib/Makefile | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/examples/cmdif/lib/Makefile b/examples/cmdif/lib/Makefile | ||
13 | index d28badf..4e9851c 100644 | ||
14 | --- a/examples/cmdif/lib/Makefile | ||
15 | +++ b/examples/cmdif/lib/Makefile | ||
16 | @@ -28,7 +28,7 @@ SRCS-y += server/cmdif_srv_gpp.c | ||
17 | SRCS-y += shbp/shbp.c | ||
18 | |||
19 | CFLAGS += -O3 | ||
20 | -CFLAGS += $(WERROR_FLAGS) | ||
21 | +CFLAGS += $(WERROR_FLAGS) -Wno-cast-function-type | ||
22 | CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib | ||
23 | CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/client | ||
24 | CFLAGS += -I$(RTE_SDK)/examples/cmdif/lib/server | ||
25 | -- | ||
26 | 2.7.4 | ||
27 | |||
diff --git a/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch b/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch deleted file mode 100644 index 51987b53..00000000 --- a/recipes-extended/dpdk/dpdk/0001-fix-gcc-8-build-error.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From 7409d0b89f80a72d91e02dc9ec688a01723c3c66 Mon Sep 17 00:00:00 2001 | ||
2 | From: Chunrong Guo <chunrong.guo@nxp.com> | ||
3 | Date: Wed, 4 Jul 2018 17:12:39 +0800 | ||
4 | Subject: [PATCH] fix gcc-8 build error | ||
5 | |||
6 | Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> | ||
7 | --- | ||
8 | examples/ipsec-secgw/parser.c | 6 ++---- | ||
9 | mk/toolchain/gcc/rte.vars.mk | 2 +- | ||
10 | 2 files changed, 3 insertions(+), 5 deletions(-) | ||
11 | |||
12 | diff --git a/examples/ipsec-secgw/parser.c b/examples/ipsec-secgw/parser.c | ||
13 | index 9d0ea46..b2b30e4 100644 | ||
14 | --- a/examples/ipsec-secgw/parser.c | ||
15 | +++ b/examples/ipsec-secgw/parser.c | ||
16 | @@ -544,8 +544,7 @@ parse_cfg_file(const char *cfg_filename) | ||
17 | goto error_exit; | ||
18 | } | ||
19 | |||
20 | - strncpy(str + strlen(str), oneline, | ||
21 | - strlen(oneline)); | ||
22 | + strcpy(str + strlen(str), oneline); | ||
23 | |||
24 | continue; | ||
25 | } | ||
26 | @@ -557,8 +556,7 @@ parse_cfg_file(const char *cfg_filename) | ||
27 | cfg_filename, line_num); | ||
28 | goto error_exit; | ||
29 | } | ||
30 | - strncpy(str + strlen(str), oneline, | ||
31 | - strlen(oneline)); | ||
32 | + strcpy(str + strlen(str), oneline); | ||
33 | |||
34 | str[strlen(str)] = '\n'; | ||
35 | if (cmdline_parse(cl, str) < 0) { | ||
36 | diff --git a/mk/toolchain/gcc/rte.vars.mk b/mk/toolchain/gcc/rte.vars.mk | ||
37 | index 3b907e2..cc63da8 100644 | ||
38 | --- a/mk/toolchain/gcc/rte.vars.mk | ||
39 | +++ b/mk/toolchain/gcc/rte.vars.mk | ||
40 | @@ -75,7 +75,7 @@ WERROR_FLAGS := -W -Wall -Wstrict-prototypes -Wmissing-prototypes | ||
41 | WERROR_FLAGS += -Wmissing-declarations -Wold-style-definition -Wpointer-arith | ||
42 | WERROR_FLAGS += -Wcast-align -Wnested-externs -Wcast-qual | ||
43 | WERROR_FLAGS += -Wformat-nonliteral -Wformat-security | ||
44 | -WERROR_FLAGS += -Wundef -Wwrite-strings | ||
45 | +WERROR_FLAGS += -Wundef -Wwrite-strings -Wno-cast-function-type | ||
46 | |||
47 | ifeq ($(RTE_DEVEL_BUILD),y) | ||
48 | WERROR_FLAGS += -Werror | ||
49 | -- | ||
50 | 2.7.4 | ||
51 | |||