summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-07-12 17:01:24 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-07-14 17:14:13 -0300
commit0db51a0c6cd25eaf3328afbe5b352e3ea35528e0 (patch)
treecda8351167b1ab121537e56200534e8eb54a98e9 /recipes-extended/dpdk
parentb5c351ee708053fbc3f29d3b54c011f63d6a5319 (diff)
downloadmeta-freescale-0db51a0c6cd25eaf3328afbe5b352e3ea35528e0.tar.gz
dpdk: fix build error with gcc 7
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/dpdk')
-rw-r--r--recipes-extended/dpdk/dpdk_16.07.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.07.bb b/recipes-extended/dpdk/dpdk_16.07.bb
index ee0fcca0..ebc08809 100644
--- a/recipes-extended/dpdk/dpdk_16.07.bb
+++ b/recipes-extended/dpdk/dpdk_16.07.bb
@@ -12,6 +12,7 @@ inherit module
12SRC_URI = "git://git.freescale.com/ppc/sdk/dpdk.git;nobranch=1 \ 12SRC_URI = "git://git.freescale.com/ppc/sdk/dpdk.git;nobranch=1 \
13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \ 13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
14 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ 14 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \
15 file://0001-fix-build-with-gcc-7.1.patch \
15" 16"
16SRCREV = "a3395d24774a8a7a2ce0d56a92a8ad2895b2ae8c" 17SRCREV = "a3395d24774a8a7a2ce0d56a92a8ad2895b2ae8c"
17 18
@@ -20,6 +21,8 @@ S = "${WORKDIR}/git"
20DPAA_VER ?= "dpaa2" 21DPAA_VER ?= "dpaa2"
21DPAA_VER_fsl-lsch2 = "dpaa" 22DPAA_VER_fsl-lsch2 = "dpaa"
22export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc" 23export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc"
24export ETHTOOL_LIB_PATH = "${S}/examples/ethtool/lib/${RTE_TARGET}/"
25
23 26
24EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \ 27EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \
25 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \ 28 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \
@@ -37,7 +40,7 @@ do_compile() {
37do_install() { 40do_install() {
38 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS 41 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
39 42
40 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" T="${RTE_TARGET}" DESTDIR="${D}" install 43 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install
41 44
42 # Build and install the DPDK examples 45 # Build and install the DPDK examples
43 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do 46 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do