summaryrefslogtreecommitdiffstats
path: root/recipes-extended/dpdk/dpdk_16.07.bb
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-03-16 13:03:34 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-02 10:30:13 -0300
commitee326e566ba00a8494ee19cbad465d022f577c80 (patch)
treed8d0968da430cc4506bb24eb6003b10abb026e08 /recipes-extended/dpdk/dpdk_16.07.bb
parent5291ef0bab056e617bda716971a8f980a9c6dfbf (diff)
downloadmeta-freescale-ee326e566ba00a8494ee19cbad465d022f577c80.tar.gz
dpdk : Upgrade to v17.11
1. Rename the recipe version 2. Remove add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch 3. Add cmdif demo and lib 4. Enable openssl and kni 5. Changes: 11d461d - PVT: dpaa: Coverity fixes f48f745 - PVT: dpaa2: Coverity fixes 4294b65 - Merge pull request #581 in GITAM/dpdk from bugfix/DPDK-1236-vhost to 17.11-next-qoriq ea9e9f5 - PVT:examples/vhost: add NXP NON upstream compilation flag fa63d1a - PVT: dpaa2: add dynamic AIOP DPL script 0c5d852 - PVT: crypto/dpaa_sec: Adding a check to verify portal configuration 3be54a7 - PVT: crypto/dpaa_sec: adding a check to create mempool only once per device 09dc340 - PVT: test/test: add macro for dpaa_sec device name edd313f - PVT: crypto/dpaa_sec: add macro for device name cad0a33 - Merge pull request #571 in GITAM/dpdk from bugfix/DPDK-1222 to 17.11-next-qoriq 0057e69 - dpaa/event: rearranging of atomic queue support code 2a43d84 - Merge pull request #569 in GITAM/dpdk from feature/DPDK-781 to 17.11-next-qoriq 214085e - README: Update for l3fwd with eventdev config 5ab4786 - PVT: mbuf: change mempool set from register 4ecd97c - license: introduce SPDX identifiers e762ed7 - doc: add DPAA eventdev guide 84956ed - crypto/dpaa2_sec: fix build with GCC < 7 e716b6f - crypto/dpaa2_sec: fix build with GCC 7 a38ca35 - lib: remove unused map symbols 4d8a6de - net/dpaa2: remove unused global variable 513dac2 - bus/fslmc: fix build with latest glibc ae9a891 - bus/dpaa: fix default IOVA mode 3d4dacb - bus/fslmc: fix DPCI compare in scan 080fda4 - bus/dpaa: fix clang warnings d82a750 - crypto/dpaa2_sec: fix enum conversion for GCM 17ae857 - crypto/dpaa_sec: fix enum conversion for GCM 2e1e748 - net/dpaa: fix potential memory leak 18a9fad - Merge pull request #566 in GITAM/dpdk from ~NXA15309/dpdk:DPDK-781-l3fwd-event to 17.11-next-qoriq 6acd7a7 - PVT: doc: update the cmdif doc with correct AIOP ELF path 0056df7 - PVT: examples/l3fwd: adding CLI parameters for eventdev config 46aaafa - PVT: raw/dpaa2_cmdif: use iova-vaddr conversion macros e7933b2 - PVT: bus/fslmc: add typecast in iova-vaddr conversion macros fa06a86 - PVT: doc: add DPAA2 based CMDIF demo 5fcd632 - PVT: examples/cmdif: add the command interface demo application 3bcae6d - PVT: examples/cmdif: add CMDIF SHBP library a8ff22c - PVT: examples/cmdif: add CMDIF server library 86a71f5 - PVT: examples/cmdif: add CMDIF client library Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/dpdk/dpdk_16.07.bb')
-rw-r--r--recipes-extended/dpdk/dpdk_16.07.bb89
1 files changed, 0 insertions, 89 deletions
diff --git a/recipes-extended/dpdk/dpdk_16.07.bb b/recipes-extended/dpdk/dpdk_16.07.bb
deleted file mode 100644
index 78328c44..00000000
--- a/recipes-extended/dpdk/dpdk_16.07.bb
+++ /dev/null
@@ -1,89 +0,0 @@
1DESCRIPTION = "Data Plane Development Kit"
2HOMEPAGE = "http://dpdk.org"
3LICENSE = "BSD & LGPLv2 & GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe"
5
6DEPENDS += "virtual/kernel openssl"
7RDEPENDS_${PN} = "bash python"
8RDEPENDS_${PN}-examples = "bash python-core"
9
10inherit module
11
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobranch=1 \
13 file://add-RTE_KERNELDIR_OUT-to-split-kernel-bu.patch \
14 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \
15"
16SRCREV = "076aa8e2f9a4ad7e0a020f5c574371d92afe4a60"
17
18S = "${WORKDIR}/git"
19
20DPAA_VER ?= "dpaa2"
21DPAA_VER_fsl-lsch2 = "dpaa"
22export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc"
23export ETHTOOL_LIB_PATH = "${S}/examples/ethtool/lib/${RTE_TARGET}/"
24
25EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \
26 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \
27 OPENSSL_PATH="${STAGING_DIR_HOST}" RTE_KERNELDIR="${STAGING_KERNEL_DIR}" \
28 RTE_KERNELDIR_OUT="${STAGING_KERNEL_BUILDDIR}" \
29'
30
31do_configure[noexec] = "1"
32
33do_compile[depends] += "virtual/kernel:do_shared_workdir"
34do_compile() {
35 oe_runmake O="${RTE_TARGET}" T="${RTE_TARGET}" config
36}
37
38do_install() {
39 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
40
41 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" WERROR_FLAGS="-w" V=1 T="${RTE_TARGET}" DESTDIR="${D}" install
42
43 # Build and install the DPDK examples
44 for APP in examples/l2fwd examples/l3fwd examples/l2fwd-crypto examples/ipsec-secgw examples/kni examples/ip_fragmentation examples/ip_reassembly; do
45 oe_runmake EXTRA_LDFLAGS="-L${STAGING_LIBDIR} --hash-style=gnu" -C ${APP}
46
47 [ ! -d ${D}/${bindir}/dpdk-example ] && install -d 0644 ${D}/${bindir}/dpdk-example
48 install -m 0755 ${S}/examples/`basename ${APP}`/build/`basename ${APP}` \
49 ${D}/${bindir}/dpdk-example/
50 done
51 install -m 0755 ${S}/${RTE_TARGET}/app/testpmd ${D}/${bindir}/dpdk-example/
52 rm -fr ${D}/lib/modules/*
53 install -d ${D}/lib/modules/${KERNEL_VERSION}/dpdk
54 install -m 0755 ${S}/${RTE_TARGET}/kmod/rte_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/dpdk/
55 install -d ${D}/${bindir}/dpdk-example/extras
56 cp -rf ${S}/nxp/* ${D}/${bindir}/dpdk-example/extras/
57 rm ${D}/${datadir}/${RTE_TARGET}/app/dpdk-pmdinfogen
58
59 chown root:root -R ${D}
60}
61
62PACKAGE_ARCH = "${MACHINE_ARCH}"
63
64PACKAGES += "${PN}-examples"
65
66FILES_${PN} += "${datadir}/* ${bindir}/* ${sbindir}/*"
67FILES_${PN}-dbg += "${bindir}/dpdk-example/.debug \
68 ${datadir}/examples/kni/build/.debug \
69 ${datadir}/examples/kni/build/app/.debug \
70 ${datadir}/examples/l2fwd/build/.debug \
71 ${datadir}/examples/l2fwd/build/app/.debug \
72 ${datadir}/examples/l2fwd-crypto/build/.debug \
73 ${datadir}/examples/l2fwd-crypto/build/app/.debug \
74 ${datadir}/examples/l3fwd/build/.debug \
75 ${datadir}/examples/l3fwd/build/app/.debug \
76 ${datadir}/examples/ipsec-secgw/build/.debug \
77 ${datadir}/examples/ipsec-secgw/build/app/.debug \
78 ${datadir}/examples/ip_fragmentation/build/.debug \
79 ${datadir}/examples/ip_fragmentation/build/app/.debug \
80 ${datadir}/examples/ip_reassembly/build/.debug \
81 ${datadir}/examples/ip_reassembly/build/app/.debug \
82"
83FILES_${PN}-dev += "${datadir}/mk ${datadir}/scripts \
84 ${datadir}/${RTE_TARGET} \
85 ${includedir} \
86"
87FILES_${PN}-examples += "${datadir}/examples"
88
89COMPATIBLE_MACHINE = "(ls2080ardb|ls2084ardb|ls2088a|ls1043a|ls1046a|ls1088a)"