summaryrefslogtreecommitdiffstats
path: root/recipes-extended/crconf
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-05 14:09:22 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commitce845fff088da3f4bc8e4a8019e6725bd291a98b (patch)
tree5a365f71d7d644ffaa399e752f14be0b63722e05 /recipes-extended/crconf
parentcf73ff164d9b8a03b57a444d10408c7a4ed7a068 (diff)
downloadmeta-freescale-ce845fff088da3f4bc8e4a8019e6725bd291a98b.tar.gz
crconf: add recipes
include the following changes: 7b5819e - Restructure copy_name() to follow best practice 8bd9964 - Set algorithm mask only when type is provided 81bd24f - Don't overwrite compiler env. if alredy set 0248373 - Update dependencies - Linux kernel and iproute2 headers 547b464 - Fix potential segfault when omitting type argument 274eaba - Honor max length of alg/driver name in strncpy 9d0ae95 - Improve usage information 6ab1c3c - crconf: Fix error output on crconf_del_alg. d8a0a6f - crconf: Add a basic manpage 27a173f - crconf: Update headers to the Linux mainline 873058f - crconf - Linux crypto layer configuraton tool Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended/crconf')
-rw-r--r--recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch30
-rw-r--r--recipes-extended/crconf/crconf_git.bb18
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch b/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch
new file mode 100644
index 00000000..4459c370
--- /dev/null
+++ b/recipes-extended/crconf/crconf/0001-Modify-the-Makefile-for-cross-compile.patch
@@ -0,0 +1,30 @@
1From 2c260c8c437c7f72f093b6c157a38b93443bde1d Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Mon, 11 Dec 2017 15:45:05 +0800
4Subject: [PATCH] Modify the Makefile for cross compile
5
6Upstream-Status: Inappropriate [embedded specific]
7
8Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
9---
10 Makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/Makefile b/Makefile
14index c7bfee2..d6421f3 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -4,8 +4,8 @@ LIBDIR=/usr/lib
18 SBINDIR=/sbin
19 MANDIR=/share/man
20
21-CC = gcc
22-HOSTCC = gcc
23+CC ?= gcc
24+HOSTCC ?= gcc
25 CCOPTS = -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall
26 CFLAGS = $(CCOPTS) -I../include
27
28--
292.7.4
30
diff --git a/recipes-extended/crconf/crconf_git.bb b/recipes-extended/crconf/crconf_git.bb
new file mode 100644
index 00000000..7dc92776
--- /dev/null
+++ b/recipes-extended/crconf/crconf_git.bb
@@ -0,0 +1,18 @@
1SUMMARY = "crconf -Linux crypto layer configuraton tool"
2SECTION = "base"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=5;md5=0f77fc44eb5911007ae4ac9f6736e111"
5
6SRC_URI = "git://github.com/Thermi/crconf.git;protocol=https;nobranch=1"
7
8EXTRA_OEMAKE = "'CC=${CC}' 'HOSTCC=${CC}'"
9
10SRCREV = "7b5819e7638e471d41dd2dca71f012d5a022f014"
11
12S = "${WORKDIR}/git"
13
14do_install () {
15 oe_runmake install DESTDIR=${D}
16}
17
18FILES_${PN} += "/share/man/* ${libdir}/* ${sbindir}/*"