summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-11-10 15:23:18 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-11-14 14:10:38 -0200
commite9d8f4f608220f986708d4ca2bfdec55e2f680da (patch)
treeab1790d68a7d57f4eca7ae2e896558097ed880de /recipes-dpaa
parentfda4c4911f3ba2bbf0d9521c59d266023bc2bf69 (diff)
downloadmeta-freescale-e9d8f4f608220f986708d4ca2bfdec55e2f680da.tar.gz
fm-ucode: Add B variable to SOURCE parameter in install command
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa')
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
index 566a6e39..c6a5b8b7 100644
--- a/recipes-dpaa/fm-ucode/fm-ucode_git.bb
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -23,13 +23,13 @@ REGLEX_ls1043ardb = "t2080"
23do_install () { 23do_install () {
24 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'` 24 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
25 install -d ${D}/boot 25 install -d ${D}/boot
26 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/ 26 install -m 644 ${B}/fsl_fman_ucode_${UCODE}*.bin ${D}/boot/
27} 27}
28 28
29do_deploy () { 29do_deploy () {
30 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'` 30 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
31 install -d ${DEPLOYDIR}/ 31 install -d ${DEPLOYDIR}/
32 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/ 32 install -m 644 ${B}/fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}
33} 33}
34addtask deploy before do_build after do_install 34addtask deploy before do_build after do_install
35 35