diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2021-10-20 14:38:56 +0800 |
---|---|---|
committer | Hongxu Jia <hongxu.jia@windriver.com> | 2021-10-21 15:45:27 +0800 |
commit | 265c7afa5c7e1491b960e5f77132a01dd6455feb (patch) | |
tree | abdb00146e43c21b3bd3f7cfdf04f416e85a9727 /recipes-dpaa2 | |
parent | 00f062d105b7617f6503cdec7bac9eefb2628974 (diff) | |
download | meta-freescale-265c7afa5c7e1491b960e5f77132a01dd6455feb.tar.gz |
dce: fix QA Issue during usermerge
While enabling usermerge, there is a QA issue:
...
ERROR: dce-git-r0 do_package: QA Issue: dce: Files/directories were installed but not shipped in any package:
/sbin/dce-api-perf-test
/sbin/dce-example
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
...
Use Yocto base_sbindir to replace hardcode ./sbin
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r-- | recipes-dpaa2/dce/dce_git.bb | 1 | ||||
-rw-r--r-- | recipes-dpaa2/dce/files/0001-support-user-merge.patch | 31 |
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb index 24b39a0b..368e5aa6 100644 --- a/recipes-dpaa2/dce/dce_git.bb +++ b/recipes-dpaa2/dce/dce_git.bb | |||
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=956df5ea6cfe0a1dcf2dee7ca37c0cdf" | |||
5 | 5 | ||
6 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \ | 6 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \ |
7 | git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \ | 7 | git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \ |
8 | file://0001-support-user-merge.patch \ | ||
8 | " | 9 | " |
9 | SRCREV = "9db9c08379aa89f45f514f4f3f0a8e8212198758" | 10 | SRCREV = "9db9c08379aa89f45f514f4f3f0a8e8212198758" |
10 | SRCREV_qbman = "2f92993a9f34e5221d6b36c63b9e30ef703e9ac3" | 11 | SRCREV_qbman = "2f92993a9f34e5221d6b36c63b9e30ef703e9ac3" |
diff --git a/recipes-dpaa2/dce/files/0001-support-user-merge.patch b/recipes-dpaa2/dce/files/0001-support-user-merge.patch new file mode 100644 index 00000000..33b351a1 --- /dev/null +++ b/recipes-dpaa2/dce/files/0001-support-user-merge.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From d4aa7f64db5841242257c5b30dd652afd0f6ff68 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Wed, 20 Oct 2021 14:00:35 +0800 | ||
4 | Subject: [PATCH] support user merge | ||
5 | |||
6 | Use Yocto base_sbindir to replace hardcode ./sbin | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
11 | --- | ||
12 | Makefile | 3 ++- | ||
13 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/Makefile b/Makefile | ||
16 | index 62eff25..18b79b1 100644 | ||
17 | --- a/Makefile | ||
18 | +++ b/Makefile | ||
19 | @@ -25,7 +25,8 @@ CFLAGS += -fdiagnostics-color | ||
20 | |||
21 | LDFLAGS = -static -Wl,--hash-style=gnu ${EXTRA_CFLAGS} | ||
22 | |||
23 | -PREFIX = $(DESTDIR)/sbin | ||
24 | +base_sbindir ?= ./sbin | ||
25 | +PREFIX = $(DESTDIR)/${base_sbindir} | ||
26 | |||
27 | HEADER_DEPENDENCIES = $(subst .o,.d,$(OBJS)) | ||
28 | |||
29 | -- | ||
30 | 2.27.0 | ||
31 | |||