diff options
author | Ting Liu <ting.liu@nxp.com> | 2020-06-12 19:38:41 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-06-16 08:46:19 -0300 |
commit | fa1844cc2e013240b37c6964bf6dea767ef90aa2 (patch) | |
tree | 0e0b5ce21dd95c72a9c831cd6a26a60a08c87887 /recipes-dpaa2 | |
parent | 3197a0e40ff38e453fb83dd47c18f046942041e5 (diff) | |
download | meta-freescale-fa1844cc2e013240b37c6964bf6dea767ef90aa2.tar.gz |
management-complex: avoid soft link loop in do_deploy
when the deploy mc_app directory is already populated, a soft link
loop from mc.itb to mc.itb will be created.
Steps to reproduce:
$ bitbake -c cleansstate management-complex
$ bitbake management-complex
$ bitbake -c deploy -f management-complex
Use 'find -type f' to exclude links.
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.14.1.bb | 2 | ||||
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_10.20.4.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb index 52da410e..ddb305c1 100644 --- a/recipes-dpaa2/management-complex/management-complex_10.14.1.bb +++ b/recipes-dpaa2/management-complex/management-complex_10.14.1.bb | |||
@@ -25,7 +25,7 @@ do_deploy () { | |||
25 | install -d ${DEPLOYDIR}/mc_app | 25 | install -d ${DEPLOYDIR}/mc_app |
26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | 26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app |
27 | # make a symlink to the latest binary | 27 | # make a symlink to the latest binary |
28 | for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do | 28 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do |
29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | 29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb |
30 | done | 30 | done |
31 | } | 31 | } |
diff --git a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb index a687657c..3e14a26e 100644 --- a/recipes-dpaa2/management-complex/management-complex_10.20.4.bb +++ b/recipes-dpaa2/management-complex/management-complex_10.20.4.bb | |||
@@ -25,7 +25,7 @@ do_deploy () { | |||
25 | install -d ${DEPLOYDIR}/mc_app | 25 | install -d ${DEPLOYDIR}/mc_app |
26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app | 26 | install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app |
27 | # make a symlink to the latest binary | 27 | # make a symlink to the latest binary |
28 | for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do | 28 | for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do |
29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | 29 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb |
30 | done | 30 | done |
31 | } | 31 | } |