summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorZongchun Yu <zongchun.yu@nxp.com>2016-07-16 00:28:37 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-22 11:30:51 -0300
commitac8d7fb81b1108507038151f9dfcf831546c26a1 (patch)
tree33ce6bad74cf78042ad23020d7a91f4f13d0b38c /recipes-dpaa2
parent4469a2ad9ce5200a5543eeb2ce2e905f36050094 (diff)
downloadmeta-freescale-ac8d7fb81b1108507038151f9dfcf831546c26a1.tar.gz
dpl-examples: Add recipe
Signed-off-by: Zongchun Yu <zongchun.yu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/dpl-examples/dpl-examples_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
new file mode 100644
index 00000000..17296ffd
--- /dev/null
+++ b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Datapath layout examples"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
4
5DEPENDS = "dtc-native"
6
7inherit deploy
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;branch=sdk-v2.0.x"
10SRCREV = "2f8a6c2c0607b663afd69aa0477c2047f25031ca"
11
12S = "${WORKDIR}/git"
13
14do_install () {
15 install -d ${D}/boot
16 install -m 644 ${S}/ls2080a/RDB/*.dtb ${D}/boot
17}
18
19do_deploy () {
20 install -d ${DEPLOYDIR}/dpl-examples
21 install -m 644 ${S}/ls2080a/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
22}
23addtask deploy before do_build after do_install
24
25PACKAGES += "${PN}-image"
26FILES_${PN}-image += "/boot"
27
28COMPATIBLE_MACHINE = "(ls2080ardb)"