summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-07-28 15:44:11 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-08-07 11:42:29 -0300
commit15bf9e750c3bb22c3b3401f09e2bff4246dc2789 (patch)
tree2f241fb0a91241cbb63930f3373527a1e4698747 /recipes-dpaa2
parent668d4ab18581bf8c84bb276bc4a9fe77cbc1ef1e (diff)
downloadmeta-freescale-15bf9e750c3bb22c3b3401f09e2bff4246dc2789.tar.gz
mc :update to 10.2.2
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.2.2.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.1.2.bb)13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.1.2.bb b/recipes-dpaa2/management-complex/management-complex_10.2.2.bb
index e5fe33b9..a6377547 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.1.2.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.2.2.bb
@@ -6,19 +6,22 @@ inherit deploy
6 6
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8 8
9SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;nobranch=1" 9SRC_URI = "git://github.com/qoriq-open-source/mc-binary.git;nobranch=1"
10SRCREV = "10db0dfa51c8aa6308d7986355bb8b1a3a34d298" 10SRCREV = "5798f9c2ec0f3b1f2a7a67dc666c87ae3ade837b"
11 11
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14REGLEX_ls2088a = "ls2088a"
15REGLEX_ls1088a = "ls1088a"
16
14do_install () { 17do_install () {
15 install -d ${D}/boot 18 install -d ${D}/boot
16 install -m 755 ${S}/ls2080a/*.itb ${D}/boot 19 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
17} 20}
18 21
19do_deploy () { 22do_deploy () {
20 install -d ${DEPLOYDIR}/mc_app 23 install -d ${DEPLOYDIR}/mc_app
21 install -m 755 ${S}/ls2080a/*.itb ${DEPLOYDIR}/mc_app 24 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
22 # make a symlink to the latest binary 25 # make a symlink to the latest binary
23 for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do 26 for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
24 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb 27 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
@@ -31,6 +34,6 @@ FILES_${PN}-image += "/boot"
31 34
32INHIBIT_PACKAGE_STRIP = "1" 35INHIBIT_PACKAGE_STRIP = "1"
33 36
34COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a)" 37COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
35PACKAGE_ARCH = "${MACHINE_ARCH}" 38PACKAGE_ARCH = "${MACHINE_ARCH}"
36 39