summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-07-28 15:44:14 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-08-07 11:42:29 -0300
commit04600265f0404c61d863ec4f83fd3bc287170d0e (patch)
tree578911d9d72721623101e2333826583b5097b7df /recipes-dpaa2
parentbac1cb4634c31ec3ad06f3ef9e897510679e0fca (diff)
downloadmeta-freescale-04600265f0404c61d863ec4f83fd3bc287170d0e.tar.gz
aiopsl: update to 9d45f430b
*include the following changes 9d45f43 - apps: update elfs before tag 126f4f3 - firmware no.: 8.0.2 c274ff9 - aiop_apps : Soft Parser after legal review ae0be0e - apps: update elfs before tag 95a02c9 - firmware no.: 8.0.1 145ceb0 - qos demo: initial version 009a2ff - aiopsl: Wrong BPID in dedicated Storage Profile 50fc7de - fdma : Split command error when SM is 1 and PSA is 2 6d2186d - apps: update elfs before tag 84e1c4d - coverity: fix ipr, cmdif_srv f8dbc47 - firmware no.: 8.0.0 a3010f7 - aiop_apps : Soft Parser egress parse profile cbfbc79 - aiop_apps : Soft Parser onto WRIOP Parser 1c9c257 - aiop_apps : Soft parser library and global labels 39a2d7d - license: BSD 3-Clause b64df95 - aiopsl project: remove booke_irq.S 8c8e5ed - aiopsl project: remove booke_irq.S fe7bee4 - aiop_apps : Add local labels support 1d22b72 - doorbell: fix test fa3ce17 - roc_process_packet: update all lcf files 67c4e4f - aiop_apps: Add soft parser generator 8bed077 - roc_process_packet: fix project dcc52a4 - apps: update elfs before tag c7a6d4d - capwap: support for ls1088a and fixes for ls2088a 377cd42 - aiop_apps : Add Soft Parser Demo application 879da4d - aiop_apps: Add Soft Parser Disassembler and Simulator 108a467 - aiopsl : Soft Parser load and activate 8a96e38 - sNIC: TCP GRO/GSO (basic support) 23b47ff - apps: update elfs before tag c7ef6f6 - sNIC: TCP GRO/GSO (basic support) 0421606 - Merge pull request #1186 in DPAA2/aiopsl from ~R70178/aiopsl__r70178:feature/AIOPSL-1062-ipr-tmi to develop d797a26 - Merge pull request #1181 in DPAA2/aiopsl from ~R70178/aiopsl__r70178:feature/AIOPSL-1097-4G_DDR to develop b03cfb9 - mem_mng: Changes to support more than 4G DDR in aiopsl app 1e6a046 - ipr: TMI management b87a7f3 - aiopsl : Add Storage Profile driver Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/aiopsl/aiopsl_git.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-dpaa2/aiopsl/aiopsl_git.bb b/recipes-dpaa2/aiopsl/aiopsl_git.bb
index 23a5e9dc..5df26e66 100644
--- a/recipes-dpaa2/aiopsl/aiopsl_git.bb
+++ b/recipes-dpaa2/aiopsl/aiopsl_git.bb
@@ -7,17 +7,20 @@ BASEDEPENDS = ""
7 7
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10SRC_URI = "git://git.freescale.com/ppc/sdk/aiopsl.git;nobranch=1" 10SRC_URI = "git://github.com/qoriq-open-source/aiopsl.git;nobranch=1"
11SRCREV = "80f3d450896d17a3d8e10f3c6d1c224e78d32757" 11SRCREV = "9d45f430b648d49a893be8a43ef1b64c09a5b41b"
12 12
13do_configure[noexec] = "1" 13do_configure[noexec] = "1"
14do_compile[noexec] = "1" 14do_compile[noexec] = "1"
15 15
16DEMOS_PATH_ls2088a = "LS2088A"
17DEMOS_PATH_ls1088a = "LS1088A"
18
16do_install () { 19do_install () {
17 install -d ${D}/usr/aiop/bin 20 install -d ${D}/usr/aiop/bin
18 install -d ${D}/usr/aiop/scripts 21 install -d ${D}/usr/aiop/scripts
19 install -d ${D}/usr/aiop/traffic_files 22 install -d ${D}/usr/aiop/traffic_files
20 install -m 755 ${S}/demos/images/LS2088A/*.elf ${D}/usr/aiop/bin 23 install -m 755 ${S}/demos/images/${DEMOS_PATH}/*.elf ${D}/usr/aiop/bin
21 install -m 755 ${S}/misc/setup/scripts/dynamic_aiop_*.sh ${D}/usr/aiop/scripts 24 install -m 755 ${S}/misc/setup/scripts/dynamic_aiop_*.sh ${D}/usr/aiop/scripts
22 install -m 644 ${S}/misc/setup/traffic_files/classifier.pcap ${D}/usr/aiop/traffic_files 25 install -m 644 ${S}/misc/setup/traffic_files/classifier.pcap ${D}/usr/aiop/traffic_files
23} 26}
@@ -26,4 +29,4 @@ FILES_${PN} += "/usr/aiop/*"
26INSANE_SKIP_${PN} += "arch" 29INSANE_SKIP_${PN} += "arch"
27INHIBIT_PACKAGE_STRIP = "1" 30INHIBIT_PACKAGE_STRIP = "1"
28INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 31INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
29COMPATIBLE_MACHINE = "(ls2088a)" 32COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"