diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2019-01-11 03:14:21 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-01-14 16:23:38 -0200 |
commit | c03639c2e46aba90a60fd2dfd78f651bf801e933 (patch) | |
tree | bc4841a2c009285eec5283d8d792ebe0dfe7c354 /recipes-dpaa2/spc | |
parent | d1ad925be40cdc595532aab78b2867a56be0eb09 (diff) | |
download | meta-freescale-c03639c2e46aba90a60fd2dfd78f651bf801e933.tar.gz |
spc: add recipes
*update to lsdk 1812 tag
include the following changes
1a41424 - License updates
6aa1509 - Fixed Jump/Gosub instruction code
f814f3e - Updated the LX2 Parser revision
d7e3f30 - Set the blob version to 1.0
bd1b667 - Refactoring the makefile and net headers.
12b6a71 - Updates on some RA (Result Array) fields
bf1a132 - Small install updates
f45da58 - Updated Parser revisions according to platform
5799b9f - Parser IP block Rev fix for LS2
4de4651 - Add more validation and error messages and FAF names changed
b8a2630 - Blob version fix
2707f30 - Dump the blob as array of bytes in a header
0eddcd2 - Display some runtime warnings
66c1e1e - Small fix for Ubuntu: include string.h
3b8d002 - Changes around debug layers and intermediate code generation
722ebd9 - Small updates (warning message for unsupported elem and removed base proto from another SP from blob)
f486cba - VxLAN support and Blob protocols ID update
84bf344 - Small HW config file refactory: parser
5f6414c - Small fixes (prevproto type and load in AIOP)
2d37fad - Fixed protocol entry point offset in blob
58da088 - Add support to call from another SP (use: prevproto / nextproto)
9f22e3e - Add support to run SP before HW Parser (use: prevproto='none')
8852fb0 - Added configuration file
46fd66a - Added SP Parameters in Blob Generation
303354c - Added Blob Generation (initial version)
d7efad8 - Memory map update for DPAA2
33af4c3 - HXS PDL update with new protocols
c9e07ee - Fixed checksum calculation
e686771 - Adding RA_GPR1 utility functions
8831a9c - FAF update according to Parser_Block_Guide_03.106
40c8e02 - Refactory the set faf high level xml instruction
8eb61a6 - Added support for FAF and new protocols
21dba55 - Added command to generate intermediate code
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-dpaa2/spc')
-rw-r--r-- | recipes-dpaa2/spc/spc_git.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-dpaa2/spc/spc_git.bb b/recipes-dpaa2/spc/spc_git.bb new file mode 100644 index 00000000..eceabf91 --- /dev/null +++ b/recipes-dpaa2/spc/spc_git.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "Soft Parser Configuration tool" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=163b09a1c249a6ff2b28da1ceca2e0a8" | ||
4 | |||
5 | DEPENDS = "libxml2 fmlib tclap" | ||
6 | |||
7 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/spc;nobranch=1" | ||
8 | SRCREV = "1a414247ad3228bf60bfb53995a28930a8a29acc" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \ | ||
13 | FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \ | ||
14 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' | ||
15 | EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \ | ||
16 | FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \ | ||
17 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' | ||
18 | |||
19 | EXTRA_OEMAKE_PLATFORM ?= "" | ||
20 | |||
21 | do_compile () { | ||
22 | oe_runmake -C source | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -d ${D}/${bindir} | ||
27 | install -m 755 ${S}/source/spc ${D}/${bindir} | ||
28 | |||
29 | install -d ${D}${sysconfdir}/spc/config | ||
30 | install -m 644 ${S}${sysconfdir}/spc/config/* ${D}${sysconfdir}/spc/config | ||
31 | |||
32 | } | ||
33 | |||
34 | PARALLEL_MAKE = "" | ||
35 | |||
36 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
37 | |||
38 | COMPATIBLE_MACHINE = "(qoriq-arm64)" | ||