diff options
author | Zongchun Yu <zongchun.yu@nxp.com> | 2016-07-16 00:28:40 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-22 11:30:51 -0300 |
commit | 8577e585108e0650566740a03118bbc5c3038231 (patch) | |
tree | 721e72ddfb8798a5e20b4c59daad8531c2b87977 /recipes-dpaa2/management-complex | |
parent | e33faea587752329cdaa4643155a5a0e24f35938 (diff) | |
download | meta-freescale-8577e585108e0650566740a03118bbc5c3038231.tar.gz |
management-complex: Add recipe
Signed-off-by: Zongchun Yu <zongchun.yu@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa2/management-complex')
-rw-r--r-- | recipes-dpaa2/management-complex/management-complex_0.8.4.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_0.8.4.bb b/recipes-dpaa2/management-complex/management-complex_0.8.4.bb new file mode 100644 index 00000000..924a5735 --- /dev/null +++ b/recipes-dpaa2/management-complex/management-complex_0.8.4.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "DPAA2 Management Complex Firmware" | ||
2 | LICENSE = "Freescale-Binary-EULA" | ||
3 | LIC_FILES_CHKSUM = "file://Freescale-Binary-EULA;md5=da89ad557c4a497fb005e76c2600cda3" | ||
4 | |||
5 | inherit deploy | ||
6 | |||
7 | INHIBIT_DEFAULT_DEPS = "1" | ||
8 | |||
9 | SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;branch=sdk-v2.0.x" | ||
10 | SRCREV = "40e7cc7bfc9b35488394450605d649cb7073051a" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | do_install () { | ||
15 | install -d ${D}/boot | ||
16 | install -m 755 ${S}/ls2080a/*.itb ${D}/boot | ||
17 | } | ||
18 | |||
19 | do_deploy () { | ||
20 | install -d ${DEPLOYDIR}/mc_app | ||
21 | install -m 755 ${S}/ls2080a/*.itb ${DEPLOYDIR}/mc_app | ||
22 | # make a symlink to the latest binary | ||
23 | for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do | ||
24 | ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb | ||
25 | done | ||
26 | } | ||
27 | addtask deploy before do_build after do_install | ||
28 | |||
29 | PACKAGES += "${PN}-image" | ||
30 | FILES_${PN}-image += "/boot" | ||
31 | |||
32 | INHIBIT_PACKAGE_STRIP = "1" | ||
33 | COMPATIBLE_MACHINE = "(ls2080ardb)" | ||